PrusaConnect print jobs display error
 
Notifications
Clear all

PrusaConnect print jobs display error  

Page 2 / 2
  RSS
sto
 sto
(@sto-2)
Eminent Member
RE: PrusaConnect print jobs display error

More investigation:

  • PrusaLink displays the proper info about the print, even though PrusaConnect does not.
  • Only 354MB used on the USB thumb drive (the stock one that shipped with the printer).
  • 58 total file items at the root.

I tried reducing the number of files at the root of the USB stick, and shortening some file names that appeared unreasonably long, then I tried sending another job from PrusaSlicer, and I noticed something interesting:

PrusaConnect still showed the file as being transferred whereas the printer actually started printing. Once PrusaConnect updated, it, again, showed incomplete job info ("Print job #52").

Is it possible that when PrusaConnect registers the new job, it is incapable of linking it to the file, because it was unable to find it?


I also found this unrelated bug: the date displayed in PrusaConnect seems to be based on incorrect timezone calculations: I just renamed files on the USB drive, and when I plugged it back into the printer, PrusaConnect showed some file dates as "tomorrow". To be exact, 9 hours later than the actual time I made the modification. Relatedly, I live in Japan, which timezone is UTC+9.

 

 

Posted : 05/05/2024 2:31 pm
mAyty
(@mayty)
Active Member
Topic starter answered:
RE: PrusaConnect print jobs display error

Formatting the USB drive fixed the issue for me

Posted : 05/05/2024 4:20 pm
sto
 sto
(@sto-2)
Eminent Member
RE: PrusaConnect print jobs display error

Indeed. I just started a job on a freshly formatted USB drive (MBR/MS-DOS on macOS' Disk Utility) and PrusaConnnect shows the right thing. 👍🏻

Next I'll try restoring the files I had on the stick, to see if the problem was caused by the files names/amount/size, or some kind of memory corruption.

Still weird that it'd happen to so many people around the same time... 🤔

Posted : 06/05/2024 1:11 am
reconbot
(@reconbot)
Member
RE: PrusaConnect print jobs display error

My last 3 prints are working normally again without doing anything to anything. Good to know about the formatting trick.

Posted : 06/05/2024 1:34 am
McBig
(@mcbig)
Member
RE: PrusaConnect print jobs display error

Thank you a lot! It looks that we have enough data. As i did some introspection there are two problems, one in Firmware one in Connect. We are working on fix. Please stay tuned.

Posted : 06/05/2024 7:15 am
Luca, sto and mAyty liked
sto
 sto
(@sto-2)
Eminent Member
RE: PrusaConnect print jobs display error

I restored the Gcode files I had on the USB drive before formatting it, and the bug is back.

@mcbig it would be nice if, while waiting for a fix, you could tell us what needs to be avoided to prevent the bug.

Is it the number of files on the USB drive? Total size? File names/length?

Posted : 06/05/2024 10:31 am
REB
 REB
(@reb-2)
Member
RE: PrusaConnect print jobs display error

Is this issue anywhere near to being fixed? It's become really annoying now. Sometimes I get the right details for a job (#31) whilst others just display the job number with no printing details (#30 & #32)

Posted : 08/05/2024 12:41 pm
sto
 sto
(@sto-2)
Eminent Member
RE: PrusaConnect print jobs display error

Am I seeing a fix on PrusaConnect? 🎉

Looks like the job I just started displays correctly, whereas the one I started 3 hours ago did not.

Posted : 08/05/2024 3:02 pm
REB
 REB
(@reb-2)
Member
RE: PrusaConnect print jobs display error

Not fixed here with a print started at 19:04. Still showing job numbers and adding a duplicate file to print queue.

Posted : 08/05/2024 6:08 pm
reconbot
(@reconbot)
Member
RE: PrusaConnect print jobs display error

Mine's back to not working well. So it goes. @mcbig give us more details! 🍿

Posted : 10/05/2024 3:32 am
Burve
(@burve)
Active Member
RE: PrusaConnect print jobs display error

It was not printing for a few days, had zero in Queue, and the printer was turned off. Just started a print via Queue and got Print job #145

Before that, it was a little random for a while, so it is definitely a mess on the website side of the whole construction 🙁

Posted : 10/05/2024 1:56 pm
Sarka
(@sarka)
Member
RE: PrusaConnect print jobs display error

Hi, there was a small bug fix deployed to the production yesterday. As the bug was not reproducible on our side, could you please test if it helped with the job x file not matching problem? Thanks a lot.

Posted : 14/05/2024 11:42 am
sto
 sto
(@sto-2)
Eminent Member
RE: PrusaConnect print jobs display error

Hey @sarka!

Here's what I just did:

  • Update my MK4 to 6.0.1 firmware. (Printer rebooted, AFAIK.)
  • No job left in PrusaConnect's queue.
  • Send a job from PrusaSlicer 2.7.4. ("Upload and Print")

The job first showed as "Job #xxx" for a few seconds, but then it shows properly, with the right file name, thumbnail etc.

To me, seems to be fixed.

Posted : 19/05/2024 7:31 am
sto
 sto
(@sto-2)
Eminent Member
RE: PrusaConnect print jobs display error

Oh, here's something that seems to be broken, compared to older behaviour (I think).

PrusaConnect's notifications show "MK4: file #66 is printing", with no proper thumbnail, whereas it used to show proper filename and thumbnail.

Posted : 19/05/2024 7:47 am
Page 2 / 2
Share: