Clear all

Building Prusa mini firmware failed  

New Member
Building Prusa mini firmware failed

I'm trying to build the prusa mini firmware but I have had no luck so far. I am following the guide found at '':

I have installed Python 3.9.1 with pip, then I do a:

git clone --recurse  -b RELEASE-4.3.1
Followed by:

S:\Python39\Prusa\Prusa-Firmware-Buddy>python utils/
Downloading ninja-1.9.0
Extracting ninja-1.9.0
Downloading cmake-3.15.5
Extracting cmake-3.15.5
Downloading gcc-arm-none-eabi-7.3.1
Extracting gcc-arm-none-eabi-7.3.1
Downloading clang-format-9.0.0-noext
Extracting clang-format-9.0.0-noext
Downloading bootloader-mini-1.0.0
Extracting bootloader-mini-1.0.0
Building mini_release_noboot
Building mini_release_emptyboot
Building mini_release_boot

Building finished: 0 success, 3 failure(s).
mini_release_noboot project configuration FAILED
mini_release_emptyboot project configuration FAILED
mini_release_boot project configuration FAILED

Have tried this with both modified and unmodified versions of release 4.3.1 and release 4.2.0, and the result is the same - anyone who can tell me what I'm doing wrong?

Posted : 17/02/2021 8:05 pm
Estimable Member
RE: Building Prusa mini firmware failed

check under build\some_name\CMakefiles\CmakeError.log and CmakeOutput.log

there you could find the failure reason

Posted : 18/02/2021 12:32 am
New Member
Topic starter answered:
RE: Building Prusa mini firmware failed

Many thanks, looked through the files there and it seems like the problem was that I had 64bit Python installed and the commands tried to call 32bit Python. Might have been able to fix it in another way, but installing 32bit Python sorted it.

Posted : 18/02/2021 6:44 pm