First power up, Screen will not power on, 5v bus cycling?
 
Notifications
Clear all

First power up, Screen will not power on, 5v bus cycling?  

  RSS
maxfagin
(@maxfagin)
Member
First power up, Screen will not power on, 5v bus cycling?

On first power up, the screen didn’t turn on. I checked the electronics bay, and the every ~8 seconds, the 5V LED was coming on, staying on for <1 second, then turning off. Checked the 24V bus with a multimeter, and it is powered and stable. I’m worried I may have pinched a wire and caused a short somewhere, but before I check all of those, any other suggestions?

Posted : 03/12/2023 7:23 pm
maxfagin
(@maxfagin)
Member
Topic starter answered:
RE:

Here is the LED cycling after startup

https://storage.googleapis.com/prusa3d-content-prod-14e8-wordpress-forum-prod/2023/12/2ec3bb3b-20231203_110257.mp4

 

Posted : 03/12/2023 9:16 pm
Hello
(@hello)
Noble Member
RE: First power up, Screen will not power on, 5v bus cycling?

Best way to find out is unplug all but screen the plug in 1 by 1

Posted by: @maxfagin

Here is the LED cycling after startup

https://storage.googleapis.com/prusa3d-content-prod-14e8-wordpress-forum-prod/2023/12/2ec3bb3b-20231203_110257.mp4

 

 

Please help me out by downloading a model it's free and easy but really helps me out https://www.printables.com/@Hello_474427/models

Posted : 04/12/2023 5:02 am
maxfagin
(@maxfagin)
Member
Topic starter answered:
RE: First power up, Screen will not power on, 5v bus cycling?

Issue resolved. It turned out to be a faulty LCD screen. Prusa sent a replacement, and the printer is now working correctly!

Posted : 20/12/2023 2:40 am
Share: