Notifications
Clear all

Prusa Slicer - wipe tower issues  

  RSS
MysticGringo
(@mysticgringo)
Trusted Member
Prusa Slicer - wipe tower issues

Hi...

I have a few annoying issues that aren't show stoppers, but adds steps to my workflow, and frankly annoy me.

1. I want the wipe tower to stay put when I hit the arrange button. I like it in the default part of the bed and it's frustrating when arrange moves it to the center part of the print area. Anyway to lock it in location in respect to the arrange function?

2. If I print something with a "label" using 2 colors, white writing on a black object for example, the slicer won't build the tower the whole way, yet it will cause a purge at the very top of the object. Is there a way to stop this purge that ends up in mid-air? I can show a screen capture from the sliver if it's not clear what I am saying. The "no sparse layers" actually exasperates the problem.

3. Is there a way to make it print the tower base first before it prints the object. The reason for this is if my last print ended with black or red filament, but this new print starts with white, I want the color purged out before starting the white. I have set up a "white" filament with extra purging, but the slicer tells it to print the object first, and not the tower, so there is no extra purge to start with for the white. My work around is to add a skirt to ensure it purges the color from the nozzle.

If nobody has good solutions I will likely add these to GitHub so developers can see it.

Thanks.

Posted : 19/06/2024 12:24 pm
Antimix
(@antimix)
Reputable Member
RE: Prusa Slicer - wipe tower issues

@mysticgringo Hi,

regarding POINT 3 I don't have this behaviour. I just tried to slice a PRUSA keychain. PrusaSlicer set the change colour automatically.

Then it started with the initial purge line, and then it started the tower to ensure the colour is pure.

Then it moved to start to print the object. When it finished the plate, it went to the tower, removed the filament, purged the material in the tower structure not on the air, and then continued normally to finish the label letters.

keep in mind that all the filament handling is fully automatic through MMU3, there is no interaction with the LCD panel.

All the filament colours should be preloaded on the buffer box and on the MMU3 tubes before printing, and the filament colour order should be the same in the corresponding Extruder x colour filaments in PrusaSlicer before slicing.

Ensure to have set Original Prusa MKx MMU3 0.4 Nozzle in print settings.

 

Posted : 20/06/2024 10:40 pm
MysticGringo
(@mysticgringo)
Trusted Member
Topic starter answered:
RE: Prusa Slicer - wipe tower issues

Hey Antimix...

Thanks for pointing this out... it does appear to work as expected. I know there was a time it did not, I am searching for a gcode that shows it. I think this may have been for when I was acting as a manual MMU or on a slicer prior to the latest. For all the other concerns with the buffer, the profile, etc, I am pretty aware of those, I had an MK3 with MMU2 for years prior, so no worries there.

In regard to it purging in mid air, here's a photo from a recent print that shows the purge. It's acted like this for many years, and I have just lived with it... but I don't think it's a good way to do things.

Posted : 21/06/2024 11:57 am
MysticGringo
(@mysticgringo)
Trusted Member
Topic starter answered:
RE: Prusa Slicer - wipe tower issues

Found one...

Here are two photos from an older print that basically is just to prove I am not crazy. The first photo you can see the nozzle position is on the white writing, and second photo you can see the base of the wipe tower, which would have been visible in the first image too.

 

So I wasn't going crazy, but yes, they have fixed this issue.

Posted : 21/06/2024 12:15 pm
Antimix
(@antimix)
Reputable Member
RISPONDI: Prusa Slicer - wipe tower issues

@MysticGringo Nobody though you were crazy 😉  The gcode produced by version of PrusaSlicer sometime had glitches.

As example,  some days ago I read on a PrusaSlicer guide that the gcode viewer sometimes shows  ramming as line in the air... 😆 

Still now I realized that is thanks to the huge purge of the initial line on the new PrusaSlicer, that I did not fail some mono colour prints on the MMU3, since there was a different colour residue in the nozzle from the old print, but since it did not build a waste tower, he just did not purge the old colour and started immediately to print. Luckily the initial line was enough to purge the residual of the old colour.

Regards

Posted : 22/06/2024 6:16 pm
MysticGringo
(@mysticgringo)
Trusted Member
Topic starter answered:
RE:

Hey Antimix (or anybody else) would you mind trying to slice this file and see what it puts down first, the writing, or the wipe tower? I just did this one today and it out the lettering down first, and then the wipe tower.

(ugh, if I can figure out how to attach the file).

Thanks.

This post was modified 5 days ago by MysticGringo
Posted : 09/07/2024 2:16 pm
Antimix
(@antimix)
Reputable Member
RE: Prusa Slicer - wipe tower issues

@MysticGringo Hello, I sliced it and all seems normal to me.

It starts normally with the first colour, then it purge, then complete the first layer with the second colour, and then since the colour is the same, it completes the object.

- Did you encounter any issue ?

NOTE: My MK4 has no MMU3. The MMU3 is installed on the MK3.5. However I used all the settings in your file without any change, I just sliced, and there were no problems.

Regards

 

Posted : 09/07/2024 4:57 pm
Antimix
(@antimix)
Reputable Member
RE:

@MysticGringo I realized what you mean 😧 and I spent last two hours trying to figure how to justify the behaviour.

Basically I noticed that your project starts the initial purge line, and without a wipe tower , immediately prints the text object (if you did not had the right colour in the nozzle, then good luck, with colour mesh.... ). It starts immediately the orange text, and then it creates the wipe tower when it is time to print the rectangle of the different colour (yellow lines).

I was not able to force a wipe tower before the text object. No way. 😫 

BUT

I have exactly the same thing, a demo Prusa keychain that I have created time ago, and it automagically starts always creating the wipe tower first and then the object.😣  But if I try to add one of your object, then your object is printed without wipe tower.

You will find attached the DEMO Keychain project and you will see that it always creates the Wipe tower and purge the colour before starting the object.

At the moment I can't figure how I did .... 🤔 

Regards

 

This post was modified 5 days ago by Antimix
Posted : 09/07/2024 7:39 pm
MysticGringo
(@mysticgringo)
Trusted Member
Topic starter answered:
RE: Prusa Slicer - wipe tower issues

Hey Antimix...

Thanks for trying it, and for figuring out what my issue was, I guess I could have been clearer.

For every other print I've done, it works as expected the wipe tower first to purge the nozzle, and then print the object. I've tested it with numerous copies of this object thinking it was volume of filament that might trigger the purge, and even with 30 copies of the object it still won't do the wipe tower first. I even changed the purge volumes, and it still did not make the wipe tower first.

So... it's obviously a bug. Guess I'm off to Github with these issues.

Thanks for trying it, and for confirming my findings.

Posted : 10/07/2024 11:30 am
Share: