Clear all

Filament stops feeding during load  

Eminent Member
Filament stops feeding during load

I've had great success for many months with my MMU2S based on what I did and documented (…/Prusa-MMU2S-Reliability-Modifications… ), however, I am now having an issue I could use help with.

After the selector moves to the correct position, it will often times load the filament to the point of making the FINDA trigger, but then it stops. Other times it pushes it a few cm into the guide tube and then stops and then other times it just works and pushes all the way to the extruder.

It is NOT the FINDA steel ball - it is calibrated perfectly and confirmed by watching the sensor statuses under the Support menu. Also, all the pathways are clear and there is no slipping of the feed gears. Basically it pushes so far and then just literally stops.

It feels like something electronic or fw wise. I had been on the latest FW and even recently updated to the most recent and it still acts the same. I have replaced the MMU2S control board with a brand new one and that did not fix it.

I have a FINDA on order to try replacing that and am hoping that is it, because at this point I don't know what else it could be, although I'm suspect of this because the Sensors menu option shows the FINDA triggered when their is filament under the steel ball and shows not triggered when no filament is in there.

Any one else experience this? Help please ...

Posted : 04/06/2020 6:09 pm
Reputable Member
RE: Filament stops feeding during load


Did you check the status of the filament sensor in the extruder chimney ?

If it is triggered, it would stop the filament like you described. 

If it is showing as a 1 with no filament, you will need to readjust the filament sensor.

Posted : 04/06/2020 9:19 pm
Eminent Member
Topic starter answered:
RE: Filament stops feeding during load


I had checked that and it was normal (zero) during loading, HOWEVER, based on a similar suggestion, I took the chimney apart anyway because I agree that it sounded suspect.  I straightened the wires from the sensor connector, wiggled some things, put it all back together and it started acting ok.  I guess I also had tightened the power cables going from the MMU2S to the MK3S (although they ended up not being loose).

After doing this it did start acting ok - I had one successful MMU2S print this morning and when I get home tonight I hope to see a second one, so maybe that was it.

I appreciate the reply.

Posted : 05/06/2020 7:28 pm
Active Member
RE: Filament stops feeding during load

I had a lot of issues getting my MMU to print correctly so put it on the back burner until the latest firmware 3.9.0. I setup again but the whole loading system just doesn't work for me. I changed it around so that the filament flows directly into the MMU extruder rather than through the cartridge and found it worked a lot better. The first print was perfect. Upon trying to load the first filament back in the filament wouldn't feed all the way through. I discovered a fine powder in the gears produced by slipping of the previous filament. Once cleaned it worked.

However, since updating the firmware, when the print starts, just before the text lines are printed, the nozzle goes down to 0.2mm above the surface then starts pushing out filament. It appears to be too close to the surface as you can hear the filament popping as it's forced out. Is this normal?

Posted : 08/06/2020 8:53 pm