Clear all

Printer not moving up Z since update  

New Member
Printer not moving up Z since update
I am trying to print some masks for a nursing home.  I hooked up and tested my printer with a couple of designs.  They printed well.  I downloaded a mask design, sliced and exported, and before printing, the printer said there was a firmware update.  So, I updated the firmware and software/drivers for good measure.
Since then, I can't get anything to print.  The printer runs around the design, but never rises above the first level.  It keeps dragging the head around at the first level.  I thought it might be the new design, so I tried one of the older gcodes I had just test printed and they do the same.
I ran autohome, xyz calibration, z calibration, first layer calibration, replaced the nozzle, ran them all again.  I can't find the problem.  There is no problem with the z-axis.  It moves up and down during testing and other operations normally.
I downgraded the firmware by flashing 3.8.0 (down from 3.8.1).
None of these fix the problem.It just keeps printing without moving up Z.  I would really appreciate some help.  I'd like to print these masks for brave nursing home staff.
Posted : 08/04/2020 11:43 pm
Peter M
Noble Member
RE: Printer not moving up Z since update

Did you use the correct firmware, for your printer model?

Search forum how to reset the settings inside the printer, so you are 100% safe that the old calibration setting are gone.

And there is no reason to update the printer if everything works, is not needed.

Posted : 09/04/2020 10:17 am
New Member
Topic starter answered:
RE: Printer not moving up Z since update

I have an I3 MK3 which I had some upgrades done to so it is a MK3S.  I am using the correct firmware.

I had some SERIOUS calibration problems which Prusa spent over 8 hours trying to diagnose and sending me replacement 2 replacement PINDAs for.  Prusa was unable to fix it so I had to pay a local 3d printer repair shop to reset everything.  They informed me that the problem was not a calibration issue then.  So, I am concerned that if I reset everything now, I will wind up back where I started with a printer that won't even pass calibration tests and I will have to pay them again to fix the firmware.

This is why I have not reset the printer.  I am concerned it will revert to its previous state where it fails Z-axis calibration tests.  I will do it if nothing else works, but I am not there yet.

I will remember the 'no reason to update' advice in the future, though it is not helping me now.

Thanks for your reply, but I am hoping someone has seen this problem and knows specifically what the cause is.  The print keeps printing on the first level and never rises.

Posted : 09/04/2020 1:24 pm
RE: Printer not moving up Z since update

when the printer is turned on, and at rest. 

press and hold the knob for about 3 seconds, 

does the display change to 

Z:            +0.0

if so, does rotating the control knob Clockwise cause the printer to raise the extruder? 

regards Joan

I try to make safe suggestions,You should understand the context and ensure you are happy that they are safe before attempting to apply my suggestions, what you do, is YOUR responsibility. Location Halifax UK

Posted : 09/04/2020 1:37 pm