Clear all

Printer Crashing and Freezing Mid-Print  

New Member
Printer Crashing and Freezing Mid-Print

Hi, I'm hoping you can help because I'm unable to get my i3 MK3S MMU2S working reliably.

Ignoring issues with bed adhesion and MMU filament selection reliability, things I can probably be able to fix in isolation, I'm having regular but random crashes of various forms.

Originally I flashed the latest firmware (3.8.1) during my build and I didn't notice any crashes (for a couple of weeks), but this may be because issues with MMU (fixed by better calibration of the extruder filament sensor) were meaning I never made enough individual or long enough prints to notice this. (though I did print a section of chainmail for 13 hours without issue)

I then started experiencing soft resents of my MK3S when trying to print specific GCODE files on my SD card, I tried re-flashing the firmware latest, but this didn't fix anything.

I week or so later and it seemed to be not crashing consistently on files anymore, more at random, I'd try to print files that had always crashed and on a 3rd attempt they may print, but also files that printed fine first time may crash the printer now. During this I also started to experience mid-print freezes, where the extruder will stop moving at a seemingly random point in the print, it will remain heated, the print progress will still show (and not change) on the LCD, pausing and resuming the print doesn’t have any effect, stopping the print looks to work fine with no print failures logged after the fact, but trying to re-print the file straight away leads to my board rebooting like with the previous bug.

Note: this is all when printing from SD card, generally using Prusa PETG or PLA profile and the Prusa i3 MK3S MMU2S Single printer profile, though I'm tweaking settings like retraction length.

To troubleshoot I tried different SD cards (including a brand new SanDisk 32 GB A2 rated one) and did a full (not quick) reformat of each with no noticeable result. I also re-seated all cables on the Einsy board and LCD unit, unplugged my Octoprint Raspberry Pi (I hadn't been using that for control at this stage).

I eventually downgraded the firmware to 3.8.0, which seemed to work fine, with the exception of it complaining there's a firmware update every time I printed.

I then started using OctoPrint to control the unit, initially it worked flawlessly on a 6.5 hour print and many smaller prints, but then on a smaller print (about an hour) the MK3S crashed with the screen showing symbols and ending "? SEC_LANG" (this message was the same when it failed), this showed as a disconnection from OctoPrint. Looking online this suggested I may need to update the firmware, which I did, then on a 2 hour print I got a similar mid-print crash, but the LCD shows nothing but symbols now.

I'm getting to the point now that I feel searching randomly through the forums is just delaying me and you guys may be able to get me running quicker. (I need to re-test printing for SD with the new firmware again and I'm tempted to manually upload firmware from source, but that's not something I'm looking forward to doing)

The thing that’s franking frustrating me is how it feels like my printer is actively fighting me, no sooner then I fix one issue develops a totally different one before I even get a chance to use it.

For reference my OctoPrint is running on a Raspberry Pi 3 via the GPIO pin serial, my current firmware is MK3S: 3.8.1-2869 (Einsy_10a), MMU: 1.0.6-372.

Any help is much appreciated.

Posted : 25/02/2020 6:19 pm
New Member
RE: Printer Crashing and Freezing Mid-Print

Did you ever find a fix for this? I currently have the same problem with my MK3S and it is frustrating me beyond the moon.

Thanks in advance

Posted : 08/06/2022 12:21 pm