Input Shaper with Klipper Testprint
 
Notifications
Clear all

Input Shaper with Klipper Testprint  

Page 3 / 3
  RSS
Rainer
(@rainer-2)
Reputable Member
Topic starter answered:
RE: Input Shaper with Klipper Testprint

This looks somehow like a mechanical cause. Belt tension oK? The pully is in the correct position?

I had it once similar but I have not tried different speeds. I have disassembled the Y-axis belt, bearings and pully. And mounted everything according to the instructions. The belt rather a little too tight. Since then it is gone.

Posted : 28/10/2023 2:34 pm
Punished Brains
(@punished-brains)
New Member
RE: Input Shaper with Klipper Testprint

Yes I checked the belt tension and also changed that to tighter and looser. I'll double check the pully, but I also ordered some replacement bearings just in case. Thanks for the tips, I'll let you know what comes out.

Posted : 28/10/2023 3:10 pm
Razor
(@razor)
Estimable Member
RE: Input Shaper with Klipper Testprint

 

Posted by: @rainer-2

I have 2 GCode for the MK4 high with PLA and PETG.

It is used to measure the resonance.

In this video everything is explained in detail.

Here you can simply enter your measurement and get the frequencies calculated.

Simply post the results here. Would be a contribution to show the effects of input shaper

Thanks for this post this explains a lot. To be honest I had the same view of some of the other people as to what the input shaper was and how it worked. I too thought you needed a sensor on the head for it to work. I think Prusa could have done a better job presenting this feature.

Mini+MK3S+XL 5 Tool

Posted : 15/12/2023 5:47 am
Klausn
(@klausn)
Active Member
RE: Input Shaper with Klipper Testprint

X = 35.15
Y = 42.73

Posted : 18/04/2024 10:32 am
Paxer
(@paxer)
Active Member
RE: Input Shaper with Klipper Testprint

How are you sending the gcode commands to the printer and gettting the response? I have been trying to find a way to do that on the mk4 for a while.

Posted : 28/04/2024 1:04 pm
Lucid
(@lucid)
Member
RE: Input Shaper with Klipper Testprint

You can add gcode commands to your gcode file as it is generating within PrusaSlicer; Under the Printer Settings Tab; there is a left panel for Custom G-code.

Posted : 29/04/2024 12:03 am
slowdude
(@slowdude)
Member
RE:

The test worked great and I decided I want to apply the following shaper values.  Unfortunately I don't think the values are applying while printing.  I'm on firmware 6.0.0 (release, not alpha/beta)

M593 Y T2 F42.8788

M593 X T2 F41.2121

M500  (tried with and without this)

 

I also tried with and without T2 in the M593 lines.

I put this in the Start G-Code section in prusaslicer, exported the gcode and did see my change in the file.  

 

The print ends up looking like the default values are still in use.  The Tuning->Input Shaping page while printing still show the default values.  

 

Any suggestions?

This post was modified 2 weeks ago by slowdude
Posted : 07/05/2024 3:54 pm
slowdude
(@slowdude)
Member
RE: Input Shaper with Klipper Testprint

Interesting additional point here.  Trying it in Octoprint I put the M593 commands in via terminal.  I sent:

M593 Y F42.8

and in the terminal I saw

Send: N1033 M593 Y F42.8*18

[...]

Recv: ok

 

What's the *18 for?

Posted : 07/05/2024 5:10 pm
Filmmax
(@filmmax)
Member
RE: Input Shaper with Klipper Testprint

Hi, try
M593 W instead of M500

buddy-firmware-specific-g-code-commands
"W<1>: Write current input shaper settings to EEPROM."

 

Posted by: @slowdude

The test worked great and I decided I want to apply the following shaper values.  Unfortunately I don't think the values are applying while printing.  I'm on firmware 6.0.0 (release, not alpha/beta)

M593 Y T2 F42.8788

M593 X T2 F41.2121

M500  (tried with and without this)

 

I also tried with and without T2 in the M593 lines.

I put this in the Start G-Code section in prusaslicer, exported the gcode and did see my change in the file.  

 

The print ends up looking like the default values are still in use.  The Tuning->Input Shaping page while printing still show the default values.  

 

Any suggestions?

 

Posted : 08/05/2024 11:15 am
slowdude
(@slowdude)
Member
RE: Input Shaper with Klipper Testprint

I did.

Posted : 08/05/2024 10:11 pm
slowdude
(@slowdude)
Member
RE: Input Shaper with Klipper Testprint

I chatted Prusa support, they said to email the firmware team.  I emailed and didn't receive a response.

M593 doesn't seem to do anything on my prints when configured via PrusaSlicer.  But the ringing tower test seemed to work fine.  Is there some other command I'm missing?  

Posted : 15/05/2024 3:12 pm
Page 3 / 3
Share: