Max feedrate, acceleration, etc for stealth mode
 
Notifications
Clear all

Max feedrate, acceleration, etc for stealth mode  

  RSS
lukas.w2
(@lukas-w2)
New Member
Max feedrate, acceleration, etc for stealth mode

Hello,

I am trying to solve an issue i've run into with layer shifts happening on fast y-axis travel moves when using stealth mode.

When playing around with the machine limits for stealth mode I realized that those values don't seem to show up in the generated gcode, hence are not having an effect on the behavior of the printer.
Am I missing something? How do I tell the printer to move slower in stealth mode?

(I am printing via gcode upload to octoprint on a raspberryPi Zero directly connected to a mk3s.)

I apologize in advance, should I be missing something obvious here.

Greetings from northern Germany,
Lukas

Posted : 29/01/2020 10:14 am
vasily.kiniv
(@vasily-kiniv)
New Member
RE: Max feedrate, acceleration, etc for stealth mode

I'm having the same issue. The same behaviour when printing directly from SD card. I was trying to limit printer to 20mm/s in stealth mode, so I'll have near silent operation overnight using stealth mode, but also have ability to change mode to normal(200mm/s) during a day to speed things up.

 

P.S. when I set machine limits to 20mm/s for both modes, it's working as expected - printer does not move faster than 20mm/s.

This post was modified 2 years ago by vasily.kiniv
Posted : 13/07/2020 11:34 pm
Neophyl
(@neophyl)
Famed Member
RE: Max feedrate, acceleration, etc for stealth mode

Stealth mode doesnt actually directly move slower.  When the printer is put into stealth mode it uses the acceleration and speed settings from the stealth section in the firmware (which match those in stealth section of Printer Config of Prusa Slicer).  As such it wont get up to the same speeds as the acceleration is lower as well as the firmware limited top speeds.  Stealth mode also does some stuff with drive currents etc which I think is why the crash detection cant work.

If you want it quieter overnight then as well as doing the change to Stealth you can also dial the speed back using the printers rotary encoder.  This can be done in any mode and is a normal part of its function.  Just dial it back to something quiet enough for you and then in the morning if its still printing dial it back up to 100%

Posted : 14/07/2020 6:45 am
vasily.kiniv
(@vasily-kiniv)
New Member
RE: Max feedrate, acceleration, etc for stealth mode

I understand the concept behind stealth mode - it’s not related to speed, it’s an another way to drive the motors, which affects sound produced by the motors and not the actual movement distance or speed of the axis.

 

I’d love to be able to use speed dial, but there is two issues with it:

- you can’t set speed to lower than 20%(for example, travel speed is 180 mm/s * 20% = 36 mm/s);

- tuning the speed dial makes slower the moves that should not be affected. For example first layer speed is 20 mm/s which is already below the limit, no need to lower it to 4 mm/s.

 

I also tried to tune speeds in “Print Settings” tab, and it sort of working, but the problem with that approach is that in some cases(for example wipe tower movements when printing with MMU2S) printer still ignores speed settings and goes full blast, even though I checked every single speed option and lowered all acceleration options.

After that I found only one working solution - setting maximum feedrates in Printer Settings->Machine limits. I set maximum feedrate for X and Y axis to 20 mm/s and that’s working well, my only remaining issue, is that I can’t make it back to full speed by switching to normal mode while printing. But I believe that it should work because Prusa Slicer have separate “Maximum feedrate” settings each mode, there is two columns - “Normal” and “Stealth”.

 

When the printer is put into stealth mode it uses the acceleration and speed settings from the stealth section in the firmware (which match those in stealth section of Printer Config of Prusa Slicer).

But it does not ignore machine limits settings when I print file in Stealth mode sliced with the same 20 mm/s limit for both modes, it only ignores it when I set 20 mm/s limit only for Stealth and leave Normal at 200 mm/s.

 

These settings works, but won't let you switch to normal 200 mm/s on the fly.

 

 

These should let you switch back to 200 mm/s by switching to Normal during print, but instead it does not limit speed even in Stealth.

 

Thanks for the help!

Posted : 14/07/2020 8:00 am
Share: