Notifications
Clear all

Holes for magnets disappear  

  RSS
henkjan_nl
(@henkjan_nl)
New Member
Holes for magnets disappear

Hi,

I have a part with internal cavities in which I want to insert magnets during printing.

  1. When I import the part as a STEP file in PrusaSlicer 2.7.1, the holes are closed upon import in PrusaSlicer (they are briefly visible upon import, confirming they exist in the STEP file, but then are missing
  2. When I import the same part in .3mf format the holes remain in the model
  3. When I choose fix STL by Windows repair algorithm, the holes are removed again

The forum does not allow me to attach the STEP and 3MF files.

HenkJan 

Posted : 15/01/2024 8:34 pm
Neophyl
(@neophyl)
Illustrious Member
RE: Holes for magnets disappear

You have to zip such files to attach them. For best please save your 3mf from Prusa slicer using file>save as. A 3mf from PS also contains your settings which is just as important as the model file. 

Posted : 15/01/2024 8:43 pm
_KaszpiR_
(@_kaszpir_)
Honorable Member
RE: Holes for magnets disappear

I had similar issue with exported models from other software in stl format, where holes were as negative volume and this was not understood by PrusaSlicer - in fact negative volume was normal volume so it even tried to print shapes twice.

What I did was merge everything to single object in the original software and export as stl and it worked.

See my GitHub and printables.com for some 3d stuff that you may like.

Posted : 16/01/2024 7:59 am
henkjan_nl
(@henkjan_nl)
New Member
Topic starter answered:
RE: Holes for magnets disappear

Ring

I included a ZIP file.

  1. Bottom.3mf contains the print job. The shape contains errors but has the magnet holes and is editable. After the model  is fixed, the magnet holes disappear
  2. Top.step also contains magnet holes, but they disappear directly upon import

It is not urgent, I can print my parts by importing as STL. It is just an opportunity to improve the already great slicer.

HenkJan

 

Posted : 16/01/2024 6:17 pm
Neophyl
(@neophyl)
Illustrious Member
RE: Holes for magnets disappear

You have answered your own question.  You say the object has errors.  And on opening your project yes it does, 12962 open edges.  In fact if you turn on the Preferences option for Show Non Manifold edges then all those holes are shown as edges in purple. I'm surprised it slices as well as it does. 

If you believe the step import has a problem then you need to post all of this on the PS github.  There are already quite a few STEP import related ones though.  

I used a few of the various online step file viewers and all of them had problems with the model, either removing parts of it or it not being a solid at all.  So I'd say your step is faulty in the first place and expecting PS to be able to use it is asking too much.

 

Posted : 16/01/2024 7:17 pm
Robin
(@robin)
Prominent Member
RE:

Your model in the step file is flawed. I loaded it with fusion360 and it shows as a surface only - not a solid. The "holes" for the magnet on the other hand are solids.

Since there is no solid body to substract the holes from slicer fails to compute the body as intended. 

It seems not to be easily fixable since I can not stitch the surface togther and create a solid in fusion - some more inspecting is necessary, which is most probably better done in the CAD you used to create the file...

This post was modified 3 months ago by Robin

If at first you don't succeed, skydiving is not for you.

Posted : 17/01/2024 1:56 pm
henkjan_nl
(@henkjan_nl)
New Member
Topic starter answered:
RE: Holes for magnets disappear

Thanks all for looking into it. I fully agree. I created the model in FreeCAD. I will raise a question in the FreeCAD forum, my experience is that even quite simple models often have errors in their mesh exports.

Posted : 19/01/2024 9:36 am
Share: