XL Dual Head won't boot past 50% after attempting to update to 5.1
 
Notifications
Clear all

XL Dual Head won't boot past 50% after attempting to update to 5.1  

  RSS
Fadings
(@fadings)
Active Member
XL Dual Head won't boot past 50% after attempting to update to 5.1

Hey guys, just looking for some advice here.

Had just gotten a dual head XL factory assembled. before turning it on, I went ahead and put the 5.1 firmware on the USB drive and tried flashing it. It uploaded 100% then goes into the load screen where it locks up at 50%. I have tried going to 4.7.0, 4.7.5 and retried 5.1. I have reformatted the USB drive to FAT32. I've even used a different USB still with no different results. Still nothing is changing. No other lights show up anywhere on the printer other than the yellow light from under the LCD. No fan noise on boot up. Just a 50% loaded boot screen. Wondering if anyone else has had this issue and may be able to give some recommendations. I've looked around on the forums and have tried all the possible solutions other people have had with mk3s+'s and no luck. Just looking for other things to try and diagnose the problem. Already been in contact with support and waiting for an email back from them.

Posted : 12/12/2023 6:39 am
JoanTabb
(@joantabb)
Veteran Member Moderator
RE: XL Dual Head won't boot past 50% after attempting to update to 5.1

have you tried 'Chat' with support...

it's usually faster, than email

regards Joan

I try to make safe suggestions,You should understand the context and ensure you are happy that they are safe before attempting to apply my suggestions, what you do, is YOUR responsibility. Location Halifax UK

Posted : 12/12/2023 11:41 am
Fadings
(@fadings)
Active Member
Topic starter answered:
RE: XL Dual Head won't boot past 50% after attempting to update to 5.1

Hey! I did go through support and they could not resolve the issue and they had said they will email me with a potential solution. So I am waiting on that email. Sorry for the clarification!

Posted : 12/12/2023 12:37 pm
JoanTabb
(@joantabb)
Veteran Member Moderator
RE: XL Dual Head won't boot past 50% after attempting to update to 5.1

Thanks Zack, 

Some people just email, and that can take a while to get a response! 

regards Joan

I try to make safe suggestions,You should understand the context and ensure you are happy that they are safe before attempting to apply my suggestions, what you do, is YOUR responsibility. Location Halifax UK

Posted : 12/12/2023 1:00 pm
neslekkim
(@neslekkim)
Eminent Member
RE: XL Dual Head won't boot past 50% after attempting to update to 5.1

Lets hear what the solution is, I had no problem upgrading to 5.1.0, but upgraded to 5.1.2, and seemed ok, I did not print or anything though, turned off the printer.

Today I turned it on again, and now it hangs with like 50% on the progressbar.

all 5 tools have full fans, let the printer sit like 20+ minutes, but nothing happened.

Posted : 19/12/2023 5:40 pm
Dave
 Dave
(@dave-17)
Member
RE: XL Dual Head won't boot past 50% after attempting to update to 5.1

I had the same issue going to 5.1.2. 

I flashed to 5.1.2 and recalibrated per the instructions, rebooted my XL and had the 50% issue.  After multiple reboot attempts, I reflashed to 5.1.0 using the reset button then pressing the dial button (per instructions on Prusa help for XL) then recalibrated per instructions.  Turned the unit off for the evening, turned on this morning and received a PUPPY ERROR looked at the link https://prusa.io/17516 and the instructions indicated reflashing the firmware.  I reflashed 5.1.2, then recalibrated per the instructions.  Turned the unit off for 30 minutes or so, turned it back on and everything is working fine.  No PUPPY errors, correct boot and am now printing a 5 head print.

Of course your mileage may vary but this worked for me.

Good luck.

Posted : 19/12/2023 9:13 pm
Fadings
(@fadings)
Active Member
Topic starter answered:
RE: XL Dual Head won't boot past 50% after attempting to update to 5.1

I still have yet to be able to get the printer to boot. I even tried flashing to 5.1.2 but still gets hung up at 50% load screen. Have tried 4 different flash drives, reformatted them all and have tried every firmware release and nothing works. Support got back to me saying to try reflashing again which didn't work. Contacted them again and awaiting another email about further instructions. It might be the board? All I want is to be able to print on this machine lol.

Posted : 20/12/2023 7:07 am
neslekkim
(@neslekkim)
Eminent Member
RE: XL Dual Head won't boot past 50% after attempting to update to 5.1

Started the printer again today, determined to try to flash 5.1.0, but, now it booted correctly.. wtf.

 

Posted : 20/12/2023 3:20 pm
Fadings
(@fadings)
Active Member
Topic starter answered:
RE: XL Dual Head won't boot past 50% after attempting to update to 5.1

I resolved the issue. I removed the CMOS battery on the xbuddy board for a minute and put it back in. Resolved my issue 1st time.

Posted : 22/12/2023 9:22 pm
neslekkim
(@neslekkim)
Eminent Member
RE: XL Dual Head won't boot past 50% after attempting to update to 5.1

Did it loose all it's calibrations then?

Posted by: @fadings

I resolved the issue. I removed the CMOS battery on the xbuddy board for a minute and put it back in. Resolved my issue 1st time.

 

Posted : 02/01/2024 4:30 pm
neslekkim
(@neslekkim)
Eminent Member
RE: XL Dual Head won't boot past 50% after attempting to update to 5.1
Posted by: @neslekkim

Started the printer again today, determined to try to flash 5.1.0, but, now it booted correctly.. wtf. 

I don't understand this printer, it managed to boot to 5.1.2, and I confirmed the nozzle size.

But next boot (I had removed 5.1.2 fw file, and replaced it with 5.1.0 fw file), it downgraded it self. Is there really no fw version check??
So then I ended up with 5.1.0, and tried to upgrade to 5.1.2 again, but same problem, install newer finished, let it sit two hours, nothing hapened. Reboot, and it hangs at 50%.
So, I replaced the fw files again, and it managed to install 5.1.0 again.. so atleast, printer is not a huge brick, but I cannot get it updated.

I also need to remove the fw file, or otherwise it install firmware each time I boot the printer..

 

Posted : 02/01/2024 4:36 pm
Area51
(@area51)
Member
RE: XL Dual Head won't boot past 50% after attempting to update to 5.1

@neslekkim, Your description of the 5.1.2 upgrade matches my experience upgrading my MK4 from 5.1.0 to 5.1.2. I found this GitHub reported issue on the problem: https://github.com/prusa3d/Prusa-Firmware-Buddy .

My XL 5T is still running 5.1.0 and I am hesitant to upgrade after my experience with the MK4 and this forum thread.

Have a look at my models on Printables.com 😉

Posted : 05/01/2024 3:07 am
neslekkim
(@neslekkim)
Eminent Member
RE: XL Dual Head won't boot past 50% after attempting to update to 5.1

Strange, this does not happen on my mk4, it starts fine, does not try to flash firmware again.

I wonder about @Fadings experience there, regarding removing the cmos battery. Are the batteries empty?, and, what does the cmos store?, do we need to run full calibration again if I remove it?

 

 

Posted : 05/01/2024 12:21 pm
Share: