Notifications
Clear all

Octoprint issue  

  RSS
Ardjan
(@ardjan)
Member
Octoprint issue

I have used Octoprint successfully the last weeks. All under FW 4.7.2 and Slicer 2.6.1: worked good.

Yesterday I switched to Slicer 2.7.0 and installed firmware 5.1.0 as well. 

When I now want to print from Octoprint, I get a message

Suppressed command

The command T0 S1 L0 D0 was not sent to the printer:

 

Not queuing T0, that tool doesn't exist according to the printer profile or was reported as invalid by the firmware. Make sure your printer profile is set up correctly.

And the funny thing: it starts the print as usual: heating up, probing the bed, but then parks the tool, wait for the temperature, and starts doing the printing movements, but without the toolhead 🙂

When I use the same gcode and upload it to PrusaLink, it prints fine...

I deleted all printer profiles in PrusaSlicer and just created one, having the IP of the OctoPrint and the API key in it. No change...

 

Any idea what I can do here?

Posted : 26/11/2023 9:12 pm
Nikhil S.
(@nikhil-s)
Trusted Member
RE: Octoprint issue

Not an answer, but just to confirm, you are hooking up your Octoprint server via the USB-C port on the back of the XL, correct?  I just got a RPi4 that I intend to use for this, but have never used Octoprint (this is my first 3d printer).  It seems the XL does not have a pre-made profile either, so I guess we just manually put in the dimensions?

Brand new to 3D printing and my 5-tool XL is my first 3D Printer! I have done massive amounts of research though, so I'm not starting completely from square one....

Posted : 04/12/2023 3:56 pm
MalsBrownCoat
(@malsbrowncoat)
New Member
RE: Octoprint issue

Ardjan, did you ever get this resolved?  I just fired up Octoprint, figuring (incorrectly) that enough time had gone by to work out the bugs for compatibility with the XL.  
I'm seeing the same suppressed command for my 5 tool head XL.  I've followed the instructions for the Octoprint setup with the XL here (though it makes no mention about tool head configurations) - 
https://help.prusa3d.com/guide/octoprint-setup-on-mk4-mk3-9-xl_646395

What I've noticed is that after a certain point during the print, the bed temp drops to ambient, despite being configured in the slice to be 60 C.  
And after a while, the tool head temp shuts off and eventually the filament stops flowing but the tool head continues to try to print in mid air to complete the print.  

I suspect that this is due to the heater timeouts within Octoprint (basically, since the tool head can't be queued, it defaults to timing itself out).  
That's just a hypothesis though.  
I shut down my Octoprint server and retried the same print, which succeeded just fine.
Clearly something going on with Octoprint.    

 

 

 

Posted : 29/12/2023 7:48 pm
Gavin
(@gavin-6)
Member
RE: Octoprint issue

Wanted to add another datapoint to the conversation. I was unable to get a print to succeed on my 5-tool XL through OctoPrint, giving the same error as the original post. The same g-code would only work correctly and pick the right tool if started from the USB. Even previously successful g-code would fail in the same manner - air printing with no tool attached.

I restarted OctoPrint and the print completed with no issues. I will be keeping tabs on the rate of recurrence of this issue.

Posted : 13/02/2024 12:26 pm
Share: