MMU3 beeps on each colour change since Prusaslicer 2.70 update
 
Notifications
Clear all

MMU3 beeps on each colour change since Prusaslicer 2.70 update  

  RSS
Bazzalight
(@bazzalight)
Active Member
MMU3 beeps on each colour change since Prusaslicer 2.70 update

I re sliced a MMU model after updating to the latest Prusaslicer 2.7 yesterday and now find the Printer is beeping on every filament change (it didn't do this on the old 2.6.1 gcode which I printed the day before).  I did not observe any issues with physical operation during the colour change and have since checked the filament sensors and they are good.  My sound was set to "once" and have now changed to silent (to keep the household happy) awaiting resolution.

Has any one else had the same problem ?

My config:-

Mk3S (not +) with MMU3 upgrade from MMU2

Firmware 3.13.2 (3.0.1) (latest)

REVO equipped

using Octoprint

 

 

thanks

Posted : 28/11/2023 10:11 pm
Bazzalight
(@bazzalight)
Active Member
Topic starter answered:
RE: MMU3 beeps on each colour change since Prusaslicer 2.70 update

Did a quick look at the 2 version of gcodes. The 2.6.1 version appears to lift the nozzle just before the T command whereas the 2.7 doesn't.  Is there some firmware nozzle height check as part of the T command that might be issuing a warning beep ?

disclaimer: I am no expert of gcode

 

Posted : 28/11/2023 11:45 pm
K7ZPJ
(@k7zpj)
Reputable Member
RE:

It looks like Prusa Slicer 2.7 could be using M600 for the color change.   

This is from gcode that I sliced with 2.7:    ; color_change_gcode = M600

gcode sliced with 2.6 doesn't have this in it.

Posted : 29/11/2023 12:31 am
Bazzalight
(@bazzalight)
Active Member
Topic starter answered:
RE: MMU3 beeps on each colour change since Prusaslicer 2.70 update

The G600 code was in both of my 2.6.1 and 2.7 versions as a single entry but I thought as it was behind a semicolon it was ignored (ie a compiler comment).

the only reference both of mine was towards the end of the gcode with a stack of other comments from the compilation. The variable name "color_change _gcode" does not appear anywhere else either in the gcodes.

; color_change_gcode = M600\nG1 E0.4 F1500 ; prime after color change

Looking at the knowledge base it seems to be associated with filament sensors  in a non MMU mode colour change, but I could be wrong....

Posted : 29/11/2023 1:21 am
K7ZPJ
(@k7zpj)
Reputable Member
RE: MMU3 beeps on each colour change since Prusaslicer 2.70 update

I submitted a bug report for this issue and I am looking forward to a response.

Here is the link to the bug report:  https://github.com/prusa3d/PrusaSlicer/issues/11786

Posted : 29/11/2023 1:56 am
Sam Bald
(@sam-bald)
Member
RE: MMU3 beeps on each colour change since Prusaslicer 2.70 update

I'm experiencing the exact same thing and it's becoming very annoying very quickly. Otherwise the MMU3 has been fantastic, but unless I change my sound settings to mute (and potentially miss important warnings), I have this incessant beeping. Thanks for submitting the bug report, hopefully it gets some traction soon

Posted : 09/12/2023 6:55 am
Chewie
(@chewie)
Active Member
RE: MMU3 beeps on each colour change since Prusaslicer 2.70 update

Hi all

Just installed my mmu3 tonight and found this thread after my wife threatened to kill me over the noise. 

Was a fix found please, other than silencing all the alarms? I don't want to come home tomorrow to find my printer thrown out the house into the middle of the street. 😫 

Many thanks

Chewie

Posted : 03/01/2024 11:32 pm
Hello
(@hello)
Noble Member
RE: MMU3 beeps on each colour change since Prusaslicer 2.70 update

Known issue fix is being worked o  https://github.com/prusa3d/Prusa-Firmware/issues/4551

 

Please help me out by downloading a model it's free and easy but really helps me out https://www.printables.com/@Hello_474427/models

Posted : 04/01/2024 2:34 am
Share: