Clear all

MMU2S has all sorts of problems  

New Member
MMU2S has all sorts of problems
Hello in the about 1 year i own a prusa MK3S with the MMU2S i feel like the MMU2S is in a alpha 0.0.1 stage...
this thing has so many problems. i managed to get about 2 successful prints with 2 colors more than that it has a 100% fail rate for me. i don't know why but it has all kinds of problems from out of no where wanting to select a different fillement while it is printing. to going to blink all leds green and the red once and it is completely stuck like a PC that has crashed. i have to reset the MMU2S and it will go on. this worked fine for the 2 dual color prints. now i also gave a 3 color print a try this all went prety well untill it randomly decided it was a good idea to print some parts in the wrong colors so it did not change the fillement and just kept going. also what happends a lot even with single color prints is it loads the fillement up to the F.I.N,D.A sensor and instantly pulls it back this goes back and forward untill i once again reset the MMU2S. also 9 out of 10 times wen the MMU2S begs for attention i just have to reset it and it will go on no problem at all this happens a lot for single color prints as well just mid printing it complains.
I have calibrated the printer many times and it all goes well.
Posted : 05/01/2021 2:52 pm
John Svensk and liked
Estimable Member
RE: MMU2S has all sorts of problems

A well calibrated printer is not all it needs for the MMU2s to work flawless, it is the mere basis to build upon.

There are a lot of issues with not well dialed in systems during load and unload moves. However, if your MMU behaves funky in the middle of one colour (and you haven't previously done a forced reset in between) and even in the middle of a single colour print, then there might be a problem with the MMU2 board.

However other problems you describe sound like there are other issues as well. If the MMU tries to load filament but gives up somewhere in the extruder and pulls out again, just to retry. Then you may have an issue with friction or a (semi-)blocked hotend, which a regular MK3s might handle just well but an MMU doesn't.

Until your MMU2 works well, I would test print only with high quality PLA. Prusament PLA would be a good option as its the house filament and the standard settings in slicer should work well if the system is dialed in. If you have these loadin issues, I would print maybe something of the size of a benchy with that very material to really get all residues of other stuff out of the hotend and nozzle. Then try two prusament PLAs of different colour.

Resetting the MMU might seem like a solution but I made only bad experiences with that. It should be possible to handle all situations without resetting. If you do reset it, it might lead to exactly those issues of the MMU acting confused and making wrong moves.

To get your MMU working, it is important to single out individual problems and tackling them individually. In your case, if the MMU is making troubles even in single colour mode, I would say the single colour mode is where to start, as that should work flawlessly on a well dialed in system.

PS: The problem I had which I needed several weeks to finally pinpoint was that the MMU selector screws loosened which caused the weird error that the first changes (after start calibration) worked fine but somewhere in between the changes started to be totally wrong and it always failed. All it needed for my largest issue was tightening those screws again. This error is quite mean as it is not immediately visible and allows very short successful prints.

Mk3s MMU2s, Voron 0.1

Posted : 21/01/2021 3:38 pm