Clear all

FINDA Probe & Filament not loading MMU2  

New Member
FINDA Probe & Filament not loading MMU2

Hello, Monday morning, filament is loading from MMU to Extruder. Monday afternoon it is not.

PRUSA i3 MK3S factory built, and MMU2S kit build and using filament buffer. 1.5 yrs old, used frequently.

Latest firmware updates to both printer and MMU, Tuesday. To see if this would resolve issue. (it did not)..

So I am trying to print with multiple materials, Matter Hacker PRO series PLA in slot 1 and Verbatim PVA for supports in Slot 5. Brand name PLA that I am using I have used almost 1.5 years.

  • FINDA sensor appears to detect filament, (red light turns off when filament is present.)
  • Double checked filament in center of idler gear, and roller bearing appear to be in the right position(s).
  • Filament slides through PTFE tubing without obstruction.
  • Found that the razor blade filament cutoff this afternoon moved out of position and caused a jam, (removed for now)
  • Held down MMU reset button to maybe resolve issue, (still not feeding). 

Filament will not load to extruder from MMU unit, either during a SD card print run or even trying to load to extruder through printer settings. I watched closely from the time I started the process. I could see that the MMU motor start to turn and push filament to the FINDA sensor, but as soon as the light on the sensor turned off (detect filament) then motor went into reverse back the filament away from sensor, this would happen a few times and then the display on the printer would ask if the correct color was loaded or if it still needed to be loaded. Any of these options would still not help load the filament to the extruder. After a few tries the printer acted as though the filament was loaded and tried to start the print. Even thought the red light was on the extruder FINDA sensor (filament not detected).

During a few of these events I tried manually/physically pushing the filament passed the FINDA sensor, but as soon as I did the MMU would grab the filament and pull it back to the starting position. ( I know from this that tension and pully grab is not the issue).

Seems as though this might be a electronic/software issue? Not sure. I reviewed some of the forums and found others that had tension issues but I don't believe that I am having this problem.

Anyone else have this issue or similar, did you get any resolve? If so how?






Posted : 24/02/2021 12:48 am
Active Member
RE: FINDA Probe & Filament not loading MMU2


I have occasionally had problems with erratic MMU behavior. I have usually been able to resolve the issue by disconnecting and reconnecting the MMU signal cable at the einsy board. When I had the problem most recently, I disconnected the cable at both ends and cleaned everything with a contact cleaner. 

Posted : 24/02/2021 4:44 pm
Active Member
RE: FINDA Probe & Filament not loading MMU2

Did you manage to resolve it - I'm also seeing the same behaviour - I've checked sensor calibration and everything mechanical - was printing fine, now I can't get it to load to extruder

Posted : 27/03/2021 2:48 pm
Active Member
RE: FINDA Probe & Filament not loading MMU2

In the end this was down to the ir filament sensor - although it looked like it was correctly configured in the menu, inserting an allen key triggered the correct reading, no flickering of the results when I set the "chimney" as far left as I could and made sure the bolts were tight the filament loaded reliably - it would be nice if there was some kind of visual indication of the sensor triggering

Posted : 27/03/2021 10:14 pm