Excessive "purging" when changing filament and Revo6 Nozzle
 
Notifications
Clear all

Excessive "purging" when changing filament and Revo6 Nozzle  

  RSS
smartroad
(@smartroad)
Active Member
Excessive "purging" when changing filament and Revo6 Nozzle

Hi all,

I recently changed the nozzle to a Revo6 (with a 0.6mm nozzle) and am now having issues with loading filaments on occasion. Basically the MMU2 will load the filament to the extruder then the extruder takes over, primes the nozzle, but then keeps priming the nozzle (pulsing it a little each time) meaning it creates a large blob of plastic forms (see picture). Then the MMU retracts then tries again, making the blob even bigger. At that point the MMU will either retract and then give an MMU load error or it does this thing where the MMU tries to retract but the extruder keeps trying to push the filament into the hot-end (so they are fighting each other).

Anyone know what the printer is trying to do when it is swapping filaments? The hotend is primed and extruding (hence the blob) but the printer doesn't seem to realise that and I am not sure how it is "detecting", or not in this case, that the filament is ready to go.

Posted : 26/06/2022 9:23 am
Robin
(@robin)
Reputable Member
RE:

I don't think it's the priming already that is going haywire here. The nozzle is supposed to move during that process. This kind of blob would form, if the filament reaches the extruder during loading but the IR sensor won't tell that it's there, so extruder and MMU keep feeding and waiting for the IR to report filament causing the blob to form. Finally the MMU will give up (since it thinks the filament never reached the extruder) and retract and generate a loading error.

Try recalibrate the IR sensor, consider soldering in an LED which will facilitate easy troubleshooting in cases like this.

This post was modified 1 month ago by Robin

If at first you don't succeed, skydiving is not for you.

Posted : 26/06/2022 10:16 am
smartroad liked
smartroad
(@smartroad)
Active Member
Topic starter answered:
RE: Excessive "purging" when changing filament and Revo6 Nozzle

Hi @robin thanks for that, I moved the sensor position and so far it seems to be working 😀

Posted : 26/06/2022 10:46 am
Share: