i3 mk3 display shows garbage / random characters / gibberish / nonsense
 
Notifications
Clear all

i3 mk3 display shows garbage / random characters / gibberish / nonsense  

  RSS
jaschanarveson
(@jaschanarveson)
Active Member
i3 mk3 display shows garbage / random characters / gibberish / nonsense

Hello!  My i3 mk3 developed a funny glitch after being used for a couple of years:  

  • the display will show nonsense characters
  • if I twist the dial on the front I'll temporarily see readable text again, but it will revert
  • I checked the connections for the ribbon cables at the display end and at the main board - didn't fix anything
  • there looks to be a kink on the right-hand ribbon cable (looking from the front of the printer) - wondering if that affected things I tried swapping the ends of the ribbon cable at both sides so the side with the kink was in the other set of connectors, but i still got garbled text
  • the printers had been working fine for almost two years before this happened 

 

Any ideas?

 

 

Posted : 30/01/2020 8:13 pm
jaschanarveson
(@jaschanarveson)
Active Member
Topic starter answered:
RE: i3 mk3 display shows garbage / random characters / gibberish / nonsense

Extra facts:

  • firmware was at 3.8.1, and I went back to 3.8 as an experiment - didn't change anything
  • I print from SD cards only (no network printing or software-controlled printing)

 

Thanks!

Posted : 30/01/2020 8:43 pm
rmm200
(@rmm200)
Noble Member
RE: i3 mk3 display shows garbage / random characters / gibberish / nonsense

I am quoting from vague memories here...

Other than bad hardware (possible) the current version of the firmware has a bug where some error message switches to

an invalid language. You might have a crash detection situation, or filament out, or ... something.

Hopefully someone with a better memory than mine can chip in.

Posted : 30/01/2020 9:59 pm
jaschanarveson
(@jaschanarveson)
Active Member
Topic starter answered:
RE: i3 mk3 display shows garbage / random characters / gibberish / nonsense

Hi, Robert-rmm200 -

Is there a general sense that going back to a firmware version from before 3.8 could be a fix?  I already moved back form 3.8.1 to 3.8, but it could be worth going back to 3.7.x?

 

Posted : 31/01/2020 4:07 pm
jaschanarveson
(@jaschanarveson)
Active Member
Topic starter answered:
RE: i3 mk3 display shows garbage / random characters / gibberish / nonsense

Update: going back to 3.7.2 didn't work....

Posted : 31/01/2020 8:18 pm
Zoltan
(@zoltan)
Moderator
RE: i3 mk3 display shows garbage / random characters / gibberish / nonsense

Hi @jnarveson

Which language are you using? 

Did you try after the flash factory reset or reflash the printer?

Can you pls. provide the picture of the display with the strange characters and with potential description in which situation did it occur? 

even an old man can learn new things 🙂
Standard I3 mk3s, FW 3.10.1 RC1, MMU2S, no closed box, Fusion 360, PrusaSlicer, Windows 10
PRUSA MINI FW 4.3.4, Prusa Connect Beta

Posted : 31/01/2020 8:31 pm
rmm200
(@rmm200)
Noble Member
RE: i3 mk3 display shows garbage / random characters / gibberish / nonsense

If you have the same problem with multiple versions of the firmware and a Master Clear (mandatory) - it is time to contact Support.

Click EShop above, log in, and Chat will shortly appear in lower right.

Tell them what you have tried, and have a picture handy of the gibberish. Good luck!

Posted : 31/01/2020 8:48 pm
karl-herbert
(@karl-herbert)
Illustrious Member
RE: i3 mk3 display shows garbage / random characters / gibberish / nonsense

Did you flash the right firmware? Mk3 and MK3S have different firmware. Maybe an electrostatic problem or a defective LCD. Try to deactivate RPI (RPI off on LCD). Disconnect USB cable if connected. 3.8.1 only shows hieroglyphs if printer sends a kill command (M112). There exits a patch on github:

https://github.com/prusa3d/Prusa-Firmware/pull/2348

https://help.prusa3d.com/article/vo6Ocztcs9-lcd-not-working


 

Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen.

Posted : 31/01/2020 9:28 pm
Zoltan
(@zoltan)
Moderator
RE: i3 mk3 display shows garbage / random characters / gibberish / nonsense

It does need to be a corrupted display at all. I have encounterd once the same and since my display is 100% working, can be a bug or incorrect character set downloaded.

Is it all around or appearing from time to time?

even an old man can learn new things 🙂
Standard I3 mk3s, FW 3.10.1 RC1, MMU2S, no closed box, Fusion 360, PrusaSlicer, Windows 10
PRUSA MINI FW 4.3.4, Prusa Connect Beta

Posted : 01/02/2020 8:08 am
jaschanarveson
(@jaschanarveson)
Active Member
Topic starter answered:
RE: i3 mk3 display shows garbage / random characters / gibberish / nonsense

@karl-herbert

Yes – I had the most recent firmware on it, and then tried moving back to two previous versions.  Both the 3.8.x versions showed random characters – now that I've tried a 3.7.2.x version all I see are solid rectangles...

 

 

Posted : 01/02/2020 12:51 pm
jaschanarveson
(@jaschanarveson)
Active Member
Topic starter answered:
RE: i3 mk3 display shows garbage / random characters / gibberish / nonsense

@zoltan

The display mostly shows strings of random characters (and lots of little folder-shaped characters in the mix, which is interesting).  If I spin the knob around I'll get back to a readable display screen for a moment, and can even navigate to "Print from SD" sometimes, but then back to gibberish.

I tried moving back to an earlier firmware, but in that case all I get now is a solid string of rectangles - not even random characters!

Posted : 01/02/2020 12:53 pm
Zoltan
(@zoltan)
Moderator
RE: i3 mk3 display shows garbage / random characters / gibberish / nonsense

So if you can come to the readable text is for sure not the display issue, but the memory where the characters are stored unless some cabling would be losen or faulty by years of printer jerks.

Did you try to reconnect the cables and connectors?

I understand it happens immediately after printer switch on or restart. Does the printer react on knob push? When you come to readable print from SD, after turning the knob back the text print from SD reappears same readable? I am trying to eliminate random behaviour.

Did you start the hard reset? https://help.prusa3d.com/article/SYvbQ66IXF-factory-reset

Try please describe as much as possible , picture or better the video recording the strange behaviour would help much more.

 

even an old man can learn new things 🙂
Standard I3 mk3s, FW 3.10.1 RC1, MMU2S, no closed box, Fusion 360, PrusaSlicer, Windows 10
PRUSA MINI FW 4.3.4, Prusa Connect Beta

Posted : 01/02/2020 4:17 pm
jaschanarveson
(@jaschanarveson)
Active Member
Topic starter answered:
RE: i3 mk3 display shows garbage / random characters / gibberish / nonsense

Hi, all -

 

Thanks for all your suggestions.  Working with Prusa tech support over chat I determined that it was a faulty LCD display, and I'm just going to order a new one.

cheers,

j

Posted : 04/02/2020 9:41 pm
Titan
(@titan-2)
Estimable Member
RE: i3 mk3 display shows garbage / random characters / gibberish / nonsense

I was interested to come across this post as my mk3 has similar symptoms, although not as severe by the sounds of it. The lcd displays nonsense characters just as you describe intermittently, but they don't generally stay on screen and it doesn't happen all that often.

It sometimes happens directly after powering the printer on, but usually fixes itself after a few seconds. Sometimes it happens randomly during a print, but a quick turn of the control dial generally 'fixes' it. I've only had to reset the printer a couple times on start up due to it getting stuck with the nonsense characters you mention.

I assumed it was an einsy hardware fault and decided to live with it until it caused major issues. Please do let us know if changing out the lcd screen fixes the problem. I hope it does fix it for you.

This post was modified 2 years ago by Titan
Posted : 04/02/2020 11:59 pm
jason
(@jason-18)
New Member
RE: i3 mk3 display shows garbage / random characters / gibberish / nonsense

I had just started to preheat the hot end to load filament when random characters appeared. once it beeped I loaded filament then the screen when back to readable. how ever the temperature numbers were on the right side. the z height, the % and time were on the left. after I turned the scroll wheel, the screen went back to normal. this is a MK3+ printer that we got in April.

Posted : 26/05/2022 9:32 pm
Share: