Notifications
Clear all

Filament sensor not working  

  RSS
Joel
 Joel
(@joel-2)
New Member
Filament sensor not working

I’m not sure what or if I have done something wrong when putting together the filament sensor but I keep getting a message to unload and load filament. I keep unloading and loading filament but it seems to either not detect it or something because it will keep asking me to do the same thing over and over. This is frustrating as I can’t use the auto load filament feature. Any suggestions will be greatly appreciated.

Posted : 28/11/2021 7:56 pm
Joel
 Joel
(@joel-2)
New Member
Topic starter answered:
RE: Filament sensor not working

Sorry, machine is an mk3s+

Posted : 28/11/2021 8:04 pm
Diem
 Diem
(@diem)
Famed Member

To confirm your diagnosis you can disable the filament sensor in the LCD menu - if it prints OK without the sensor then you've nailed it.

If so, look first at the plugs on the Einsy - are they seated correctly? pull and reinsert.

If no joy check there is no debris caught in the sensor, even a fragment of stringing can cause trouble...

Let us know how you get on.

Cheerio,

Posted : 29/11/2021 12:54 am
Joel
 Joel
(@joel-2)
New Member
Topic starter answered:
RE: Filament sensor not working

I have disabled the sensor in the LCD menu and it does print just fine with it disabled. What does this mean?

Posted : 29/11/2021 11:20 am
Diem
 Diem
(@diem)
Famed Member

It means you are correct in thinking the problem is with the filament sensor circuit.

Check the sensor is clear, check it is correctly connected.

If no help test the resistance of the part with a multimeter.  You are looking for a resistance, not an open circuit or a short.

Cheerio,

Posted : 30/11/2021 12:30 am
Mimir
(@mimir)
Active Member
RE: Filament sensor not working

I have been able to repare and replace whatever needed with my MK3S+ (that I 💕 ) but the problems of the filament sensor I never managed to make working consistantly -apart from the very first months after I received it from Prusa). I disabled the filament sensor at least a year ago and have never missed it. It is unlikely you will have problems, unless you are careless with your filaments. I mainly print with Bronzefill of Colorfab (Prusa).

Posted : 02/12/2021 8:32 am
Share: