PSA How to Fix "Calibration failed, check axes and run again" for Z-Axis
 
Notifications
Clear all

PSA How to Fix "Calibration failed, check axes and run again" for Z-Axis  

  RSS
Constructicon
(@constructicon)
Active Member
PSA How to Fix "Calibration failed, check axes and run again" for Z-Axis

Posting for easy searching for posterity.

If you start xyz calibration and run into an almost immediate failure with the Extruder failing to go all the way to the top, this is the solution to try. This does not address issues with the x or y axis, though you can run into issues on the x axis at the top of the volume if your zip ties aren't cut short enough on the extruder cable bundle, they can catch on the spool holder.

On to the Z-Axis:

First try loosening the nuts just above the Z motors. They may be too tight and preventing it from spinning.

If that doesn't work:
1) Lower the extruder until it barely/almost touches the heat bed and move it away from the edges so you can mess with bolts.
2) Loosen the 4 bolts on each of the 2 Z motors but don't let them fall off (8 bolts total)
3) Loosen the 2 bolts on each of the trapezoid nuts holding the x-axis pieces onto the Z-Axis (4 bolts total)
4) Loosen the 2 bolts on each of the Z-Axis top pieces (holds the axis in place at the top of the printer). (4 bolts total)
5) Turn the printer on and run the extruder up to the top using the settings>move axis>move z menu. Then if it doesn't go all the way up, turn the printer off and manually twist it until it stops. 
6) Loosely Tighten the 2 bolts on each top piece of the Z-Axis and the 2 bolts on each of the trapezoidal nuts.
7) Turn the printer back on, and you can use the Calibration>xyz calibration to run it back down to the bottom, but then you can stop it/turn off the printer.
8) With the extruder barely/almost touching the heat bed again, loosely tighten the 4 bolts on each of the Z-axis motors in a star pattern (tighten diagonal bolts from each other).
9) Hopefully, if you didn't over tighten in these steps, you should now be able to run xyz calibration and see the extruder climb all the way to the top and click a bit before coming back down to the heatbed and running the rest of the calibration steps.

All it does is help fix a minor misalignment when the Z-Axis isn't quite parallel enough due to screws being overtightened. Unfortunately the error message gives no real clues about how to fix this.

I really hope future versions of the user guide/handbook give this potential solution for fixing this issue for this error code. It should also describe in more detail exactly what should happen when the Z-axis is trying to calibrate, as it would have helped narrow down the issue sooner and helped me find the right forum posts. 

I don't have the original post up at the moment to credit the user but I believe their name is "Henry"? I got a similar suggestion from the user "Hello" on this post: Issues with XYZ calibration

Posted : 03/01/2023 3:55 am
Hello
(@hello)
Noble Member
RE: PSA How to Fix "Calibration failed, check axes and run again" for Z-Axis

Yes I'm glad that it worked for you 

Please help me out by downloading a model it's free and easy but really helps me out https://www.printables.com/@Hello_474427/models

Posted : 03/01/2023 4:10 am
Bent Derailleur
(@bent-derailleur)
Eminent Member
RE:

Had this problem.

First, yesterday I finished the build and today I should do to pre-flight check and calibration.

I came to the XYZ calibration which failed with this message "Check axes and run again".

Tried various things, well.... to make a long story short. There were two problems! First, you had to manually put the extruder all the way to the top (easy done with holding button and jog Z axis to the top), couldn't there have been a note with this in the instruction, would have saved me some time. After doing this I came further to this four-corners calibration.... BUT... then the second problem... didn't pass calibration...

After a few hours or fault searching I concluded the right trapezodial nut is a little tight, sometimes it binds on the axle! It is also dependant on how tight I screw it onto the holder (orange part). If I have it loose it works, but it is still harder to manual screw right z-axis than the left. If I tighten trapez nut slightly it binds and gets harder to screw, leading to this problem. It sometimes binds so the motor can't work correctly.

Very frustrating, going nuts here. Need to contact support and see if they can send a new trapez nut for me. Tried to "clean" the threads but it only made the problem worse.

This post was modified 1 year ago by Bent Derailleur
Posted : 06/01/2023 5:14 pm
Constructicon
(@constructicon)
Active Member
Topic starter answered:
RE: PSA How to Fix "Calibration failed, check axes and run again" for Z-Axis

I found that I had to not tighten any of the screws down all the way on the z axis. I "loosely" tightened all of them and left a bit of a gap between the nuts on the bottom of the axis and the motors. I also only tightened stuff when the x-axis was near each part as in my original post. Hope you're able to get it sorted. Drove me nuts for like 3 days.

Posted : 08/01/2023 1:39 am
Share: