Notifications
Clear all

Can't get colorprint to work with MM  

  RSS
mavu
 mavu
(@mavu)
Estimable Member
Can't get colorprint to work with MM

I tried several times, and cannot get the colorprint utility/website to work.

What I did:

- Slice with Slic3r Prusa edition, MultiMaterial profile.
- upload GCODE to colorprint webservice, chose layer, download.
- process downloaded gcode with multimaterial post-processor.

print.

Printer ust prints the whole file with extruder one without any kind of pause, or change.

Posted : 06/07/2017 4:37 pm
PJR
 PJR
(@pjr)
Moderator
Re: Can't get colorprint to work with MM

I thought ColourPrint was now included in the latest Slic3r.

Peter

Please note: I do not have any affiliation with Prusa Research. Any advices given are offered in good faith. It is your responsibility to ensure that by following my advice you do not suffer or cause injury, damage…

Posted : 06/07/2017 6:54 pm
mavu
 mavu
(@mavu)
Estimable Member
Topic starter answered:
Re: Can't get colorprint to work with MM


I thought ColourPrint was now included in the latest Slic3r.

Peter

If it is, i don't know how. Or did you mean post processing for MM was in the latest slic3r?
Which it also does not tell me...

Posted : 06/07/2017 7:16 pm
mavu
 mavu
(@mavu)
Estimable Member
Topic starter answered:
Re: Can't get colorprint to work with MM



I thought ColourPrint was now included in the latest Slic3r.

Peter

If it is, i don't know how. Or did you mean post processing for MM was in the latest slic3r?
Which it also does not tell me...

Talked to support, and the post processor is included in the latest slic3r beta. not colorprint.

Colorprint is included in the new PrusaControl. But as far as I can tell, that one does not work with MMU yet?

I just tried again, and there is definitely something wrong with the Colorprint website utility.

I generated gcode with the latest Slic3r beta, and uploaded it to colorprint.
it correctly detected MMU, and i selected the layer and extruder and downloaded the resulting gcode.

this is the diff between the new file and the old:


--- ../motorcycle-fidget-spinner-cap-topper.gcode 2017-07-11 12:18:21.501544130 +0200
+++ motorcycle-fidget-spinner-cap-topper-color.gcode 2017-07-11 12:25:17.459288060 +0200
@@ -13,7 +13,6 @@
M190 S55 ; set bed temperature and wait for it to be reached
M115 U3.0.12-RC1 ; tell printer latest fw version
; Start G-Code sequence START
-T0
M109 S215
G21 ; set units to millimeters
G90 ; use absolute coordinates
@@ -16296,6 +16295,7 @@
G1 Z4.100 F7200.000
G1 X115.644 Y105.043 F7200.000
G1 Z3.600 F7200.000
+T1
G1 E4.00000 F3000.00000
M204 S2000
G1 F2400

the only change in the whole file is the addition of the T1 and removal of the T0.
That simply cannot be right. because it would just lead to the second filament being blocked by the first.

no retraction moves, no wipetower etc.

So that does not work.

Has anyone here managed to get the simple "change color on layer X" to work?

Posted : 11/07/2017 1:34 pm
PJR
 PJR
(@pjr)
Moderator
Re: Can't get colorprint to work with MM

Has anyone here managed to get the simple "change color on layer X" to work?

Apologies, I was mistaken.

Yes, I have colour change working, not by using the utility but simply adding an M600 where I want it (and removing hte subsequent retraction prime if present).

Peter

Please note: I do not have any affiliation with Prusa Research. Any advices given are offered in good faith. It is your responsibility to ensure that by following my advice you do not suffer or cause injury, damage…

Posted : 11/07/2017 5:39 pm
mavu
 mavu
(@mavu)
Estimable Member
Topic starter answered:
Re: Can't get colorprint to work with MM


Has anyone here managed to get the simple "change color on layer X" to work?

Apologies, I was mistaken.

Yes, I have colour change working, not by using the utility but simply adding an M600 where I want it (and removing hte subsequent retraction prime if present).

Peter

ok, I think i just figured out why the colorprint website is not working for me:

I'm using the beta slic3r prusa edition, which has the multimaterial postprocessor builtin.
That means the colorprint website is currently unusable for me, because i would have to use it after generating gcode, but *before* i use the multimaterial postprocessor.
But I can't do that because the postprocessing is included in the latest Prusa Slic3r.

This is pure speculation, but seems consistent with the information i found so far.

So, i could try the last slic3r which does not have the post processing included. or wait until colorprint makes it into the MM slic3r.

Posted : 11/07/2017 10:44 pm
Share: