Clear all

Y-Axis Overstepping  

Active Member
Y-Axis Overstepping

Hello all,

I started my i3 MK2 up today to run some prints, and at first everything was working fine. My bed adhesion was bad though so I cleaned off my bed and applied a new layer of glue-stick to support better adhesion. After doing that, when the printer homes and performs meshbed compensation, I keep getting an error that the z-probe didn't trigger and to clean the nozzle and what not. My nozzle is clean, the print head didn't crash - it just dives like its going to probe for z, and then stops and throws an error on the fourth probing point. I've had this happen a couple times in the past and usually if I rerun a Z or XYZ calibration or just turn my printer off for a bit the problem will solve itself. 

This time, however, it continued to throw the error when I ran my Z calibration. Looking closer, I can see that when the printer is probing the first 3 probe points everything looks good. I can see that the z-probe is pretty well centered on all of the little probing circles, and it triggers no issue. When it moves to the fourth point though (first point in second row) I noticed that the z-probe is no longer centered on the probing points - it's now shifted deeper into the y-axis by 5-7mm. If it were shifted in the opposite direction, I would just assume that my y-motor is skipping because of some mechanical issue like a bad bearing or a belt issue or something; but it's shifted deeper into the y-direction, which would imply that my printer is moving the y-axis too much. I don't know how that could be possible unless a firmware setting was changed, but there's no way that happened. Can anyone advise? My printer is sitting idle and unusable at the moment and that does not make me a happy camper.

Thank you in advanced for your help!

Posted : 11/06/2020 12:41 am
New Member
RE: Y-Axis Overstepping

    I am unsure if you have resolved this issue by now but I had the same problem that plagued me for nearly a week and I solved it a few minutes ago.  I could not understand how the device could be overstepping even after recalibrating, re flashing the firmware, etc etc but then I thought, "wait, the y-axis diameter would have to change if it's not a software issue", that's when I saw the problem.

    Likely there is a bit of filament caught or wrapped into the metal piece that connects the stepper to the timing belt.  This is what causes the overstepping (in my case it was more dramatic and it was the belt bulging upwards that finally revealed the issue to me)  I hope this helps you and anyone else that has crossed this oddity.

Posted : 25/12/2020 12:04 am