Clear all

Octoprint Error "No More Candidates to Test...." - I3Mk2  

New Member
Octoprint Error "No More Candidates to Test...." - I3Mk2

Hi All,

I have seen heaps of online references to the above error where a machine will no longer connect automatically to the Raspberry Pi Octopi installation and render Octoprint unusable.  I have tried different USB cables (and shielded / ferrite cores).

I installed Octopi from the github image over a year ago and worked flawlessly, right up until last night.  This morning I powered on, it showed up fine, then went into error after a power cycle.  Now just shows connecting to serial port and won't connect with AUTO config, tried all manual combos and wont connect.  I also tried restarting Octoprint in safemode.

My connection ID is dev/ttyS0 on my Mk 2 (yes some of us still have them!)  , Octoprint 1.8.7 - with Octolapse 0.4.1/ Bed Visualiser 1.1.1 / Touch UI 0.3.18 as the main plugins.

I have power cycled both the Pi and the printer, tried to do a refresh in putty to add in the ttyUSB port which showed up then I have a conflict when I tried to send a print to the machine.  Have now gone back to USB card manual loading.

What I don't get, is this worked flawlessly for ages, no changes and JUST CONNECTED.  There are TONS of reports of this occurring all over the net with different machine makes and models, yet it still happens for apparently no reason?

I have seen many suggestions that even fresh installs of Octopi image etc won't fix this, I have tried the SUDO mods for the ports and still no joy.  

Is there any 100% definitive fix for this that doesn't involve putty and coding out a script to reinstall the ports?

Thanks in advance


Posted : 31/03/2023 2:20 am