I'm lost. After 6+ years of printing... MK2.5S is randomly shifting x and y...
 
Notifications
Clear all

I'm lost. After 6+ years of printing... MK2.5S is randomly shifting x and y...  

  RSS
JasonJason
(@jasonjason)
Active Member
I'm lost. After 6+ years of printing... MK2.5S is randomly shifting x and y...

After printing non stop for 5.5 years straight, I noticed oily metal dust accumulating on the rod and bearings. I started to have a bit of layer shift (like slightly skewed prints). Then I started to notice bigger shifts (like picture). So I invested some time and money and rebuilt the entire printer's x, y, and Z's linear motion.

I don't know to do. I've done:

  • Replaced all bearings with new Misumi
  • Replaced all linear rods with new Misumi
  • New gates new belts. Updated the Y bolt holder to the newest MK3s+ setup so you can tension. 
  • Updated the right side X axis to a bear version to allows for tensioning of the x axis belt
  • New idler pullies from printed solid .
  • Re torqued the splined gears at the motors (snugging up super tight on flats first then round)
  • Redone the entire printer calibration for xyz, first layer cal. 
  • None of the harnesses (x axis, or y axis snag anywhere)
  • The motion of the x axis moves smoothly across it's full travel (tilting the bed like 25 deg, the x axis slides across), same for Y axis
  • I used superLube in the brand new misumi bearings upon assembly. Made sure they were all clocked per assembly instructions
  • the y belt and x belt when plucked sound like a bass guitar string.

I can do 1 part print 75% of the time successfully. But if I do a big bed print of the same part it starts to randomly shift. Can be Y, can be X. Even other small parts I see this problem. Anything over 5 hours.

I noticed that the layer shift normally happens at the same layer height. 12.80mm layer. 

I'm printing petg, max 50mm/s, 800 mm/s/s accelerations. 245Deg hotend, 90bed. I only ever print petG.

Can it be my Einsy Mini Rambo board going bad? 

 

 

Posted : 05/08/2022 5:33 pm
JasonJason
(@jasonjason)
Active Member
Topic starter answered:
RE: I'm lost. After 6+ years of printing... MK2.5S is randomly shifting x and y...

Could belts too tight cause this?

Posted : 05/08/2022 9:49 pm
Share: