Original Prusa MINI & MINI+ WIFI Troubleshooting.
 
Notifications
Clear all

[Sticky] Original Prusa MINI & MINI+ WIFI Troubleshooting.  

Page 2 / 5
  RSS
Nonnus
(@nonnus)
Active Member
RE: Original Prusa MINI & MINI+ WIFI Troubleshooting.

First of all: thanks a lot for this huge firmware and its awesome new features, it was clearly a lot of work but rest assured it is greatly appreciated!

Just ordered a ESP01S Module and will report my progress as soon as I get it and install it but I did start testing the new firmware over ethernet connection and so far I have noticed 2 odd behaviours:

  • Every time I connect to prusa link on my browser I am asked to enter api key which is not a great user experience, please add `password` metadata to the text field so the browser can offer to store the key / password automatically
  • The release notes state that is possible to upload / print either from prusa link or from prusaslicer but I can not find any way to to reach the printer from prusaslicer, I tried with both latest official release (2.4.2) and 2.5.0-alpha3 with no luck, also tried to find any configuration regarding accessing the mini (I assume we also need to enter api key somewhere to authenticate printer access) but could not find anything, what am I missing?
Posted : 31/07/2022 8:21 pm
cwbullet
(@cwbullet)
RE: Original Prusa MINI & MINI+ WIFI Troubleshooting.

 

Posted by: @nonnus
  • Every time I connect to prusa link on my browser I am asked to enter api key which is not a great user experience, please add `password` metadata to the text field so the browser can offer to store the key / password automatically

Odd, I do not have this experience.  

--------------------
Chuck H
3D Printer Review Blog

Posted : 01/08/2022 9:29 am
Nonnus
(@nonnus)
Active Member
RE: Original Prusa MINI & MINI+ WIFI Troubleshooting.

 

Posted by: @cwbullet

 

Posted by: @nonnus
  • Every time I connect to prusa link on my browser I am asked to enter api key which is not a great user experience, please add `password` metadata to the text field so the browser can offer to store the key / password automatically

Odd, I do not have this experience.  

My bad, I should have included my browser details: Safari 15.6 (latest) on MacOS 12.5 (latest)
Every time I access my printer ip I get this:

Posted : 01/08/2022 10:41 am
LittleNeutrino
(@littleneutrino)
RE:

its in the patch notes that this is intended for the time being. its not a permenant solution

as far as reaching the printer from Prusa slicer, go into the printer settings tab, click the gear, and then update the Print Host Upload information please see attached image for clerificatoin

Posted by: @nonnus

First of all: thanks a lot for this huge firmware and its awesome new features, it was clearly a lot of work but rest assured it is greatly appreciated!

Just ordered a ESP01S Module and will report my progress as soon as I get it and install it but I did start testing the new firmware over ethernet connection and so far I have noticed 2 odd behaviours:

  • Every time I connect to prusa link on my browser I am asked to enter api key which is not a great user experience, please add `password` metadata to the text field so the browser can offer to store the key / password automatically
  • The release notes state that is possible to upload / print either from prusa link or from prusaslicer but I can not find any way to to reach the printer from prusaslicer, I tried with both latest official release (2.4.2) and 2.5.0-alpha3 with no luck, also tried to find any configuration regarding accessing the mini (I assume we also need to enter api key somewhere to authenticate printer access) but could not find anything, what am I missing?

 

Posted : 01/08/2022 3:11 pm
Nonnus
(@nonnus)
Active Member
RE: Original Prusa MINI & MINI+ WIFI Troubleshooting.

Thanks a lot @LittleNeutrino

That worked perfectly!

Posted : 01/08/2022 3:32 pm
Nonnus
(@nonnus)
Active Member
RE:

Can you please point me to where this is stated in the release notes? 

Posted by: @littleneutrino

its in the patch notes that this is intended for the time being. its not a permenant solution

ps: sorry for the double post, I ran out of time to update the previous post...

Posted : 01/08/2022 3:44 pm
Michael Musgrove
(@michael-musgrove)
Active Member
RE:

Alright. Here's where I am. 

I have Prusa Buddy v. 1.0.7 installed. I've installed a 10 MB wi-fi card. When I bought the card from SparkFun.com, I also ordered a 16GB flash drive which I formatted on my mac extended and journaled. I downloaded both files from GitHub to the flash and then inserted them into the printer. 

I cut the printer on, and it runs, just like it always does, and doesn't recognize I put new firmware into it. I still have v. 4.3.4, not v 4.4.4.

I've checked everything I can think of. The files are there, they're on the formatted, brand new drive, in the printer, with it on. And nothing.

Oh, and I tried to chat with Prusa using thone link I could find to connect with them, and it returns "Internal Server Error." Great.

Does anyone have any ideas? I don't!

Michael B. Musgrove

Posted : 02/08/2022 5:11 am
Michael Musgrove
(@michael-musgrove)
Active Member
RE:

I'm now at the stage where I'm getting the same thing. I've put the firmware onto a new flash drive, and the unit won't read anything now. I receive the very same message, just so the devs know. I'm dead in the water.

Michael B. Musgrove

Posted : 02/08/2022 9:41 am
JoanTabb
(@joantabb)
Moderator
RE: Original Prusa MINI & MINI+ WIFI Troubleshooting.

Hi Michael, 
Devs don't usually look here. 

I would suggest using Chat, on the Eshop page, 

Or reporting the issue in the Github pages. 

regards Joan

I try to make safe suggestions,You should understand the context and ensure you are happy that they are safe before attempting to apply my suggestions, what you do, is YOUR responsibility. Location Halifax UK

Posted : 02/08/2022 1:03 pm
Nonnus
(@nonnus)
Active Member
RE: Original Prusa MINI & MINI+ WIFI Troubleshooting.

 

Posted by: @michael-musgrove

I also ordered a 16GB flash drive which I formatted on my mac extended and journaled. I downloaded both files from GitHub to the flash and then inserted them into the printer. 

AFAIK, the mini only reads USB drives formatted with FAT32: https://help.prusa3d.com/article/sd-cards-and-usb-flash-drives_112291

Posted : 02/08/2022 1:24 pm
Michael Musgrove
(@michael-musgrove)
Active Member
RE: Original Prusa MINI & MINI+ WIFI Troubleshooting.

Thank you- I followed the instructions meticulously, and the same error code: #12608, comes up on the Prusa screen. And I'm dead. I have a whole box of USB flash drives to test with, and that isn't the problem that I can tell. It's more and more looking like the printer's ability to read the drive. It always sees it as corrupted, although I use a new drive, and a new DL of the software each time for consistency's sake.

Michael B. Musgrove

Posted : 02/08/2022 9:08 pm
Michael Musgrove
(@michael-musgrove)
Active Member
RE: Original Prusa MINI & MINI+ WIFI Troubleshooting.

"

I would suggest using Chat, on the Eshop page, 

Or reporting the issue in the Github pages."

I cannot find that chat, could you please direct me with a link? Also, Github isn't where I tend to think I'll find a Prusa-specific issue. I'm willing to try anything mind you, but that's my first thought.

Michael B. Musgrove

Posted : 02/08/2022 9:11 pm
JoanTabb
(@joantabb)
Moderator
RE: Original Prusa MINI & MINI+ WIFI Troubleshooting.

Prusa chat seems to have moved.
Try this page... 

https://www.prusa3d.com/page/ask-us-anything_482/

Joan

I try to make safe suggestions,You should understand the context and ensure you are happy that they are safe before attempting to apply my suggestions, what you do, is YOUR responsibility. Location Halifax UK

Posted : 02/08/2022 11:30 pm
Michael Musgrove
(@michael-musgrove)
Active Member
RE:

Alright, this is my follow-up "I fixed it with the great help of a member of one of the Mini+ Facebook groups" post.

Brian E. Spliner was the big winner and figured it out for me! He had the same issue and shared his solution, which was to try to flash the old software, but I flashed the New software instead, and along the line, got to a screen that eliminated the error message.

I believe the key was to reset the unit with the button next to the knob, then press the knob twice in succession. Then try to flash the new software that way.

Note: possibly that IS HOW people have been doing it and I'm a noob dummy. But I won't be the last, I assure you! So hopefully that helps.  

 

And incidentally, the upgrade to the new firmware and resetting and tuning up everything made my printer start working like butter. The Wi-Fi integration is clean and nice. And the resulting prints and printing are clean, quiet, and with no fuss or muss. I Love it. Yes, the transfer of the files is slow now, but that will surely either die or grow with the use of it, and I have faith, combined with good reason that Jo Prusa will continue to grow this wireless ecosystem for us to use, and it will only improve. And if it doesn't then there will be a good technical reason why; not financial insolvency or anything like that.

I'm patient, and the utility it gives me now is better than before and really all I need. It's not like my life will go off the rails if I have to walk over to the printer.

Michael B. Musgrove

Posted : 03/08/2022 1:55 am
You liked
Michael Musgrove
(@michael-musgrove)
Active Member
RE: Original Prusa MINI & MINI+ WIFI Troubleshooting.

OK, next issue I can't seem to find any existing documentation on. When I attempt to print from Prusa Link and my print has loaded and everything looks good, and I click the big green "Start Print" button, I receive an error message. "409: Conflict. Can't Start Print Now" to be precise. It's with any print I load into PrusaLink.

Michael B. Musgrove

Posted : 03/08/2022 4:18 am
Nonnus
(@nonnus)
Active Member
RE:
Posted by: @michael-musgrove

OK, next issue I can't seem to find any existing documentation on. When I attempt to print from Prusa Link and my print has loaded and everything looks good, and I click the big green "Start Print" button, I receive an error message. "409: Conflict. Can't Start Print Now" to be precise. It's with any print I load into PrusaLink.

I noticed the same error and found out this happens when the printer screen is on a "incompatible" menu (eg: the print menu with `tuning`, `pause` and `stop` options), I usually have to manually navigate to `home`on the printer  to be able to print again from prusa link or prusaslicer

According to https://github.com/prusa3d/Prusa-Firmware-Buddy/releases/tag/v4.4.0-beta2 summary:
`*MINI+ must be on the home screen, “print-preview” screen, “print-finished” screen - this is intentional for safety reasons`
(I am not sure what  is the “print-finished" screen, my printer stays on the same exact screen as it was during printing and does not switch to any different screen)

This post was modified 4 months ago by Nonnus
Posted : 03/08/2022 8:34 am
jkavalik
(@jkavalik)
RE: Original Prusa MINI & MINI+ WIFI Troubleshooting.

Today I received my order of two "Ai-Thinker ESP-01S" modules and decided to install one.

The installation was straightforward, the printer fw flashing and module fw flashing went fine, wifi connectivity seems ok. Bandwith is "not great, not terrible" 🙂

Couple hiccups showed with test usage:

- my thumbdrive had quite a lot of files in root - the firmware was not really able to cope with that, listing the files in webUI somehow worked, but the UI was very unresponsive (ajax part, not js itself afaik, temperature updates pending etc), trying to start a print did not really work most of the time, the USB seemed to reset a couple of times (the printer LCD loaded the newest file as if the stick was reinserted manually) and in the end the printer showed red "Out of memory" error and reset. At that moment if finally occurred to me what the problem might be and I moved the gcode files into a subdirectory. The webUI became responsive and starting print from web upload and PrusaSlicer worked.

- starting print seems to not work for me from the “print-finished” screen contrary to the release notes, I had to exit to home screen

- download did not seem to work - looks like that one was already noted and temporarily disabled in code - https://github.com/prusa3d/Prusa-Firmware-Buddy/commit/23b54eef1958e3cafe45a01eadcc5fbdc59ba53c

- trying to upload the same file twice (when I used the "upload" button instead "upload and start" by mistake) returns a "filename already exists" error instead of rewriting the file - on my PrusaLink on MK3S uploading twice is not a problem so I was surprised

- subdirectories existing on the thumbdrive are nowhere to be seen (and I did not yet try to upload to a subdir from PrusaSlicer)

 

So yeah, couple of hiccups as expected, otherwise working nice for a beta test - my second print directly from the Slicer just finished 🙂

Posted : 03/08/2022 8:28 pm
Michael Musgrove
(@michael-musgrove)
Active Member
RE: Original Prusa MINI & MINI+ WIFI Troubleshooting.

That's good information to know and subtle little things I would never think to check. Thank you so much! That's helpful going forward and good knowledge to have!

Michael B. Musgrove

Posted : 03/08/2022 11:29 pm
DarthTater
(@darthtater)
Active Member
RE: Original Prusa MINI & MINI+ WIFI Troubleshooting.

I am getting errors when trying to upload and print files to my mini. They seem to upload fine but then it just gives an error and says "conflict" instead of starting the print.

When I go and look a the printer there is a preview of a completely different file on the screen (it was on the home screen before I start).

The file names are all unique. 

This has happened several times now.

In the end I have to go the printer and select the file to get it to print.

Posted : 05/08/2022 10:02 am
jkavalik
(@jkavalik)
RE: Original Prusa MINI & MINI+ WIFI Troubleshooting.

That was happening to me too when there was too many files, seemed like something inside the usb stack got reset and it thought I re-inserted the drive. I removed old files from the drive root (moving inside a directory was enough) and it started working quite reliably.

Posted by: @karlos

I am getting errors when trying to upload and print files to my mini. They seem to upload fine but then it just gives an error and says "conflict" instead of starting the print.

When I go and look a the printer there is a preview of a completely different file on the screen (it was on the home screen before I start).

The file names are all unique. 

This has happened several times now.

In the end I have to go the printer and select the file to get it to print.

 

Posted : 05/08/2022 10:19 am
Page 2 / 5
Share: