Notifications
Clear all

MK4 - Not a perfect first layer  

  RSS
Matthew17
(@matthew17)
Member
MK4 - Not a perfect first layer

A bit of context first...

I'm a fan of Prusa and have been using the mini/mk3 models since 2020.  My business is an engineering design firm primarily designing products for end consumer use.  Typically make a lot of small plastic parts, perfect for Prusa machines.  We aren't a printing farm but on occasion we print hundreds of parts for our customers (when more costly operations aren't an option).

We recently purchased an assembled MK4 printer in the fall of 2023.  Excited to upgrade from the mk3 and to use the wifi capabilities with prusaconnect.  Upon initially printing, the first couple of parts turned out great. 

The issue

After approximately 10 prints or so, we encountered (the now recurring) issue.  The extruder runs itself into the printer bed, thus ruining the steel sheet.  We've also encountered the opposite, where the extruder is several layers above where it should be, causing the plastic to just string and not adhere in normal layer fashion.  We've also encountered the issue where the parts completely shift 1" halfway through the build.

The steel sheet that was originally supplied with the unit is completely ruined.  Not a big deal, but subsequent sheets have been ruined with this ongoing issue.

At first, I thought this might be an isolated issue that would be solvable.  But with the self-leveling feature of the MK4 there's no way to adjust Z height or "tune" the leveling feature. 

Some reasearch on the forums suggest that perhaps there's an issue with transferring the files over wifi, and perhaps there's some data loss causing the issue.  Since the initial issues, we've no longer relied on the wifi for transferring data and export directly from Prusa slicer directly on to a flash drive (then taken to the mk4 printer).  Also, it was noted to turn down the printer speed for more reliability, so we've been printing at 85% speed.

Further issues;

Recently we had an order for 150 parts.  It was easiest to split this up into a batch of 5 parts per build.  After running approximately 7 batches of parts successfully, we've run into the same issue.  The same program that was successful on the previous 7 builds is now producing bad parts.  Extruder nozzle running to the steel sheet.  Another steel sheet ruined.  Parts shifting layers in mid build.  Again, the same program that produced successful parts was used.  The issue doesn't repeat itself on a specific part or location on the bed.  Sometimes it occurs on the front of the plate, sometimes on the back of the build plate.  Sometimes all 5 parts in the build run successfully.  It's completely random when the build fails, and steel sheets are being ruined (which is also problematic).

So, I'm reaching out on the forums to get some help. 

Has anyone encountered these issues? 

What's the fix? 

Should I reach out to Prusa for a warranty claim? 

I want to reiterate I'm a fan of Prusa.  Despite the problem with the assembled MK4 unit we recently purchased another Mk4, this time in a kit.  After ~100 hours of printing it's been running successfully with several builds completed.  The issue mentioned above is only isolated the the assembled MK4 unit that was purchased last fall.

Did we just get a lemon?

Any help or advice is appreciated.

Pictures are added for context.

Matthew

Posted : 04/01/2024 4:26 pm
fuchsr
(@fuchsr)
Famed Member
RE: MK4 - Not a perfect first layer

The fact that you have a second Mk4 that doesn't exhibit this behavior makes me think there's something wrong with that particular model. I haven't seen any of this on my own Mk4s. Could be as simple as a defective load cell. I would certainly contact Prusa and bring this up under the warranty. 

Posted : 04/01/2024 5:42 pm
Matthew17
(@matthew17)
Member
Topic starter answered:
RE: MK4 - Not a perfect first layer

Thank you, I'll reach out to them now.

Any additional insights/advice from fellow forum members is appreciated.

Posted : 04/01/2024 5:47 pm
Lynn
 Lynn
(@lynn)
Estimable Member
RE: MK4 - Not a perfect first layer

I agree with @fuchsr,  when I read your post,  I immediately thought of the load cell, but I also wonder if there might be some z axis skipping that causes the printer to loose track of the z position during  the first layer print.  I don't know anything about how the load cell was implemented, but if it is doing any form of Z hopping and the upward carriage skips on its way up, I can see it driving the  nozzle into the bed surface.  I have some experience with my MK3 doing this as various Z heights in the past, so it is possible. 

you should defiantly contact Prusa with this problem.

 

Posted : 04/01/2024 7:21 pm
Matthew17
(@matthew17)
Member
Topic starter answered:
RE: MK4 - Not a perfect first layer

Thanks @lynn @fuchsr, I've reached out to support.

In full transparency, here are their responses;

Prusa;

I am very sorry for this inconvenience. The marks on the sheet are normal, but regarding the model failure, does this happen to you with different models? Is there a specific or temperature error message?

Me; Yes, it happens with different models. Not specific to one model. I've also run the same models (that were problematic on MK4) on my MK3 and did not experience any issues.

Prusa; Is the self test passing successful?

Me; Self test passed with no issues.  I've run the same program on my newer MK4 unit and it does not display the same issues. The newer MK4 unit runs flawlessly. The older factory assembed unit is the problematic one.

Prusa; I am sorry to hear this. But it can only be a sensor problem, this can be solved very easily. If you run a calibration model at this time, we can see what other faults you may have.

Me; OK, what are the next steps?

Prusa; Let's just print one of our calibration models like the bench, it will be helpful for us to check what is the issue.  this is most likely a quality issue.

Me; I have no issues with the quality of the prints. The problem is with the extruder nozzle running into the build plate.  If the sensor is the problem, what can we do about the sensor problem specifically?

Prusa; But this is a random problem, not just one that happens with every print. To explain a bit, I'm afraid it may be a problem with the loadcell sensor, but there are ways to verify this by proceeding to print.  This is in the heatsink. you can remove the nozzle completely and re set it into the hotend and print again. You can remove the nozzle completely and re set it into the hotend and print again.

Posted : 04/01/2024 7:47 pm
Emanuele
(@emanuele)
Eminent Member
RISPONDI: MK4 - Not a perfect first layer

Sorry for my bad English (translate with google)

Three months ago I updated my MK3S+ to MK3.9 and I noticed that the prints did not always come with the perfect background and, sometimes, they detached from the plate especially in the corners. At the beginning I blamed the filament, even though I always use Prusament and I use PrusaSlicer with Prusa presets, but today I got smart and printed a completely flat layer. As you can see from the photo, many parts are crushed compared to the optimal condition, the famous "ripples" that I marked with the red and yellow pencil. The filament is Prusament PETG Clear, I used transparent so the defects can be seen better, and, despite the 49 test points performed by the load cell, the print is not flat. Of course I tested the printer, more than once, and all the tests came back positive, at least that's what it looked like with all the green ticks. The prints were made at 50% of the preset speed and 5 minutes apart from each other with the room temperature at 21°C and a humidity of 40%. The rightmost print was made after two hours under the same conditions with the same material, but this time it started with a cold plate and nozzle. As you can see, the result is completely different and there are areas that are raised instead of flattened, I marked them in yellow. I also checked the tightening of the screws of the top and those of the expansion joints and they are in line with the assembly instructions. I wonder if this, for me notable, defect is due to the load cell or something else. I'm already disappointed by the fact that I switched from the MMU2S to the MMU3 with my MK3S+ and then it worked, knowing that the MK3.9 was faster and had automatic floor leveling, I was attracted by the upgrade kit knowing that the shipping of the MMU3 kit for MK4 would have started in November, I opted to upgrade to MK3.9 and was screwed because to date we still don't know if the MMU3 will work with the MK4.

Posted : 24/01/2024 4:08 pm
Share: