This model is giving an error with empty layers...why? and how to fix?
 
Notifications
Clear all

This model is giving an error with empty layers...why? and how to fix?  

  RSS
Robin
(@robin-2)
Eminent Member
This model is giving an error with empty layers...why? and how to fix?

I am having problems slicing the top handle at 0.2mm in Prusa Slicer, while oriented vertically. It is saying:

"WARNING: Empty layer between 73.2 and 76.4. This is usually caused by negligibily small extrusions or by a faulty model."

When sliced, there is a large visual gap about 5mm below the main hole which holds the two handles together.

I tried putting it on its side, but also got an overhang perimeter right through the entire model. Tried repairing the model without sucess. I have never experienced this with Prusa slicer before. Anyone know how to fix?

https://www.thingiverse.com/thing:5146370

 

Best Answer by Neophyl:

Someone else in the comments on that item already mentioned it had issues.  The top model is showing as having 104 non manifold edges in blender, although both top and bottom are broken.  Slicers really don't handle non manifold parts well.  Lots of other errors too but the slicer handles those.

I've fixed the non manifold issues for you but this sort of repair is something you are going to need to learn how to do if you continue downloading files from the usual websites.  So so many of them are broken.

Btw Grant to attach anything to the forum you need to zip it up.  The forum is very picky about allowed file types.  

Also as theres a file size limit here is the top.

 

 

 

Posted : 24/01/2022 9:02 pm
Grant
(@grant-2)
Active Member
RE: This model is giving an error with empty layers...why? and how to fix?

There's definitely something wrong with the original stl. I downloaded this and managed to fix it, but can't upload it here.

To fix it I imported the stl into Blender, you can probably use any 3D modelling software you'd like, and then exported it as a .3mf file. When I loaded that into PrusaSlicer it was perfect.

Posted : 24/01/2022 10:02 pm
Neophyl
(@neophyl)
Famed Member
RE: This model is giving an error with empty layers...why? and how to fix?

Someone else in the comments on that item already mentioned it had issues.  The top model is showing as having 104 non manifold edges in blender, although both top and bottom are broken.  Slicers really don't handle non manifold parts well.  Lots of other errors too but the slicer handles those.

I've fixed the non manifold issues for you but this sort of repair is something you are going to need to learn how to do if you continue downloading files from the usual websites.  So so many of them are broken.

Btw Grant to attach anything to the forum you need to zip it up.  The forum is very picky about allowed file types.  

Also as theres a file size limit here is the top.

 

 

 

Posted : 25/01/2022 8:28 am
Neophyl
(@neophyl)
Famed Member
RE: This model is giving an error with empty layers...why? and how to fix?

And heres the bottom

Posted : 25/01/2022 8:28 am
Robin
(@robin-2)
Eminent Member
Topic starter answered:
RE: This model is giving an error with empty layers...why? and how to fix?

Thanks, what is the best tool to repair broken Models?

Posted : 25/01/2022 5:44 pm
jsw
 jsw
(@jsw)
Noble Member
RE:

I have yet to find one tool that will consistently fix almost all wonky .stl files.

The 'repair' function in PS will fix a few.

Meshlab will fix quite a few of them, but there's a very steep learning curve and lots of trial-and-error.  You can also get some very bizarre results.

The various 'fix' functions under the Mesh menu of FreeCad will fix some.

Reading the .stl into PS and re-exporting it will fix a few of them.

The most consistent results I've had (often with bad models prepared with OpenSCAD) is to read them into FreeCAD, convert the mesh to shape, refine the shape, convert shape to solid, and then re-export.  If it completes all three of the steps you will usually get a printable result.  If it just spins for minutes/hours or gives up on any of the steps, it's badly hosed.

Posted : 25/01/2022 5:52 pm
Robin
(@robin-2)
Eminent Member
Topic starter answered:
RE: This model is giving an error with empty layers...why? and how to fix?

Thanks.  I've tried my hand at design and haven't had these issues.  Do you know what is the cause of the errors?  I'd like to know so I can avoid it in my own designs.

Posted : 25/01/2022 5:57 pm
Lichtjaeger
(@lichtjaeger)
Noble Member
RE: This model is giving an error with empty layers...why? and how to fix?

IMO, Blender is the best tool for manual repair. For auto-repair, I would add MS 3D Builder and Fusion360 to jsws list.

Posted : 25/01/2022 6:00 pm
Neophyl
(@neophyl)
Famed Member
RE: This model is giving an error with empty layers...why? and how to fix?

 

Posted by: @robin-2

Thanks.  I've tried my hand at design and haven't had these issues.  Do you know what is the cause of the errors?  I'd like to know so I can avoid it in my own designs.

As I said in my post the problems are caused by Non Manifold geometry.  The 'simple' explanation of manifold is to think of it as "are the models water tight".  As in if you filled the INSIDE of the model would it hold water.  So no holes in the mesh.  As to how to avoid it, well that depends on your design software.  Some operations in some design tools are more likely to cause it than others.  

I'd agree with Lichtjaeger that Blender is a great tool to manually fix errors once you get the hang of it but its 3dtool add on does a reasonable job of automatically fixing many models and even if it can't it is also great for highlighting problem areas.  Its what I used to get a report of the errors, although I did fix them manually as the 3dprint tool couldn't fix them in this case.  There are lots of other issues with those models like zero faces, thin edges etc but those generally don't cause a slicer issues.

OpenScad for example is terrible at outputting models with invisble 'surfaces' so that when sliced a hole will be filled in.  This is usually caused by a boolean difference operation not cutting past a wall but just up to it, leaving a mathematically thin area.  You cant see it on the stl when loaded but the slicer can when it slices.  Traditionally Cura was better at automatically dealing with those errors but the latest PS2.4 has had some changes to try and cope with them better.  Time will tell.  If we get a drop off of posts by people saying 'slicer has filled in a hole' then I'll call that a success.  Not a Non Manifold issue though, just an annoyingly common one.  

It wasn't until I started using Blender and actually loading in some of the stl's out there that I realised just how many are bad, and just how very badly broken some of them are.  Frankly I'm amazed that the current batch of slicers cope as well as they do.

 

Posted : 25/01/2022 7:26 pm
Robin
(@robin-2)
Eminent Member
Topic starter answered:
RE: This model is giving an error with empty layers...why? and how to fix?

Ok thanks for all the tips!  This explains why I haven't had errors in any of my models.  I've been using solidworks for a long time and I am meticulous about ensuring the model is built without any open contours.

Posted : 25/01/2022 7:39 pm
Share: