How to ignore/override "no extrusions on first layer" error message
 
Notifications
Clear all

How to ignore/override "no extrusions on first layer" error message  

  RSS
M W
 M W
(@m-w)
Member
How to ignore/override "no extrusions on first layer" error message

I'm having trouble slicing a project. The project has parts that have nothing on the first layer by design.

When I clicked Slice", the slicer gave me the error message "no extrusion on first layer Object name xxxx.stl". Toolpaths appear in the main window, but the small window showing feature types by color did not appear.

I can see the tool paths in the main window and can confirm that the toolpaths are exactly what I wanted, but when I clicked on export gcode, the error message pops up again along with an "Exporting" message. The export won't finish.

How do I ignore/override this error and force an export? Thanks!

Posted : 04/10/2023 4:24 am
Diem
 Diem
(@diem)
Illustrious Member

How are you going to print it - without a first layer the part will just create spaghetti or a blob?

Cheerio,

Posted : 04/10/2023 8:43 am
Thejiral
(@thejiral)
Noble Member
RE: How to ignore/override "no extrusions on first layer" error message

You can either load an object as part of another object via right click menu or combine objects to one common object with sub-objects. In both cases it is enough if anything has a first layer, if nothing else add a small single layer high priming cube as part of the combined object.

That said, why would you want to print something without a first layer and how is that supposed to work? 

Mk3s MMU2s, Voron 0.1, Voron 2.4

Posted : 04/10/2023 10:09 am
M W
 M W
(@m-w)
Member
Topic starter answered:
RE: How to ignore/override "no extrusions on first layer" error message

This is fully intentional, it will be supported by other things around it. Done similar things before but the geometry of this one just meant that there is no first layer for some of the models.

I cannot join it into another thing because this model has different settings to the other models around it and is too small for me to use a modifier block (plus modifiers don't give me as much control so it doesn't work)

 

Another less optimal approach would be to make the first layer thinner for only those parts that shouldn't have a first layer or making the first layer extrusion width very small.

With the first layer height, I couldn't find the setting when I right clicked on the particular model. Anyone know how to set first layer height for individual parts? (height range modifier doesn't seem to modify first layer height)

With making the extrusion width super small, the slicer gives me an error message when I do that, is there a way to bypass that?

Posted : 04/10/2023 12:04 pm
Thejiral
(@thejiral)
Noble Member
RE:

I do not understand why you would not be able to combine the objects in Prusa Slicer. The objects will be still selectable and modifiable individually afterwards, they will merely be part of a master collection of objects. You should be able to retain all the different settings for the individual objects, no matter if combined or not. If I am not mistaken.

It also does not really matter with what you combine, if combining with adjacent objects doesn't work for you, simply create a small dot anywhere on the surface and combine it with your floating object of choice, you can use the same settings then for everything that is combined as you do not really care about that dot anyway, only Prusaslicer does. 

It is correct that the slicer might slice differently when you have a collection of separate objects vs objects which are combined in the slicer. So the dot solution might be what you are looking for.

I don't think there is a way to make the extrusion width super small in Prusa Slicer. It is easier to bypass the first layer warning I would assume. Maybe one can locally change the extrusion factor with height modifier or modifier? Not sure. That should have the effect you want to achieve though, if possible. 

 

This post was modified 5 months ago 5 times by Thejiral

Mk3s MMU2s, Voron 0.1, Voron 2.4

Posted : 05/10/2023 6:46 am
fuchsr
(@fuchsr)
Famed Member
RE: How to ignore/override "no extrusions on first layer" error message

I have a hard time visualizing what you're tying to accomplish. Can you post the 3mf project file? Or if it's proprietary some mockup that preserves the geometries involved?

Posted : 05/10/2023 10:25 am
Share: