GCODE temperature does not match prusaslicer v2 setting
 
Notifications
Clear all

GCODE temperature does not match prusaslicer v2 setting  

  RSS
crtrepan
(@crtrepan)
New Member
GCODE temperature does not match prusaslicer v2 setting

Using prusaslicer 2.1.0 on mac, on the filament setting page I set the extruder to 205 but the exported gcode says M109 S200;.  I have also changed the bed temperature to 55 and this one works: M190 S55 ;  Is there a maximum extruder temperature setting I am missing or is this an issue with the software?

Posted : 10/11/2019 6:59 pm
Sembazuru
(@sembazuru)
Prominent Member
RE: GCODE temperature does not match prusaslicer v2 setting

Make sure you also change first layer temperature to 205. These temperatures are well within the temperature range (I just finished creating a profile for Proto-Pasta HTPLA-CF and that is 240 with first layer 255 (these are Proto-pasta's suggested temperatures).

I'm actually not sure if PrusaSlicer has a max temperature that it can create g-code for. I think it will take what ever you give it. (Whether the target printer can actually reach that temperature is another consideration entirely...)

See my (limited) designs on:
PrusaPrinters - https://www.prusaprinters.org/social/1448-sembazuru/prints
Thingiverse - https://www.thingiverse.com/Sembazuru/designs

Posted : 11/11/2019 6:10 am
crtrepan
(@crtrepan)
New Member
Topic starter answered:
RE: GCODE temperature does not match prusaslicer v2 setting

@sembazuru

Thanks for your quick response, yes I had both the 1st layer and other layers set to 205.  So I ran some more tests and found out that if I have a temperature setting in the start gcode (M109 S200;) then prusaslicer will ignore the filament settings and leave the extruder to 200 degrees; if I remove the M109 from the start gcode then prusaslicer correctly sets the first layer temperature then changes it for the other layers.  I don't think it should behave this way but at least I will now be able to run print jobs at different temperature. 

Posted : 11/11/2019 4:32 pm
Sembazuru
(@sembazuru)
Prominent Member
RE: GCODE temperature does not match prusaslicer v2 setting

Another alternate is to replace the "M109 S200;" in your start gcode with "M109 S[first_layer_temperature];". Then when you slice PrusaSlicer will replace "[first_layer_temperature]" with the value that you specified in the filament profile for the first layer temperature.

I actually use a slightly modified variant of @bobstro's start gcode that is explained here: http://projects.ttlexceeded.com/3dprinting_prusaslicer_gcode.html

This firmware gets the extruder warm (160°C or so) to help clean schmutz off the nozzle but not allow the filament to ooze during mesh leveling, uses the warm bed to heat the PINDA probe into it's temperature calibration range for more accurate mesh leveling, then performs the mesh leveling and finally heats the nozzle up to the first layer temperature.

This start code does add a significant amount of time to one's print, but I've decided that for myself I'm willing to trade a little time for a better first layer (and not cleaning ooze dots off the bed after the mesh leveling).

See my (limited) designs on:
PrusaPrinters - https://www.prusaprinters.org/social/1448-sembazuru/prints
Thingiverse - https://www.thingiverse.com/Sembazuru/designs

Posted : 11/11/2019 5:08 pm
crtrepan
(@crtrepan)
New Member
Topic starter answered:
RE: GCODE temperature does not match prusaslicer v2 setting

@sembazuru

At first sight it appears to behave correctly, I'll play around with it some more while keeping an eye out just in case.

Thanks a lot

Posted : 11/11/2019 7:03 pm
Share: