Enforce Closed Shell on Multi-Material Slicing
 
Notifications
Clear all

Enforce Closed Shell on Multi-Material Slicing  

  RSS
F Poll
(@f-poll)
New Member
Enforce Closed Shell on Multi-Material Slicing

Hi there, I discoverd the following behaviour when slicing multi-part objects with the Prusa Slicer (tested 2.3.3, 2.4.1 and 2.5.0 alpha2):

When two neighbouring objects touch each other in the horizontal plane, the slicer does not created a closed shell (walls all around) for each object, but rather transitions between the objects with infill. This can be wanted behaviour, but I need to enforce a closed shell for every single part of a multi-part print. Is that possible to achieve with the Prusa Slicer? 

Here is an example picture of the described problem:

What I try to get is the way Cura handles the same multi-part constellation. Every part has a solid outer shell, not infill touching infill between parts.

 

 

I'm looking forward to your tips and suggestions 🙂

Posted : 04/07/2022 8:38 am
Diem
 Diem
(@diem)
Famed Member

Either: Create seperate files, load them together and tell the slicer to treat them as a multipart object.

Or: Seperate the parts by a small, positive value - say 0.01mm, and the slicer will treat them as a multipart object...

Cheerio,

Posted : 04/07/2022 9:20 am
F Poll
(@f-poll)
New Member
Topic starter answered:
RE: Enforce Closed Shell on Multi-Material Slicing

Hi Diem, I already import the the objects, which are 2 seperate files, togehther an tell the slicer to treat them as a multipart object (see the partslist on screenshot one). I think this is just how Prusa Slicer handles a multipart object with neighbouring parts in the horizontal plane. I can email you the files if you want to replicate the shown behaviour. 

Posted : 04/07/2022 10:40 am
Neophyl
(@neophyl)
Famed Member
RE: Enforce Closed Shell on Multi-Material Slicing

Please post your zipped up 3mf project file (File>Save Project as from PS).  That gives us the models and all the settings you are using in one neat file.  Must be zipped to attach to the forum post.

One setting to check is the slice gap closing radius , in Print Settings>Advanced>Slicing.  Its normally set to 0.049mm by default.  Any parts closer than that in effect get considered as one for slicing.  It often causes issues on tolerance test models.  Not saying thats the case here but it could be.  The 3mf file will be the best help.

Posted : 04/07/2022 2:36 pm
F Poll
(@f-poll)
New Member
Topic starter answered:
Solution found

I just found the setting that was wrong, and now feel kind of dumb 🙃

Print Settings -> Multiple Extruders -> Advanced -> Interface Shells has to be set, and it was not in my config... 

Thank you all for your suggestions!

Posted : 05/07/2022 6:45 am
Share: