Can't really change print speed
Clear all

[Solved] Can't really change print speed  

New Member
Can't really change print speed

In prior versions of Prusaslicer (before 2.5.0) whenever I changed a specific setting like Print-Settings/Speed/Perimeters the resulting printtime would change. Now if  I specify a higher print move speed, nothing changes.

I can set the speed to 1000mm/s, change the x/y acceleration and the displayed perimeter print speed value remains the same. I know the printer can't print at these speeds, it's just used to see what the effect would be.

Whatever other values I change does not help either. I test this on an box.stl gallery shape.

Any suggestions to what makes the slicer ignore the changes I make.


Currently I'm testing this on my Ender-3 V2

This topic was modified 2 months ago 2 times by Boja
Posted : 25/11/2022 3:20 pm
Honorable Member

If you change your machine's limits in your printer profile it has no effect on the speed values in the print profile - why should it? The acceleration and feed rates on your printer profile limit the speed the extruder reaches during print. The values on the print/speed page are the maximum values that can be reached if nothing else is limiting (e.g max volumetric speed). What is limiting depends on what you are printing, increasing the machine limits might not affect the print time if they are not limiting for your print (printer never reaches the limits). Same goes for print/speeds values. You can better see the effect if you decrease values until the one you are manipulating becomes limiting and affects the print time...

This post was modified 2 months ago by Robin

If at first you don't succeed, skydiving is not for you.

Posted : 26/11/2022 12:15 pm
Famed Member
RE: Can't really change print speed

Also without a saved project from your setup then we cant know what you are running.  You could be running into max volumetric limit for example.  

Posted : 26/11/2022 12:43 pm
New Member
Topic starter answered:
RE: Can't really change print speed

My problem is the same as the user Jiří Fiala has, and he found out what the problem was.

When the "Enable Auto Cooling" option in Filament settings is set, other speed related options is ignored.


When disabled the slicer works as expected.

Posted : 30/11/2022 10:58 am