Notifications
Clear all

Tower home error  

  RSS
eric.p5
(@eric-p5)
Active Member
Tower home error

Assembled my kit (5 hours), went through initial setup and calibration fine, no problems.

Tried my first print, print didn't stick. Was using some old leftover resin so not shocked. Cleaned everything up and switched to the bottle of Prusa Orange Tough that came with the printer.

Tried to print again, tower home error. (Of course it tells you this after you've filled the tank with resin.)

Cleaned everything up again, went through calibration again, everything fine.

Tried to print, got tower home error again. It says to 'check hardware.' But I have no idea what I'm supposed to check. The booklets that came with the printer don't mention this error code. Haven't found it online.

The tower comes as a mostly pre-assembled unit. I used the cardboard as in the instructions to align everything.. And it gets through calibration with no problem.

Any ideas? I've sent an email to support also but I thought I'd check here too, and post an answer for anyone else who runs into this.

Posted : 07/12/2019 2:32 pm
Matt liked
eric.p5
(@eric-p5)
Active Member
Topic starter answered:
RE: Tower home error

Tried redoing the whole wizard. Everything went fine in the wizard, but then when I tried to print it had the same 'tower homing error' and says 'check hardware.'

I still have no idea what to check. I've checked obvious screws on the tower, they are all tight.

Posted : 07/12/2019 6:33 pm
eric.p5
(@eric-p5)
Active Member
Topic starter answered:
RE: Tower home error

Chatted with support, they suggested a factory reset and latest firmware. It already has latest firmware so I factory reset and went through the wizard yet again. It is printing now, we'll see if it actually works, but past the earlier problem.

Also through this I learned the hard way to hit 'print' first, then wait for it to do its checks and only pour the resin in when it tells you too... saves a lot of cleanup if something goes wrong... 🤔 😓 

Posted : 07/12/2019 7:28 pm
AndrewH liked
malcinator
(@malcinator)
Trusted Member
RE: Tower home error

That’s odd. I used the my SL1 a couple of days ago and printed without issue. Then today, a few hours ago I had the same problem. I recalibrated twice without sucsses. I had the 1.3.0.beta0 firmware (due to the blower fan problem) installed and assumed it was related to that. I downloaded the 1.2.3 firmware and the problem went away, didn't do anything more than that. Started a print, the same one as before and it completed with out issue.

Posted : 10/12/2019 12:52 pm
eric.p5
(@eric-p5)
Active Member
Topic starter answered:
RE: Tower home error

Yeah I'm wondering if there is some slight firmware issue, because after the factory reset everything is working fine, printing happily.

Posted : 11/12/2019 2:16 am
Squrkk
(@squrkk)
Active Member
RE: Tower home error

I just ran into this today (my second weekend of printing after building the kit).  The weekend I finished the kit printing several objects was fine.   This weekend I started seeing the Tower home error every once in a while.  I re-calibrated and I still see the error every so often (more often with resin in the tank). 

For now I just restart prints or re-homed until it works (sometimes is takes a few tries).  I'm also on the latest firmware.  (I might try factory reset soon).

Has anybody else run into this issue lately?

Posted : 14/12/2019 6:06 pm
Matt liked
Squrkk
(@squrkk)
Active Member
RE: Tower home error

Also, is the tower supposed to hit the top a few times while it is homing?

Posted : 14/12/2019 6:17 pm
ejberg
(@ejberg)
Estimable Member
RE: Tower home error
Posted by: @squrkk

Has anybody else run into this issue lately?

Yes, I just got hit by the same bug.

My SL1 is a preassembled one, and I printed my first print yesterday. No problems whatsoever.

Today I started another print. After a couple of hours I could see that nothing was hanging down from the buildplate. I cancelled the printjob, and the Z axis banged against the top 20-30 times (didn't count the exact number). After that I couldn't restart a print anymore. Tower home error every time.

I then tried to manually steer it about halfway down, turn off the power and then back on. And now it homes and prints again.

Posted : 15/12/2019 2:20 pm
David T.
(@david-t)
Noble Member
RE: Tower home error

I hit the same bug (most likely) as well. The difference is I didn't use "cancel print" feature, it happened between two subsequent prints without turning the printer off. It was a third print in a row actually. I resolved it the same way - manually moved the platform down and then new start of printing, everything went OK after that.

Posted : 17/12/2019 11:12 am
David T.
(@david-t)
Noble Member
RE: Tower home error

I hope I'm not speaking too soon, but it seems the issue is gone with new software 1.3.2.

Posted : 27/02/2020 7:17 pm
David T.
(@david-t)
Noble Member
RE: Tower home error

Sadly, I spoke too soon. I hit the issue several times in a row yesterday even with the latest firmware. 😐 

Posted : 05/03/2020 8:48 am
Halo Jones
(@halo-jones)
New Member
RE: Tower home error
Posted by: @ejberg
Posted by: @squrkk

Has anybody else run into this issue lately?

I then tried to manually steer it about halfway down, turn off the power and then back on. And now it homes and prints again.

Had this issue today, nothing had changed all firmware up to date, printed yesterday fine, today get the Tower Homing Error.

Did a factory reset & recalibrated, no joy.
Then tried the hint above to

move platform mid way down, 

Shut down printer

unplugged printer

left it 5 min

turn back on

use setting command to home platform 

Printing fine now

🙂

Posted : 02/12/2020 3:50 pm
Matt
 Matt
(@matt-15)
Active Member
RE: Tower home error

Has anyone been able to resolve this? I'm on the latest firmware 1.4.2 and I'm getting the tower homing issue, it was also present on the previous firmware too. I have reduced the tower sensitivity with no luck, factory reset too 

Posted : 17/02/2021 1:50 pm
WeichNudel
(@weichnudel)
Active Member
RE: Tower home error

Im on the current firmware and noticed that it will stay stuck in "homing/ resetting tower position to top" if there was no resin in the bed. First I've done it, because I was afraid of another UV fan lamp error and second time was for reproducing. 

Only shutting down the printer got me out of this

 

Posted : 12/05/2021 5:49 am
Brambo09
(@brambo09)
New Member
RE: Tower home error

I ran into the same issue we are all describing where the build plate component will repetitively hit the end (top part) of the threaded lead rod on the Z-axis. It appears to be a random event since I have had successful prints in between the issue.  What I see is the build plate component doesn't know what to do besides continually hitting the top "end stop" on the Z-axis and will not stop until I power off the machine.

I have tried manually turning the lead rod with little to no fix to the issue but it seems that resetting the software from my current version 1.6.3  to my last downloaded firmware of 1.6.0 fixes the issue.

Posted : 14/12/2021 7:01 am
Matt
 Matt
(@matt-15)
Active Member
RE: Tower home error

There are a few things to try that you can do on your end which is lubricating the tower leadscrew and lowering the tower sensitivity in your settings, my tower ended up being faulty though and it had to be sent back for repair, it has been fine since, but I would try the first two suggestions as there is a good chance it could resolve it

 

Posted : 14/12/2021 7:08 am
ejberg
(@ejberg)
Estimable Member
RE: Tower home error

There is something weird going on in the last few firmware versions (at least 1.6.2 and 1.6.3).

My tower axis always gets itself stuck when powering on the printer, leading to tower home error when starting a print.
I found that manually lowering the build plate through the menu, unsticks it after 2-3 attempts. Then the printer operates (and homes) without problems, until the power is turned off.

Posted : 14/12/2021 8:32 am
JPMakesStuff
(@jpmakesstuff)
Active Member
RE: Tower home error

Just chiming in that I have this problem too.  SL1S, happens almost every print.

I do believe the normal procedure is for it to "self home" by hitting the top a few times, but if the tower is already too high (as it almost always seems to be) then there isn't enough travel for the self home to work, and it endlessly keeps slamming into the top.  I'm not sure if this is a travel distance thing, or measuring the resistance/current of the motor when it hits the end - but it isn't working.

I now remember to manually move the screw so the platform is half an inch more down.  For me, using the on-screen menu to move it down doesn't do the trick, either the software is counting steps and knows what I tried to do, or it's just messed up, but I have to manually rotate the screw to get another print to go.

Posted : 31/01/2022 1:00 am
p.diederiks
(@p-diederiks)
New Member
RE: Tower home error

I run with firmware 1.6.4, and now I'm faced with the same issue of the Tower Home error,
 move the screw so the platform is half down, switch of, switch on, home the tower.

had to do this several times before the printer started printing again.

Posted : 12/03/2022 10:09 pm
p.diederiks
(@p-diederiks)
New Member
RE: Tower home error

I run with firmware 1.6.4, and now I'm faced with the same issue of the Tower Home error,
 move the screw so the platform is half down, switch of, switch on, home the tower.

had to do this several times before the printer started printing again.

Posted : 12/03/2022 10:10 pm
Share: