Clear all

MMU2S/3 IR Sensor Issue - Steps Taken To Resolve  

Eminent Member
MMU2S/3 IR Sensor Issue - Steps Taken To Resolve

Hey all. Thought I'd document what steps I took to resolve my IR sensor issue with my MMU2S that I've been having so far.

Please note that I recently flashed my MMU2S to the MMU3 firmware, but nothing physical has changed on the MMU2S except the addition of the MMU3 IR Tower on the extruder. I am using a MK3s+


I have had two major problems with the MMU2S: firstly, I was receiving the dreaded 5 red/green LED warning whenever I tried loading filament from the idler to the extruder.

To resolve this, I ended up plugging in a USB cable from my RaspberryPi (running OctoPrint) to the MMU2S unit. The extra 5v juice coming from that cable to the unit has meant that since then I've not had the issue any more.

Secondly, my unit had issues loading filament to the extruder. This became particularly annoying after I flashed the firmware to the MMU3 when Prusa released it. This was due to how the IR sensor works; it loads the filament in until it triggers a '1' on the sensor, then it retracts it 30mm before pushing it 40mm back into the extruder. Only if it receives a stable '1' on the IR sensor does it continue. If it doesn't, it unloads and tries again. I can't tell you how many cycles of this I went through, but it was too much. I went and purchased the new 0.4 IR sensor to replace my 0.1b IR sensor that came with my kit, but the result was still the same.

I got onto Prusa Support about this particular issue, and they were stumped. I sent them pictures and videos of the extruder body, of each part and the load/unload in action. Support ended several hours later (even after swapping agents because the first one's shift ended) with "I'll have to speak to the dev team and we'll update you by email". So, I kept looking into the parts of my machine to see what was going wrong.

I noticed that the idler door on the extruder wasn't bending open like it should; when filament enters the hotend, it squeezes between the two gears. This action causes the IR idler door to swing out, which in turn makes the top of the arm push in through the sensor triggering a '1'. On mine, instead of it pushing out, it went kind of sideways. Secondly, I noticed that even when the idler arm went into the sensor (i.e. when I manually pushed it there) it would flicker between '1' and '0'. Now, I did try moving the X-axis to see if it could have been a broken cable somewhere along the line, but no joy. Moving the axis didn't make the issue worse or better.

I opted to reprint the IR idler door, as well as the MMU2S R6 extruder body parts. My previous parts were R4 and C1 from when I first upgraded my Mk3 > MK3S > MMU2 > MMU2S + MK3S+

Printed the new IR idler door and R6 body parts in PETG at 20% grid infill. Slapped them on, made sure everything was tight and aligned and... same issue.

So, I tested the IR sensor with a piece of red filament I had. It continued to flicker between '1' and '0'. Then I had the brilliant idea of painting the tip of the IR idler arm with some black paint I had. Reassembled it, and boom. No more flickering between '1' and '0'.

I wonder if it's the IR sensor having trouble picking up the filament passing through it; whether it's too shiny or reflecting the signal or something, but this worked for me.

Posted : 18/08/2023 2:57 pm
Active Member
RE: MMU2S/3 IR Sensor Issue - Steps Taken To Resolve

I am curious what color you printed your chimney parts in. I tried finding where it was mentioned but I recall a recommendation that all chimney parts including the idler door be printed in black which would align with your piece of red filament painted black experiment.

For clarification, were you using the MMU2S prior to the MMU3 firmware update without issue or was this solely a new MMU3 chimney issue?

Posted : 22/08/2023 2:03 am