FINDA stops working halfway through print, sensor value stuck at '1'
Clear all

FINDA stops working halfway through print, sensor value stuck at '1'  

New Member
FINDA stops working halfway through print, sensor value stuck at '1'


I am encountering a problem where after printing about half my parts, the FINDA sensor reading gets stuck at '1'.  Nothing I can do can unlock it besides power cycling the printer.  Usually by this time, I have had to manually fix some MMU load errors, but otherwise the prints are doing fine.  Is anyone else having this bug?    

The FINDA itself seems fine, the LED light blinks when I put a wrench near it.  It seems like the software is getting confused.  I have logged this issue in Github as well.

Posted : 26/04/2019 6:19 pm
Noble Member
RE: FINDA stops working halfway through print, sensor value stuck at '1'

is the ball getting stuck?  the first time I took the selector out to clean it.. I was shocked at how dirty my ball was......well that just sounds wrong 😀


not that the ball itself was dirty.  but there was a metric crap ton of colored dust around it.

This post was modified 3 years ago by toaf

I have a Prusa,therefore I research.

Posted : 26/04/2019 9:27 pm
Eminent Member
RE: FINDA stops working halfway through print, sensor value stuck at '1'

My MMU2 is also doing this among other issues. I've been trying to get it to do the main issue on camera now for a few months. I finally was able to get it recorded and talked to support a few days ago again. They went through a bunch of troubleshooting steps, which unfortunately I had already tried. They then thought my finda was faulty except this is the third finda I've tried on the mmu2. After hearing I have tried to replace the finda they said they would send me a replacement board. The new board will be here Monday. I will report back if the issue happens with that one as well.

Posted : 27/04/2019 8:20 pm
Eminent Member
RE: FINDA stops working halfway through print, sensor value stuck at '1'

I just started having pretty much the same problem. It started with prints failing mid print with various issues. Eventually it could not even start a print. After heating up and doing the bed check, it "tries" to feed the filament, it feeds it in and out two times then "retracts" the filament "out" of the MMU2 unit, BUT the printhead stops and I get a message that the MMU had a load issue. After trying to figure out what was happening, I checked the sensor status, and saw that the MMU2 Pinda was showing a "1" indicating that filament was still in the MMU2 unit. I pulled the filament completely out and the "1" still showed as the status. I took out the Pinda from the MMU2 unit, and it still showed a "1", The only thing that cleared the "1" was to restart the MK3. After the reset, I was able to verify that the Pinda was working by feeding a filament into the MMU2 unit, and readjusting sensore and the "ball" so when I inserted the filament it went from zero to 1. However, when I restarted the print, it never starts, it just errors out the same way, and the sensor is once again stuck at "1". I did this about 3 times with exactly the same results. Seems like a possible problem with the MMU2 board or the Pinda Sensor. I guess I'll have to send a support request to Prusa support. (btw, I was only using the MMU2 with single filament gcode so everything was "clean" with no real problem with any dirt or filament jamming the Pinda area. I did check and clean the sensor area but it was pretty clean.)

Posted : 03/05/2019 4:10 am
Dick V
Eminent Member
RE: FINDA stops working halfway through print, sensor value stuck at '1'

Hi, I have exactly the same issue as "wdgeek" described!

Posted : 03/05/2019 9:20 pm
Active Member
RE: FINDA stops working halfway through print, sensor value stuck at '1'

I have the same issue. The LED on the FINDA is working correctly but the value on the LCD is stuck on "1". 

Firmware Versions:

Printer: 3.7.0

MMU: 1.0.5

This post was modified 3 years ago by sven.j
Posted : 07/05/2019 11:24 am
RE: FINDA stops working halfway through print, sensor value stuck at '1'

During a print, the only time the FINDA sensor should display a zero is during a tool change.

Unfortunately, when the printer puts in a call to the MMU to carry out a tool change, the function call is a blocking call - the printer simply does nothing until the MMU passes back control to the printer.  So even though the FINDA LED changes state, that state change is not registered by the printer and therefore it cannot display a zero on the LCD.

Outside of when a model is printing, any change of state on the FINDA LED should be echoed on the LCD.   If not, there's a problem somewhere.

If you get ground filament blocking the FINDA ball, then you could have tension issues at either MMU or Bondtech.  If you have fine strings blocking the FINDA ball, then your unload strategy is wrong.



Please note: I do not have any affiliation with Prusa Research. Any advices given are offered in good faith. It is your responsibility to ensure that by following my advice you do not suffer or cause injury, damage…

Posted : 07/05/2019 3:27 pm
Dick V
Eminent Member
RE: FINDA stops working halfway through print, sensor value stuck at '1'

Thanks Peter, that makes sense!

I tried this week the MMU2S improved selector of  Martin_au and the MMU2 PTFE M10 passthrough adapter from Vertigo 235.

This improved the filament flow quit a lot but still no reliable multi material setup.

The facts :

Printer firmaware: 3.7.0 MMU2S firmaware 1.0.5

MK3S & MMU2S in single filament mode working perfect, both sensors, IR and MMU tested and working OK.

Gear alignments tested, tested and..... TESTED:)


During multiple filament mode the MMU2S will fail after a few filament changes.


1) The MK3S/MMU2s is very sensitive for the friction the filament encounters during the entire transportation flow.

Ad 1)

I setup my entire filament flow with as little friction as possible except where it should be: At the BondTech gears in the extruder and the MMU2s.  Test it from the entrance of the buffer you use all the way through the gear in the extruder by pushing it with your fingers, it should be without any serious friction. During this test open the MMU2s Idler and guide the filament manually!!

2) I think the filament flow is most of the times disrupted during the transition from the PTFE tubes to the printed (0,2mm Prûsa farm printed) parts. In my case the weak spot seems to be the transition of MMU2s Pulley-Body to the Selector, both original selector and the improved version by Martin_au. 

Ad 2)

Post proces the printed parts to remove any strings and the 0,2 mm layer flaws at the entrances of the filament.  A 2mm drill and a Dremel with a conic plastic suited sandstone will do the job! (Testing it as we speak!)

3) The MK3S/MMU2s and the filament quality in terms of brittleness and bending is also an issue. Even with a sharp diagonal cut tip.

Ad 3) I have almost no issues with filaments like Innofil3D and ColorFabb. PLA and PETG in my case are causing a lot of issues.

Conclusion, for the moment and open for feedback!

The MMU2s is still relative new and still need some improvements.

In the meanwhile you all received the MK3s upgrade for free! Did you all noticed the incredible quality of this new extruder?

The MK3 extruder was already perfect, but the MK3s is really awesome!

Ok, this was my contribution for the moment, stay tuned!

Disclaimer: I am an independent AM consultant with no relation to any 3D printer or filament manufacturer. Big fan of Prûsa research and FUSION 360!


Posted : 07/05/2019 11:17 pm
Active Member
RE: FINDA stops working halfway through print, sensor value stuck at '1'

Having installed the MMU a year ago I had the feeling that with every new firmware update the behavior of the whole system was rather getting worse. Seeing I am not the only one experincing this problem and summing up all the other strange behavior of my MK3 with the MMU I decided to remove the MMU completely and start from the beginning.

Know without the MMU the printer is running smoothly and even the print quality improved!

A short explanation how I came to my conclusion about the source of all these problems.
I compared the above mentioned printer behavior with my experience with octoprint on a Raspberry Pi ZERO board, as recommended in the prusa manual.
It's running but when I wanted do to some timelaps videos and installed the plugin octolaps, the print time more then doubled and the qulity decreased. I surfed the net and found out that the use of a Pi ZERO with octoprint is NOT recommended, because it has not enough perfprmance. Instead they recommend a Pi 3B+ board. Getting one of these I tried it out and all the probs where gone, normal print time normal quality.
Seeing how a more powerfull board was solving this problems and seeing that with each extension to the MK3 the performance of the printer got worse and was back to normal when I removed all this stuff, I say the hardware (8 Bit Einsy Rambo Board) is not powerful enough to control all this additional equipment. The code is getting to big and eventually it gets stuck somewhere, or its simply not enough memory availible to implement all the needed code to serve all the possible events which can occure during a print.

For this reason I will live without my MMU. Hoping there is either a more powerful upgrade board from prusa or from somewhere else.

Posted : 25/08/2019 6:18 am
Trusted Member
RE: FINDA stops working halfway through print, sensor value stuck at '1'

Just sharing my own observations here:

I have print is running perfectly, filament changes are running fine, FINDA LED is changing states as it should during the changes, but the Sensor Info screen continually shows FINDA state as "1".

I posted this same observation in the following github issue:

This post was modified 3 years ago by spiff72
Posted : 12/01/2020 7:42 pm
Trusted Member
RE: FINDA stops working halfway through print, sensor value stuck at '1'

Yep I have this same problem. The prints run fine so I'm guessing it is correctly reading the FINDA value but it is not displaying properly in "Sensor Info" (stuck high on 1, through hundreds of tool changes). I do use Octoprint so not sure if that is related at all.

Makes debugging it a pain as you have to reset the printer to make it correctly read again (until the next print).

This post was modified 3 years ago by nimaim
Posted : 13/01/2020 1:25 pm
New Member
RE: FINDA stops working halfway through print, sensor value stuck at '1'

I am suffering from the same problem that colleagues report here.

It has been almost 9 months after purchase and I have never been able to successfully print a colored object.

I initially bought an MK2S and then bought the MMU1 and now recently the MMU2.

I feel very disappointed with these updates that were sold to the PRUSA printers (MMU1 and MMU2).

But the main issue is that I feel cheated, because I thought I had bought a printing solution and apparently I bought an infinite problem.

Because I spend more time using forums correcting problems for defects that in my view should have been seen by the team that developed the product during the homologation stage.

I already had to change the heat sensor of the printing table, the sensor of the print head, the printing table and now I wonder what will be the next piece?

I apologize to everyone for the outburst.

Posted : 15/05/2020 3:22 pm
Rick Houlihan
Eminent Member
Similar problem here

I am starting to see something similar...the MMU will fail with a fast blinking red light indicating that an unload failure occurred, but the filament is unloaded and all the sensors seem to be clear.  I ran the job from USB and below is the log from the Pronterface console.  It looks like it finishes the unload then gets stuck, and once this happens there is no way to clear the error except power cycle.  Seems like a firmware bug.


Posted : 05/10/2021 2:30 am