MMU2S Loading problems and problem loading filament port 5
Clear all

MMU2S Loading problems and problem loading filament port 5  

Active Member
MMU2S Loading problems and problem loading filament port 5

I added the MMU2S to my MK3S over Xmas but only today got to turning it on and checking everything. 

I followed the guide, got the latest firmware and flashed both the printer and MMU unit.

I loaded each filament individually using the LCD menu. Each went through the process correctly. 

I calibrated the IR filament sensor:
1) I made sure the filament was not loaded to the print nozzle
2) I unscrewed the "Festo fitting on the extruder" - This was not clear as to what the Festo fitting was. I assumed it was the tube and connectors between the MMU and the print head. Initially I undid the one attached to the MMU and found a cut off bit of the filament from reel 2 in the festo fitting. There was also the tail end of the filament poking out of one of the slots. I removed the off cut and manually pulled the filament tail end so it wasn't protruding out. The blade then fell out 😐
3) - 10) I followed the rest of the IR filament sensor calibration with everything working.

I then calibrated the z-axis with no problems.

Next was the first layer calibration. I tried which each filament port and none would load.

I then tried each by first going to the Load Filament to Nozzle selection and then carrying out the First Layer Calibration with each... all worked doing it this way except filament port 5. I tried different filaments from different suppliers and tried PLA, PETG and Flex. The extruder recognised they were there but the gears just didn't grab the filament. I could push it all the way through to the nozzle manually but would then have to extract manually.

I've checked the pully alignment and they're all good.

Any ideas how I can get port 5 working?

Posted : 08/03/2020 5:32 am
ShadowVVolf and liked
New Member
System Based Flaw

I've hoped firmware updates would fix this and you may be able to find a custom one that does. The issue is the rotation of the selector fails to rotate completely for the fifth port. What I have done to remedy this is to manually rotate the selector so that the fifth port's bearing is resting at the front of the filament when idle, that way when it goes to move the filament the bearing will rotate onto the bondtech gear. Obviously this throws it out of alignment for the other 4 ports so you'd have to let the mmu2s re-calibrate itself or rotate the selector back to its original position. 

Long story short the MMU2S isn't bad if you want a platform that you need to invest heavy amounts of time to modify to get it to work correctly and try not to use the fifth port.

Posted : 23/08/2021 8:21 pm
Reputable Member

Or you could contact Prusa Support and let them help you troubleshooting.  

The MMU can be difficult to setup. But will work fine if you have it setup correctly.  Mine prints just fine with all 5 filaments without intervention. 

Posted : 24/08/2021 10:44 am
ssill2 liked
Noble Member
Agree with Baklin

The MMU is a sob to get working but support saved me from chucking the darn thing in the garbage.  And now I can do 3d prints that have 1800 filament changes.   I've even reprinted all the MMU parts in custom color PETG.  the only real change from the stock config for me ended up being using 2mm ID for the tubes from spools and between the MMU and the extruder and the Festo style connectors mod on the back of the MMU where the tubes come in from the spools. 

Key points for me were:

IR sensor config
FINDA sensor config
Correct screw adjustment on the two MMU spring idler bolts, a turn or two below the surface
And the final one that got me pass the loading errors etc was the correct idler bolt tension at the extruder, the tip of the bolt should be flush with the nut under the hex window.

This is really all it took for me.  I do soluble filament prints and the soluble is always loaded from fifth position without issues.

Posted : 12/09/2021 4:21 pm