Clear all

IR sensor  

Eminent Member
IR sensor

Massive headache with this device, but I guess this has been said a thousand times over. After 2 months of fixing all the issues, all that remains is the IR acting up. That thing is so finicky, even with all the manual calibrations and mods. What do I do when the filament is loading, and the IR reads 1 without flickering, yet the device unloads filament unexpectedly?

Posted : 11/06/2022 3:27 am
Active Member
RE: IR sensor


I would hazard a guess that we all have had this issue either when first using or after a crash and I have no doubt that you have tried some of what I am going to suggest

The way this thing works is the MMU pushes until it the IR sensor detects the filament and then the bondtech gears in the extruder take over and the MMU becomes inert.  If the Extruder  does not send a signal to the MMU or the tension is too great it will abort the load.  It tries again two more times then comes up with a mmu error.

Try this for an experiment to see if the sensor is the issue.

1. Remove the PTFE tube at both ends

2. Do a load to nozzle, the mmu will just keep pushing the filament.  When you have about 1.5 times the length of the PTFE tube insert it into the extruder.  If it loads you can assume the IR sensor is telling the bondtech gears to load properly.  (obviously) do not try to print like this.  Unload asap. 

If this works you have a tension problem.  This is caused by filament path being restricted at some point.  (most commonly where the long PTFE tubes go into the back of the mmu. ) Check the path and ensure the four screws holding the plate are not too tight (common error). 

The other one I have seen is a bend in the PTFE tube itself causing issues.    While it is out try pushing the filament through it by had to see it if moves with minimal resistance.  if it fights you the whole way it will not be helping the issues. My machine was touchy and I had to change to a 2.5mm internal tube and it solved my issues.

Common Problems (  I suggest you do this if you have not already anyway)

The IR sensor is not pushed far enough to the right.   This is one I had, it looked ok.  Solution.. loosen the holding screws and push it over.  I used a pick but a jewelers screwdriver works as well.  Whilst holding it in postion tighten the screws back up

The idler screw is not correctly positioned.   (again a problem I had on startup).  Solution ... (do this cold and turned off)

a. loosen the idler screw all the way and cut a piece of filament approx 20 - 30 cm long.   (too long is not a problem. too short is)

b. push the filament into the extruder until you hit the hotend.

c. Tighten the screw until you can move the filament by hand with high resistance

d. pull the filament out of the extruder you should hear a click or a thud.  Have a look at the IR sensor.  Done right you will see the movement as the filament goes in and out.


One more abstract issue is one I had after a power spike crashed my machine, I flashed the firmware but the MMU did not take even though it said so.   I flashed it again and the problem stopped.


I hope this helps 


Posted : 23/06/2022 11:36 pm
Robin liked