Notifications
Clear all

Help me end my cycle of issues  

  RSS
Court Greaves
(@court-greaves)
New Member
Help me end my cycle of issues

Hello guys,
So i've had my MK3/MMU2 for a few years now. Done a decent amount of prints without issues.
I then had a request to print some ASA with 100% infill. After a few prints it basically killed my hotend and i started getting filament leaks.
On and off for months i tried to fix this. Either i'd get leaks or i'd get clogs. Over these months i basically replaced my whole hotend but i still had the same issues.
Recently i knuckled down and bought a new hotend from Prusa.
Given that i'd have taken apart my hotend X number of times over the months this was a like a 4 minute swap for me.
After installing it i ran the PID and first level calibration and got to them to where i wanted them.

Thought i was out of the woods. Started a print and found my printer would do a bed level and then eject the filament and want to change it. It did this over and over again.
I then updated the firmware to the latest version but ran into an issue connecting to the MMU2. No matter what i try it cannot find it.
I've tried uninstalling/reinstalling the slicer. No luck.

So i ignored this and went to print.
When i go to print i get a mismatch error on the MK3 screen but it still loads.
It goes through the bed leveling check and then loads the filament. At this stage it gets stuck. It just keeps pumping more and more filament into the hotend. Almost like it thinks it doesn't have any. After a few minutes it tries to eject the filament but can't and then goes into error.

Am i having multiple issues or are they all linked?
How do i flash the MMU2 when it won't locate it (Tested all my usb ports. Tested multiple usb cables).

Please help. I'm a die hard Prusa user, who hasn't been able to print for like 4 months.

Posted : 17/07/2023 7:28 am
JoanTabb
(@joantabb)
Veteran Member Moderator
RE: Help me end my cycle of issues

Are you absolutely sure that you have the correct firmware version. 

I believe The MK3 has different firmware, to the mk3s which is different to the mj3s+

 Wimu mmu2 / mmu2s

 

Regards Joan

 

I try to make safe suggestions,You should understand the context and ensure you are happy that they are safe before attempting to apply my suggestions, what you do, is YOUR responsibility. Location Halifax UK

Posted : 17/07/2023 8:35 am
Hello
(@hello)
Noble Member
RE:

Joan the mk3s and mk3s+ firmware is the same. Have you tried removing mmu then get it printing good then reput mmu on to see if it is mmu or printer at fault 

Please help me out by downloading a model it's free and easy but really helps me out https://www.printables.com/@Hello_474427/models

Posted : 17/07/2023 8:42 am
Court Greaves
(@court-greaves)
New Member
Topic starter answered:
RE: Help me end my cycle of issues

I have removed the MMU2 and i was still getting the filament change cycle.
Spent some time thinking about it and decided it must be an issue with the filament sensor on the hotend.
Sure enough after about 30 minutes of slightly adjusting it (loosing the screw and trying to shift it while tightening it) i got it to work.

Started my first real print in months.
Got 10 minutes in and got a fan error. (I've had a dodgy fan for awhile). Luckily i had a spare, to i replaced it.
Went to print and the interface wasn't responding. Quickly discovered while replacing the fan i knocked the ribbon cable loose.
I have just started the print again.
I'll keep you posted how it goes.
Luckily i'm printing something for work, so these are all billable hours.

But basically everything that could go wrong has, luckily i've worked most of them out one by one.
The MMU2 might work fine now that i fixed the sensor, but i'm not going to reinstall it just yet. If it's printing good, i want to keep it that way for abit.
Maybe i'll tinker with it once i get my XL... whenever they come 😉

Thanks for the quick replies guys, it's great to see.

Posted : 17/07/2023 10:00 am
Thejiral
(@thejiral)
Prominent Member
RE:

Have you checked if both filament sensors still work reliably? The "keeps pumping filament" error could be caused by a not properly working filament sensor in the extruder. Doesn't have to be that but it could. 

Another thing you could try is to delete the loading and prime line part of the start g-code print. Add a brim to the object and let it basically start without filament loaded. Immediately pause when it starts printing the brim (well at least it tries to). Then manually load filament via "move extruder" option. Flush the nozzle a bit with filament, remove the extruded filament and hit continue. Does the print then complete successfully without issues or do you get also errors, cloggs or leaks during the print as well?

This post was modified 8 months ago 3 times by Thejiral

Mk3s MMU2s, Voron 0.1, Voron 2.4

Posted : 17/07/2023 10:12 am
karl-herbert
(@karl-herbert)
Illustrious Member
RE: Help me end my cycle of issues

I think that one or both of the filament sensors are out of adjustment. Have you ever tried to print without MMU2?

Latest firmware for MK3 (not MK3S/+) can be found here: https://cdn.prusa3d.com/downloads/firmware/prusa3d_fw_3_12_2_MK3.zip

wbr,

Karl

Statt zu klagen, dass wir nicht alles haben, was wir wollen, sollten wir lieber dankbar sein, dass wir nicht alles bekommen, was wir verdienen.

Posted : 17/07/2023 11:19 am
Court Greaves
(@court-greaves)
New Member
Topic starter answered:
RE: Help me end my cycle of issues

As you can see from the image, i have got it printing again. This print was a 9hr print. Back to "set and forget" style printing we all expect from a prusa.

 

As stated above it ended up being a bunch of issues. One after another.

Flugged out hotend due to ASA

Filament sensor adjustment

Fan replacement

Motherboard connection checks

 

Im a little suprised that the mmu2 filament sensor on the hotend failed. Even though you bolt it together, it turns out there is enough play it in to let it trip if its not 100% in the right spot.

Posted : 18/07/2023 7:51 pm
Court Greaves
(@court-greaves)
New Member
Topic starter answered:
RE: Help me end my cycle of issues

Posted : 18/07/2023 7:52 pm
Share: