Notifications
Clear all

Cannot Unload Filament  

  RSS
Steve H.
(@steve-h)
New Member
Cannot Unload Filament

Just beginning with MMU2S. This is my second MK3S+. So I am getting first layer calibration done and after each pass at this it tries to unload filament but cannot. I will open the extruder and see that the end backed out past the gears then got stuck. I will yank it out cut off the melted end and then get it to unload. It is getting stuck each and every time. It never can unload. I do have to pull pretty hard so its not the equipment but the end of the filament. This last time it got stuck in the hotend before the gears and snapped. Now on to open extruder to get to the hotend to clear it. Has anyone come across this?

This topic was modified 6 months ago 2 times by Steve H.
Posted : 23/03/2023 3:27 am
Witties
(@witties)
Active Member
RE: Cannot Unload Filament

Hi,

Probably you must adjust your filament sensor

 

Posted : 23/03/2023 2:52 pm
Beuford Alowishis
(@beuford-alowishis)
Active Member
RE: Cannot Unload Filament

I'm having this same issue.  What happens is...when it goes to unload.  The extruder pushes it out...but there remains loose string inside the extruder gears.  the IR sensor goes off, because the main body of the filament is no longer in the extruder....and the light stringy stuff....isn't thick enough to set the extruder IR sensor off.   And so the MMU continues to try to pull the filament....causing it to grind down the filament in the MMU.

In the end....all I end up with is extruder clogs and mmu clogs.  Every time.

I couldn't have designed a better machine to clog my machine if I've tried.

And that is not the only issue I've had.  Let's talk about the 'cutter'.  When even when you clean up the channel that it slides back and forth in....it still catches.  And the first time i cut on, and caught.  I didn't eralize what was catching.  Only that the filament selecter kept getting stuck.  So I put some umph behind it to make it move.  And the razor...digging into the idler body frame....Stayed right where it was.  While the filament selector and my hand...moved. 

I'm not even mad about the emergency room visit.  Which I do consider to be caused by the design flaws in this MMU.  (When sharing this story I heard other similar stories and a chorus from everyone to remove the cutter blade as it's only function is to get stuck apparantly.)   But I'll take that as my own personal loss.  I was careless.

BUT....the rest of this is a design problem.  All it would take is for the firmware to tell the extruder to continue to rotate the filament out for an extra 2 - 3 seconds and this wouldn't be happening.

And you're telling me in their rounds and rounds and round of testing....that they've never had this happen?  Even though here are two people a week apart who have this occuring, and I've spoken to others who have experience the same problem.

Prusa.  I love your printers.  I absolutely love your printers.  But the fact that you let these MMU's leave your facility in this design shape....   is upsetting to me.  I've not had one successful print.  It's turned my favorite thing in the world, my prusa mk3s+ into junk.  I've literally had clogs happen on every entrance of each filament section.  Every exit of each filament section, and it clogs my extruder every single time it tries to unload filament.

I'm not a coder/programmer.  But how hard could it be to simply say...on unloading filament....have extruder continue to spin for 3 seconds after IR sensor is no longer engaged in order to clear the extruder of all long stringy material you get from pulling out 220 degree filament.

And that's not getting into the fact that every time you unload filament.....the filament is now in horrible shape.  Which i'm assuming is what the cutter, that doesn't function right, was originally designed for.....becaues now that end of the filament thats in horrible shape....on the few amazing times i've had it leave my extruder without jamming.  Now it just gets jammed in the mmu system the next time it goes to load....because its a mushed up janky end to filament.

What am I supposed to do with this?  And yes...I've played with the IR sensor and moved it every single which way. 

If this was from another company i would just kinda shrug my shoulders...it's expected from some 3d printer companies.

And yeah...I had heard the horror stories before I bought this....but I never would have thought that prusa would have let a device leave their facility with this kind of basic design flaws.

Posted : 10/04/2023 6:15 am
Beuford Alowishis
(@beuford-alowishis)
Active Member
RE: Cannot Unload Filament

I was wondering if you had any level of satisfaction and resolution on this issue?  After.....4 days....of working on this obsessively I just uninstalled my mmu2, and will continue to enjoy my mk3s+ stock machine...because any more disappointment and letdown by this MMU2S and I don't know if I could ever look at my mk3s+ again.

But I am curious if you found a solution to your very similar problem and how it worked out for you?

Posted : 12/04/2023 3:36 am
Share: