Notifications
Clear all

Rpi Zero & Octopi working!!!!  

Page 4 / 7
  RSS
Allram
(@allram)
Active Member
Re: Rpi Zero & Octopi working!!!!


No It failed
At least the jam detection stopped the print. Going to wait for the next firmware release before testing again.

Got the same "sausage-print"-fail with the latest FW 3.1.1-RC4 B143.

BUT: When i turned off Crash Detection everything has been running smooth. Filament sensor seems to actually work now also.
Printing with Octoprint RPI2.

@Fladby3Dprint - Norway
MK3s
MK3s-MMU2s
Raise3D E2

Posted : 31/12/2017 12:15 am
jason.s6
(@jason-s6)
Trusted Member
Re: Rpi Zero & Octopi working!!!!



No It failed
At least the jam detection stopped the print. Going to wait for the next firmware release before testing again.

Got the same "sausage-print"-fail with the latest FW 3.1.1-RC4 B143.

BUT: When i turned off Crash Detection everything has been running smooth. Filament sensor seems to actually work now also.
Printing with Octoprint RPI2.

How does the terminal/logs look with Crash Detection off? Are you getting any mismatch errors?
Recv: ok
| Send: N14929 G1 X111.363 Y73.981 E0.01768*94
| Recv: Error:checksum mismatch, Last Line: 14928
| Recv: Resend: 14929
2017-12-30 21:26:39,586 - octoprint.util.comm - INFO - Got a resend request from the printer: requested line = 15037, current line = 15038
| Last lines in terminal:
| Recv: ok
| Send: N15029 G1 X123.278 Y103.467 E0.10883*101
| Recv: ok

Posted : 31/12/2017 1:01 am
Joe Mike Terranella
(@joe-mike-terranella)
Active Member
Re: Rpi Zero & Octopi working!!!!

Had one fail on RC4:

Posted : 31/12/2017 1:15 am
knightofcarnage
(@knightofcarnage)
Eminent Member
Re: Rpi Zero & Octopi working!!!!

BUT: When i turned off Crash Detection everything has been running smooth. Filament sensor seems to actually work now also.
Printing with Octoprint RPI2.

I will retest with Crash Detection off. Was that the only feature you turned off in the firmware ? I know by default the sensor was turned off. And LOL for call i a sausage print 😀

Posted : 31/12/2017 2:11 am
gibsonlpsl
(@gibsonlpsl)
Eminent Member
Re: Rpi Zero & Octopi working!!!!


Had one fail on RC4:
Screen Shot 2017-12-30 at 6.13.31 PM.png

This has been happening to me on every firmware so far. I hope it will get fixed soon!

Posted : 31/12/2017 2:11 am
kenneth.f4
(@kenneth-f4)
Active Member
Re: Rpi Zero & Octopi working!!!!


...
I was previously using OctoPrint on a Pi2, connected through USB. That worked fine.
For now, I have disconnected my camera and am using the OTG port to connect to the printer via USB instead.
Of course, that required disabling the second USART, then resetting the printer using the 'X' button to apply the setting.
This setup works fine.

My plan is to try the second USART again while monitoring the serial line to check if the data on the line matches what
OctoPrint is trying to send.

Have you attempted connecting camera via OTG since firmware update? Or has anyone had experience via OTG? I'd like to connect a c920 webcam for print viewing but i'm wondering how feasible that is.

Posted : 31/12/2017 2:25 am
knightofcarnage
(@knightofcarnage)
Eminent Member
Re: Rpi Zero & Octopi working!!!!

Ok so far so good. No error in the logs. I disabled both filament sensor and crash detection. I hope this is not cause by starvation of resources on the new board, but a simple software bugs.

Posted : 31/12/2017 4:56 am
knightofcarnage
(@knightofcarnage)
Eminent Member
Re: Rpi Zero & Octopi working!!!!

Well found issues and these are odd when i started to look at the actual printer for about 30 mins.
1) Printing paused for 3 ~ 4 seconds on the lcd screen it showed Heating .... . Then it resumed lcd Heating done
2) Printing paused buy the extruder started to creep slow in a diagonal line for about 1 inch. Then it resumed in the last spot and continued to print.

Interesting enough the print it self was fine.

Here is what i found in the serial.log For now I'm going remove the pi and wait for the next firmware release. Also does anyone know what kind of multitasking model is used Marlin firmware (eg:Cooperative multitasking)

504058 2017-12-31 05:41:43,922 - Send: N248589 G1 E0.80000 F2100.00000*42
504059 2017-12-31 05:41:46,036 - Recv: echo:busy: processing
504060 2017-12-31 05:41:48,133 - Recv: echo:busy: processing
504061 2017-12-31 05:41:50,231 - Recv: echo:busy: processing
504062 2017-12-31 05:41:52,235 - Recv: ok
504063 2017-12-31 05:41:52,242 - Send: N248590 M105*21
504064 2017-12-31 05:41:52,261 - Recv: ok T:210.1 /210.0 B:60.0 /60.0 T0:210.1 /210.0 @:45 B@:43 P:43.6 A:44.6
504065 2017-12-31 05:41:52,268 - Send: N248591 G1 F3000*126
504066 2017-12-31 05:41:54,425 - Recv: echo:busy: processing
504067 2017-12-31 05:41:56,522 - Recv: echo:busy: processing
504068 2017-12-31 05:41:58,620 - Recv: echo:busy: processing
504069 2017-12-31 05:42:00,645 - Recv: ok
504070 2017-12-31 05:42:00,652 - Send: N248592 M105*23
504071 2017-12-31 05:42:00,672 - Recv: ok T:210.2 /210.0 B:59.9 /60.0 T0:210.2 /210.0 @:43 B@:45 P:43.3 A:44.7
504072 2017-12-31 05:42:00,680 - Send: N248593 G1 X101.447 Y84.982 E0.03082*98
504073 2017-12-31 05:42:00,694 - Recv: ok
504074 2017-12-31 05:42:00,702 - Send: N248594 G1 X101.935 Y84.982 E0.00876*109
504075 2017-12-31 05:42:00,741 - Recv: ok
504076 2017-12-31 05:42:00,749 - Send: N248595 G1 X101.935 Y86.729 E0.03136*111
504077 2017-12-31 05:42:00,766 - Recv: Error:checksum mismatch, Last Line: 248594
504078 2017-12-31 05:42:00,770 - Recv: Resend: 248595
504079 2017-12-31 05:42:00,774 - Recv: ok

Posted : 31/12/2017 7:01 am
Allram
(@allram)
Active Member
Re: Rpi Zero & Octopi working!!!!




No It failed
At least the jam detection stopped the print. Going to wait for the next firmware release before testing again.

Got the same "sausage-print"-fail with the latest FW 3.1.1-RC4 B143.

BUT: When i turned off Crash Detection everything has been running smooth. Filament sensor seems to actually work now also.
Printing with Octoprint RPI2.

How does the terminal/logs look with Crash Detection off? Are you getting any mismatch errors?
Recv: ok
| Send: N14929 G1 X111.363 Y73.981 E0.01768*94
| Recv: Error:checksum mismatch, Last Line: 14928
| Recv: Resend: 14929
2017-12-30 21:26:39,586 - octoprint.util.comm - INFO - Got a resend request from the printer: requested line = 15037, current line = 15038
| Last lines in terminal:
| Recv: ok
| Send: N15029 G1 X123.278 Y103.467 E0.10883*101
| Recv: ok

Still got mismatch errors in terminal, but for now the prints seems to complete without errors, so thats a good one 🙂


BUT: When i turned off Crash Detection everything has been running smooth. Filament sensor seems to actually work now also.
Printing with Octoprint RPI2.

I will retest with Crash Detection off. Was that the only feature you turned off in the firmware ? I know by default the sensor was turned off. And LOL for call i a sausage print 😀

Turned off Crash detection and turned on Filament sensor just to try it, and now it seems to work fine without stops midprint.

@Fladby3Dprint - Norway
MK3s
MK3s-MMU2s
Raise3D E2

Posted : 31/12/2017 9:11 am
HackMonkey
(@hackmonkey-2)
Trusted Member
Topic starter answered:
Re: Rpi Zero & Octopi working!!!!

Loaded the new "Prusa Print" version of Octopi, much easier setup, just need to setup the wifi before using, no more need to tweak the ports. I had one stall, where it printed the priming strip, and then stopped before actually starting the print.

I then had 4 prints in a row with layer shifts, while printing from Prusa Print, and using all the printer settings set the the default, which was on. Jo didn't mention turning anything off when using Prusa Print.

There were no filament sensor issues, which had been very common. However, I had 4 failed prints in a row from layer shifts. There were also multiple times when it would pause and then sweep from stop to stop on the Y-axis. Turning off the Crash Sensing seems to have taken care of it. I was able to complete a 4 hour print with no shifts or crashes after turning off the Crash Sensing, although there were will still a few Y-axis sweeps.

Posted : 31/12/2017 9:41 pm
knightofcarnage
(@knightofcarnage)
Eminent Member
Re: Rpi Zero & Octopi working!!!!

Turning off the Crash Sensing seems to have taken care of it. I was able to complete a 4 hour print with no shifts or crashes after turning off the Crash Sensing, although there were will still a few Y-axis sweeps.

Yes i was able to finish the print with odd extruder movements that did not effect the print. How every you should turn on debug mode in Octprint and look in the serial.log . Search for Error/error busy etc ....

Posted : 31/12/2017 9:57 pm
Jeff
 Jeff
(@jeff-5)
Trusted Member
Re: Rpi Zero & Octopi working!!!!

Er, mine worked for a test print but I had a Y-shift of about 1 cm last night about two hours into a 6 hour print. Hard to tell if it's the new firmware or using OctoPrint with the Pi attached to the Einsy.

I threw away the pile of spaghetti left on the bed, but here's what I picked up off the floor:

I've only seen layer shifts when in stealth mode, so I made sure to check that stealth wasn't on.

Was this an OctoPrint serial error or a failure of level shift detection or something else?

Posted : 31/12/2017 10:50 pm
Josef Průša
(@josef-prusa)
Admin
Re: Rpi Zero & Octopi working!!!!

None of these problems occur when printing from SD card alone.
We did test with b143 with RPiZW however it seems there are still things to fix. To help us out, we need more information.
When you are reporting please mention:
-FW version
-RPi used
-Method of the connection - USB/expansion port
-Filament sensor on/off
-Crash detection on/off

Founder and owner / Majitel a zakladatel
Posted : 31/12/2017 11:03 pm
HackMonkey
(@hackmonkey-2)
Trusted Member
Topic starter answered:
Re: Rpi Zero & Octopi working!!!!

Thanks for jumping in Josef! Really appreciate all the teams dedication. Big selling point for me.

My problems last night were with:
- RC4 firmware
- RPiZW
- Piggy backed onto the Einsy with the expansion port
- Filament Sensor was ON
- Crash Detection was ON
- "Prusa Print" version of Octopi

I was seeing random sweeps on the Y-Axis, one false start, lots of checksum errors in the terminal, and multiple Y-Axis layer offsets.

After turning off Crash Detection, there were still multiple checksum errors, and a few Y-axis sweeps, but the 4 hour print DID complete successfully.

Posted : 31/12/2017 11:46 pm
Allram
(@allram)
Active Member
Re: Rpi Zero & Octopi working!!!!

Here are my "settings":

-FW version B143 - RC4
-RPi used - RPI2B
-Method of the connection - USB/expansion port - USB
-Filament sensor on/off - ON (autoload also on)
-Crash detection on/off - ON

This print worked fine from Octoprint before this FW (RC3, but there crash detection was not enabled when printing from usb?)
It's the measuring cube from Thingiverse: https://www.thingiverse.com/thing:2676324
Got this strange "sausage" print. It just suddenly stops printing, moves the printhead and then slowly prints this "sausage" over a long area until i stopped it.

Also alot of "Echo: busy: processing" errors in the terminal of Octoprint.

When i turn off Crash detection in the settings menu every print is perfect.

@Fladby3Dprint - Norway
MK3s
MK3s-MMU2s
Raise3D E2

Posted : 01/01/2018 2:08 am
Jeff
 Jeff
(@jeff-5)
Trusted Member
Re: Rpi Zero & Octopi working!!!!

Details on my crash:
-FW version: 3.1.1 RC4 B143
-RPi used: Zero W
-Method of the connection: expansion port
-Filament sensor: ON
-Crash detection: ON

I'll run this from the SD card tonight.

Posted : 01/01/2018 4:02 am
paul.m
(@paul-m)
Active Member
Re: Rpi Zero & Octopi working!!!!

I have had two completed prints using a Pi Zero W connected through an OTG to the USB port. Slic3r MK3 slices kept failing so I tried changing to Simplify 3d to slice, which seems to be working. Purge strip was a about 30mm into the y axis though. Anyone else try a different slicer or even a MK2 previously sliced file?

Also wanted to the thank the Prusa crew for being on top of this. God speed!

-Slicer: S3D
-FW version: 3.1.1 RC4 B143
-RPi used: Zero W
-Method of the connection: OTG hub to USB
-Filament sensor: ON
-Crash detection: OFF

Posted : 01/01/2018 5:06 pm
Hansen
(@hansen)
Eminent Member
Re: Rpi Zero & Octopi working!!!!

I just posted my findings on "checksum errors" ( https://shop.prusa3d.com/forum/original-prusa-i3-mk3-f30/-checksum-mismatch-when-printing-via-usb-t12739.html#p57648 ), and I think it could be helpful to this thread.

In short: Only movements (G1 commands) involving extruder movements result in checksum errors. I did a GCode file to test it, and I have now re-run it with the crash detection disabled, and it is completely reproducible that:

  • 1. With crash detection ON I get about 20-ish checksum errors during the execution of the gcode

  • 2. With crash detection OFF I get only 2!
  • -FW version: 3.1.1 RC4 B143
    -RPi used: No RPi, but an iMac
    -Method of the connection - USB/expansion port: USB
    -Filament sensor on/off: off (is not responding anymore?)
    -Crash detection on/off: Both on and off

    Best regards
    Hansen > Greetings from Denmark <

    Posted : 01/01/2018 5:40 pm
    joseph.greiner
    (@joseph-greiner)
    Active Member
    Re: Rpi Zero & Octopi working!!!!

    -FW version: 3.1.1 RC4 B143
    -RPi used: Zero W
    -Method of the connection: expansion port
    -Filament sensor: ON
    -Crash detection: ON
    -OctoPrint version 1.3.6 on OctoPi 0.14.0

    Printing files from the SD card through OctoPrint works flawlessly. However trying to print from OctoPrints local storage produces checksum errors and the printer halts after the priming line. When trying to upload gcode to the SD card via OctoPrint web interface OctoPrint produces similar error messages in the terminal and OctoPrint becomes unresponsive until there is finally a communications error and it disconnects from the printer.

    Power panic and crash detection still work and recover fine when printing from the SD card. I can email in the serial.log file if it helps.

    -Joseph

    Posted : 02/01/2018 12:28 am
    paul.m
    (@paul-m)
    Active Member
    Re: Rpi Zero & Octopi working!!!!


    -FW version: 3.1.1 RC4 B143
    -RPi used: Zero W
    -Method of the connection: expansion port
    -Filament sensor: ON
    -Crash detection: ON
    -OctoPrint version 1.3.6 on OctoPi 0.14.0

    Printing files from the SD card through OctoPrint works flawlessly. However trying to print from OctoPrints local storage produces checksum errors and the printer halts after the priming line. When trying to upload gcode to the SD card via OctoPrint web interface OctoPrint produces similar error messages in the terminal and OctoPrint becomes unresponsive until there is finally a communications error and it disconnects from the printer.

    Power panic and crash detection still work and recover fine when printing from the SD card. I can email in the serial.log file if it helps.

    -Joseph

    Joseph,

    What slicer are you using?

    -Paul

    Posted : 02/01/2018 2:32 am
    Page 4 / 7
    Share: