Notifications
Clear all

OctoPrint on MK3?  

Page 7 / 7
  RSS
lignumaqua
(@lignumaqua)
Eminent Member
Re: OctoPrint on MK3?

Agreed. I've now done both, disabled BT and moved the port we are using over to the faster hardware UART. Added the following overlays to /boot/config.txt on the Pi Zero W


dtoverlay=pi3-miniuart-bt
dtoverlay=pi3-disable-bt

I've also changed the port to serial0, which in Stretch and later versions of Jessie should always work no matter how the ports are configured internally.

Posted : 16/12/2017 11:58 pm
Jeff
 Jeff
(@jeff-5)
Trusted Member
Re: OctoPrint on MK3?



Yes, exact same issue with OctoPrint, stops after purge line. I think that yulong.1 has it right, it's the if/else statement in the Gcode which is causing the problem. FWIW Repetier-Server has no problem with it.

...


That did the trick for me too, thanks lignumaqua! Time to take things apart and solder some headers 🙂

Posted : 17/12/2017 3:41 pm
lignumaqua
(@lignumaqua)
Eminent Member
Re: OctoPrint on MK3?

If anyone is following along. Not unexpectedly using my own unreleased build of the current state of GitHub did have some issues. In particular the serial link was seeing a lot of errors and re-sends. This caused the print head to sporadically jump to 0,0 and print in mid-air.

Not sure if this was a Pi issue, an Einsy issue, or something else. Best way to find out is to curb my impatience and wait for a true tested release from Prusa. 😆 For now I've reverted to release B122 and an external Pi connected through the USB port. All is happy again and I've satiated my curiosity that an internal Pi Zero W will do the job in the future. 🙂

Posted : 17/12/2017 4:14 pm
Jan Pichrt
(@jan-pichrt)
Re: OctoPrint on MK3?

New firmware release is UP! Awesome... https://www.prusa3d.com/downloads/firmware/prusa3d_fw_3_1_1_rc2_b137.zip

/edit: but this fw not working with Rpi too 🙁

/edit2: working! just dont forgot to enable 2nd uart in menu 😉

Posted : 17/12/2017 10:44 pm
lignumaqua
(@lignumaqua)
Eminent Member
Re: OctoPrint on MK3?

Yep, new release seems to be working well. Or, it would be, if I hadn't just had a bearing fail and seize up! 🙁

Not good that a linear bearing fails in a week. (It was one of the Y axis ones, and one of the others is on its way) Looks like I might have to try and find a better quality than Prusa uses and swap them all out. Is this a known problem with Prusa printers?

Posted : 18/12/2017 9:21 am
Mike C
(@mike-c-3)
Eminent Member
Re: OctoPrint on MK3?

Curious if you are using Octopi or Octoprint installed on Raspbian? I am unable to connect to Serial port:

Started to get this after disabling BT

Connecting to: /dev/ttyAMA0
Changing monitoring state from 'Offline' to 'Error: Connection error, see Terminal tab'
Unexpected error while connecting to serial port: /dev/ttyAMA0 OSError: '[Errno 13] Permission denied: '/dev/ttyAMA0'' @ comm.py:_openSerial:1931 (hook default)

Posted : 20/12/2017 11:24 pm
Page 7 / 7
Share: