Notifications
Clear all

Prints stalling randomly  

Page 1 / 2
  RSS
gibsonlpsl
(@gibsonlpsl)
Eminent Member
Prints stalling randomly

I've only attempted 2 prints since updating to the latest firmware (FIRMWARE 3.1.1 RC4 B143 (DECEMBER 30, 2017)) and both have stopped/hung for no discernible reason, with no message on the LCD. When I push the encoder, the print continues as if nothing had happened (other than a blob that has formed where the hot end was resting). This kind of behavior is what I was seeing when using Octoprint (although non-recoverable), so I decided to just print some included gcode files from the SD to avoid those problems. Note, Octoprint is running on a Pi 3 and it was connected via USB during this time, but I have not been printing from Octoprint when I experienced these failures. This has happened when printing the whistle and the gear bearing. Here is a video of the machine in the state I find it in:

Any ideas as to what is going on?

Posted : 31/12/2017 12:23 am
Petos
(@petos)
Eminent Member
Re: Prints stalling randomly

It happened to me too. Only on RC4.

Posted : 31/12/2017 1:01 am
jason.s6
(@jason-s6)
Trusted Member
Re: Prints stalling randomly

Just completed an hour print from the SD card on RC4 with no issues luckily. Looks like until this is solved maybe revert back to RC3 or make sure you can constantly check the printer

Posted : 31/12/2017 1:09 am
gibsonlpsl
(@gibsonlpsl)
Eminent Member
Topic starter answered:
Re: Prints stalling randomly


It happened to me too. Only on RC4.

Were you connected via USB to anything or purely untethered? I had a second failure like this on the gear bearing and since then I've disconnected octoprint to see if it'll make a difference.

Posted : 31/12/2017 1:10 am
JLTX
 JLTX
(@jltx)
Reputable Member
Re: Prints stalling randomly

I just killed a Benchy print 2.5 hours in. Exact same problem. Random stops. I was printing from SD, but Octo was connected via USB and monitoring. I saw this on the Octo terminal:

Recv: echo:busy: paused for user

Posted : 31/12/2017 2:34 am
Brandito
(@brandito)
New Member
Re: Prints stalling randomly

Having the same issues printing from octoprint on b143. Same gcode prints fine from sd card.

The x and y axis would randomly run out to one end of the print bed and back and then print fine for a while, then eventually it'd stray too far, lose a step and ruin the print. A couple times the extruder would just start pumping out a long blob of plastic. Glad it's likely just the new firmware.

Posted : 31/12/2017 4:09 am
AndrewD
(@andrewd)
Active Member
Re: Prints stalling randomly

Had the same issue also. I assumed it was the filament sensor as I was printing with clear PLA. I know I should have disabled the sensor. The issue for me was there was no error message... no out of filament or something.

I also had a notebook connected via USB but I was printing from an SD card. I’d left it connected after firmware updates and playing in Prontoface. So guessing it could be either serial interface or filament sensor issues?

Posted : 31/12/2017 7:34 am
gibsonlpsl
(@gibsonlpsl)
Eminent Member
Topic starter answered:
Re: Prints stalling randomly


Had the same issue also. I assumed it was the filament sensor as I was printing with clear PLA. I know I should have disabled the sensor. The issue for me was there was no error message... no out of filament or something.

I also had a notebook connected via USB but I was printing from an SD card. I’d left it connected after firmware updates and playing in Prontoface. So guessing it could be either serial interface or filament sensor issues?

I've kept my filament sensor disabled since I had several false positives initially. My print succeeded with no further failures after I disconnected octoprint, so it seems to me like serial communication issues, even while printing from sd. Really hoping this info helps narrow down the culprit!

Posted : 31/12/2017 9:23 am
waino
(@waino)
Active Member
Re: Prints stalling randomly

I have seen these wierd behaviours with the RC4 b143 firmware as well. After the firmware upgrade the following print via USB (just pronterface, no octoprint) the printer halted for no reason (Waiting to user input was displayed on the screen) and after pressing the knob next to LCD-screen it continued printing. However, it had multiple times random movements, like going up 10cm on Z-axis or X-axis without any valid reason.

I think I'm going back to RC3 for now.

Posted : 31/12/2017 10:11 am
robbert.g
(@robbert-g)
Eminent Member
Re: Prints stalling randomly

I have had the exact same thing happening to me this morning, whilst printing from the SD card.
I'm going to roll back to RC3.

Posted : 31/12/2017 12:23 pm
marco.v6
(@marco-v6)
Active Member
Re: Prints stalling randomly

were i can find the RC3 firmware?

Posted : 31/12/2017 12:56 pm
vaxxi
(@vaxxi)
Estimable Member
Re: Prints stalling randomly

https://www.prusa3d.com/downloads/firmware/old/

Posted : 31/12/2017 1:10 pm
marco.v6
(@marco-v6)
Active Member
Re: Prints stalling randomly

too old there isn't the rc3

Posted : 31/12/2017 1:47 pm
vaxxi
(@vaxxi)
Estimable Member
Re: Prints stalling randomly

There you go, attached.

Posted : 31/12/2017 1:49 pm
marco.v6
(@marco-v6)
Active Member
Re: Prints stalling randomly

thanks a lot!!!!!

Posted : 31/12/2017 1:49 pm
Petclaud
(@petclaud)
Active Member
Re: Prints stalling randomly

Looks like RC4 firmware has issues. During 5 small < 1 hour print jobs I got a couple of times problems that look related to false detection of layer shifts. During the print, several times the print head suddenly starts checking either X-end, Y-end or home positions and than restarts where it left. Out of the 5, one finished successfully and four prints stopped without being finished whereof one delivered a weird 15 cm long 'blob' of about 1 cm in diameter 😯 😆

Just to add: I am connected via usb to a Pi3B running the latest release of Octoprint. I expect that the issues I had were not related to Octoprint or to its connection; the printer just randomly start checking either X-end, Y-end or home positions which gives me the impression it has to to with layer shift detection or alike. The connection to Octoprint remained in place and I did not had to reconnect during the failed prints.

I have switched back to RC3 and printing again and have made several small prints again without any of these funny phenomena.

Posted : 31/12/2017 2:26 pm
rufflez
(@rufflez)
Estimable Member
Re: Prints stalling randomly

I'm not a fan of the unload "feature" now. They changed it for more reliable unloads... But it's less reliable, 2/3 unloads resulted in me having to yank out the filament. I think I know why they did it... I was getting strings before from half-molten plastic still being attached from the hotend side. It pauses now halfway though the unload to allow it to solidify, but I get a ball that doesn't want to clear the bondtech extruder now.

As for pauses... I haven't had any printing from SD. I have my printer tethered to my desktop with the latest drivers. My computer is usually asleep though. I didn't have issues turning it on and off while connected and printing because I don't have it attached to Pronterface. You might want to disconnect from Pronterface if you're using the SD and ignore the debugging I guess. It seems ironic that the debugging process may be the source of the issue. Is there a way to make octoprint less verbose? See if there is better reliability if it just isn't reporting the messages from the printer?

Posted : 31/12/2017 2:38 pm
JLTX
 JLTX
(@jltx)
Reputable Member
Re: Prints stalling randomly


I'm not a fan of the unload "feature" now. They changed it for more reliable unloads... But it's less reliable, 2/3 unloads resulted in me having to yank out the filament. I think I know why they did it... I was getting strings before from half-molten plastic still being attached from the hotend side. It pauses now halfway though the unload to allow it to solidify, but I get a ball that doesn't want to clear the bondtech extruder now.

the new unload works better for me. I was getting many stuck unloads, now zero. Surprised you are having problems.

As for pauses... I haven't had any printing from SD. I have my printer tethered to my desktop with the latest drivers. My computer is usually asleep though. I didn't have issues turning it on and off while connected and printing because I don't have it attached to Pronterface. You might want to disconnect from Pronterface if you're using the SD and ignore the debugging I guess. It seems ironic that the debugging process may be the source of the issue. Is there a way to make octoprint less verbose? See if there is better reliability if it just isn't reporting the messages from the printer?

I can print without stalls from SD *or* USB. But if USB is connected, SD prints will stall.

Posted : 31/12/2017 3:29 pm
PixelPerfectCT
(@pixelperfectct)
Eminent Member
Re: Prints stalling randomly

I can only get prints to work from SD only. If the usb is connected to the computer or octoprint I have stalls or freezing that cant recover from. hoping for them to work this out soon, would be nice to use what was advertised when I bought this printer.

Posted : 31/12/2017 3:47 pm
keithywhites
(@keithywhites)
Trusted Member
Re: Prints stalling randomly

im running RC4 B143 this morning, connected via usb with octoprint on a pi3b, im in 1.5 hours and no hang up yet. i uploaded directly through octoprint to the pi and have no issues yet. im guessing the power panic wont work properly since its not printing from the sd card.
could a bad usb cable be causing the hangups? it has happened to me before using octoprint.

Posted : 31/12/2017 4:38 pm
Page 1 / 2
Share: