X Axis Length Error/X Axis Doesn't Move On First Startup
Clear all

X Axis Length Error/X Axis Doesn't Move On First Startup  

New Member
X Axis Length Error/X Axis Doesn't Move On First Startup

Hi All!

I just finished setting up my Original  Prusa i3 MK3 last night. I turned it on, ran the self test, and the fan tests worked. When it gets to the X-Axis test, it immediately fails without any movement from the stepper motor. The screen gives me this error:


Selftest error:

Please check :

Axis Length

Axis.  X


then tells me to check the user manual.


I have tried flashing the firmware on both the mac and windows sides of my computer, but each time flashing fails with this error:


Using Port                    : /dev/cu.usbmodem14201

                Using Programmer              : wiring

                Overriding Baud Rate          : 115200

avrdude-slic3r: stk500v2_recv(): timeout

avrdude-slic3r: stk500v2_getsync(): timeout communicating with programmer

avrdude-slic3r: Could not open port: /dev/cu.usbmodem14201


avrdude-slic3r done.  Thank you.


I have also noticed that when I turn the knob next to the screen, it immediately returns to the “Original Prusa i3 Prusa Research …” splash screen. Clicking seems to work as expected, though.


One thing different I have noticed compared with the assembly instructions is that the socket for the P2 LCD ribbon cable on the Einsy board faces the opposite direction from the manual and from what I’ve seen online. The instructions state that the pink line on both ribbon cables should be facing up, but on mine only the P1 cable faces up. See the attached photos.

Any help troubleshooting any of these problems is greatly appreciated!

Einsy board unplugged to show P2 socket direction. Einsy board with cables plugged in to show opposite ribbon direction. Instruction manual for reference.

Posted : 25/04/2020 3:50 am
Veteran Member Moderator
RE: X Axis Length Error/X Axis Doesn't Move On First Startup

the ribbon cables have been an issue from the beginning of the i3 series of printers... 

I came unstuck when I built my first Original Prusa i3 1.75mm printer, 
At that time they hadn't started giving model numbers  
nowadays we consider the first version, with the Geared Wade type extruder to be the Mk0  (3mm filament)
and the upgraded 1.75mm filament version is now the Mk1..     

On the Mk1 the Rambo had polarised shields / sockets around the LCD Cable Sockets and bare headers on the back of the LCD... 

My Sin... I put the striped end of the ribbon cable towards pin1 on the connector

Nowadays...   the connectors at both ends of the cables are polarised and the sockets on the einsy and LCD are polarised,   which should take a lot of the scope for errors out of the situation... 
the most common error on the LCD cables is mixinf cables 1 and 2 at one end, or the other...  

can you check the ribbon cables at both ends? if one cable has the stripe on the wrong side at both ends, the error cancels it'self out

regards Joan


I try to make safe suggestions,You should understand the context and ensure you are happy that they are safe before attempting to apply my suggestions, what you do, is YOUR responsibility. Location Halifax UK

Posted : 25/04/2020 12:39 pm
New Member
Topic starter answered:
RE: X Axis Length Error/X Axis Doesn't Move On First Startup

Thank you for your help!

I tried seeing if the other end might be able to be turned around, but with no luck. Instead, I individually wired the plug using some wires I had for my arduino boards and it works perfectly. It turns out that plug for the P2 LCD connector was, in fact, applied backwards. Now I just need to find a more permanent solution.

Thanks again and happy printing!


Posted : 26/04/2020 5:41 am