Notifications
Clear all

Upgraded to MK3S+, unable to level the bed  

  RSS
thomas
(@thomas-27)
Active Member
Upgraded to MK3S+, unable to level the bed

Hello,

I finally upgraded my MK3S zu MK3S+ with the newest PINDA, renewed my smooth rods and all bearings and right now I have problems leveling the printbed. I am using the Prusa Leveling Guide plugin for Octoprint. With the "old" PINDA I had a bed variance of only 0.01x with the nylock mod and it was totally easy to accomplish that. I could never come even close to that with the new PINDA of the MK3S+, I always had 0.1x bed variance cause I was having quite a huge difference every time I ran the test even without pulling the PEI sheet off every time, so I switched to the silikon mod as I thought it could be a "unstable" printbed due to the fact the screws are not really that fixed with it, but it didn't change anything.

So, right now my variance is 0.097.

I have my MK3S+ inside an selfmade enclosure, temperatures for bed are 85 °C and nozzle 240 °C for a hour now so everything is heated up. I just tried to follow the values and use the screws to fix it but everytime it is totally different. Also while the measurement with the PINDA is running the extruder jumps on many points on the bed while calibrating, so it seems it recognizes some values way off as they should normally be, but next time its just doing it fine again and other points are problematic.

When I repeat the measures right now without even touching the printer the values just jump so that the degrees on screws turn from e.g. -9,0° to +2,0°, so the PINDA isn't recognizing all the values correctly. And I absolutely do not know that kind of behaviour on the "older" PINDA of the MK3S it was before.

So, how are your experiences in leveling with the new PINDA? Is it also that different to the old one? Prints are good, but I just wanted to make sure everything is leveled as I have some quite huge prints ahead which have a huge base part that needs to be flat.

Pictures of three probes of the leveling guide without even touching anything in between so you can see the differences each test (the first had so many jumps while testing, nearly on every measurement point. On check 2 and 3 there were also some but not quite so many).

I also have some fotos of the extruder and printer with PINDA and a screenshot from the bed visualizer of octoprint. I already tried to change the position of the PINDA... moving it down a bit results in the same fluctuating values and moving it up just results in a nozzle touching the bed while recalibrating Z. Those tests run fine with the current position.

Infos to the printer itself:

Upgraded MK3S -> MK3S+ with all parts
MMU2S
MK3S+ FW: 3.11.0-4955
MMU2 FW: 1.0.6-372
XYZ calibration details: left 11,18mm, right 11,02mm, 0.03°

Belt tension x 250, y 280
Bed check points 7x7, tries 5, magnet compensation ON

I would be very happy if you have some suggestions why this is happening or some experience with your new PINDA of the mk3s+ while doing the bed level measurements. Right now I just think something is wrong with the PINDA, otherwise I cannot explain the difference between checks and also the jumping of the extruder while measuring.

Thank you for your help and best regards,

Tom

 

 

Posted : 23/09/2022 12:59 pm
fuchsr
(@fuchsr)
Famed Member
RE: Upgraded to MK3S+, unable to level the bed

Never had an issue with the super pinda. What are you trying to accomplish? This variation looks minuscule to me and is easily compensated for by mesh bed leveling. 

Posted : 23/09/2022 1:56 pm
thomas
(@thomas-27)
Active Member
Topic starter answered:
RE:

Well, the problem is that the pinda is reading quite different values from time to time in my eyes, as I know how exact the old pinda was. When I ran three bed level measurements with the old one the difference of the values was quite small. Now, with the "better" pinda it differs quite a lot and I cannot level the bed correctly due to that level lottery it sends to the printer. Also I couldn't do any mesh bed leveling with the firmware itself as the values will be different next time it measures before printing I guess.

I right now only want to accomplish a leveled bed as much as it can be, as I could do it with the old pinda. and I want to make sure if it is worth to contact the support for a replacement or if it is a issue with my build. in the current state the "better" super pinda is actually worse than the old one on my printer, and thats not how it should be.

Also calibrating the 7x7 takes a while as it jumps and resets on nearly every point, thats also nothing I have ever seen with the old one.

Posted : 23/09/2022 2:07 pm
Robin
(@robin)
Reputable Member
RE: Upgraded to MK3S+, unable to level the bed

My guess is, that your new SuperPINDA is just a little more precise than your old PINDA and therefore you get a little higher variance with the same physical bed.

Why do you care so much about that number? If you had no variance at all your MK3S+ would be very unhappy because there is no use for it's fine mesh bed leveling feature anymore...

Seriously, just be happy and print something. Or is there a bed variance competition somewhere? 

If at first you don't succeed, skydiving is not for you.

Posted : 23/09/2022 2:11 pm
fuchsr liked
thomas
(@thomas-27)
Active Member
Topic starter answered:
RE: Upgraded to MK3S+, unable to level the bed

I am not talking about a perfect first layer, I am talking about a flat bed to get a flat print. No firmware automation will get you that when your bed isn't flat enough. I use the whole printbed regularly and printed over a hundret of prints with my perfectly lined up bed with the normal pinda, and before doing the mod to flatten those on the old pinda you could even see on a flat table that the print wasnt flat, and that has nothing to do with warping or whatever. I also own two other printers from a different vendor, and on all I can setup the bed correctly for that not to happen. And I could before on my mk3s, but not after the super pinda.

right now the super pinda says on measure #1 everything perfect the first line of 7 measure points, looking through a smooth rod laying flat on the bed you can see that its not. measure #2 shows points off, measure #3 a little less off, measure #4 again perfect "on paper". Even if the super pinda is more precise, it should give precise values and no lottery.

I will contact the support with that issue, thank you guys.

Posted : 23/09/2022 5:00 pm
Share: