Notifications
Clear all

Problems upgrading to firmware 3.10.1  

  RSS
Auriea
(@auriea)
Active Member
Problems upgrading to firmware 3.10.1

I am trying to upgrade my Prusa MK3S using 'prusa3d_fw_MK3S_MK3S+_3_10_1_4697.hex' from my PC and the latest Prusa Slicer 2.4.0.

I flash fine. But then it doesn't go beyond the 'Original Prusa i3 Prusa Research' screen on my LED.

When I downgrade back to 'prusa3d_fw_MK3S_3_9_3_3556.hex' Everything is fine and back to normal.

I've tried a hard reset and then a flash to the new version, but that did nothing, same problem.

Anyone have some advice?

This topic was modified 5 months ago by Auriea
Posted : 26/12/2021 1:02 pm
Auriea
(@auriea)
Active Member
Topic starter answered:
RE:

here is the log file from the flash

maybe someone knows how to read it and it contains a clue

avrdude-slic3r -v -p atmega2560 -c wirin

 

 

Posted : 26/12/2021 1:12 pm
Auriea
(@auriea)
Active Member
Topic starter answered:
RE: Problems upgrading to firmware 3.10.1

I see someone else had the same problem here: https://github.com/prusa3d/Prusa-Firmware/issues/3321

But I do not understand the solution. I have a broken filament sensor since awhile now sensor. Does it mean that I should fix that and it fixes everything?

Posted : 26/12/2021 1:37 pm
Auriea
(@auriea)
Active Member
Topic starter answered:
RE: Problems upgrading to firmware 3.10.1

okay here is someone else with a similar problem:

https://forum.prusa3d.com/forum/original-prusa-i3-mmu2s-mmu2-hardware-firmware-and-software-help/menu-doesnt-load-when-filament-sensor-is-plugged-in/

they also did the mk3 upgrade for MMU2S and it is a problme with the IR sensor. I am not using the MMU so I wonder if there is another way I should connect the IR-sensor for just single filament printing. I think the firmware update will not work with sensors in the MMU configuration (?)

Posted : 27/12/2021 12:56 pm
CharmPeddler
(@charmpeddler)
New Member
RE: Problems upgrading to firmware 3.10.1

I'm having the same issue (just created a post).
Commenting to see if anyone responds... but it's been 3 weeks and i'm the first reply??? odd.

Posted : 13/01/2022 5:30 pm
petli_h
(@petli_h)
New Member
RE: Problems upgrading to firmware 3.10.1

Same problem here.. I think it have something to do if you have (had) MMU2 maybe...

i run flash couple time and i got printer to go "normal" standby screen but it freeze there.
after that i tried 3.10.0 but it did not work any better.

so 3.9.... we go!

Posted : 18/01/2022 10:04 pm
Tim
 Tim
(@tim-4)
New Member
RE: Problems upgrading to firmware 3.10.1

Same problem also.  Looks Like I'll be going back to ver 3.9.

 

Posted : 21/01/2022 12:11 pm
Tim
 Tim
(@tim-4)
New Member
RE: Problems upgrading to firmware 3.10.1

Would love to know why this is happening. 

Hopefully they will have a fix soon.

Posted : 21/01/2022 12:19 pm
Auriea
(@auriea)
Active Member
Topic starter answered:
RE: Problems upgrading to firmware 3.10.1

Sorry we are all having this problem! I just received the MK3S+ upgrade package so I'll be replacing the whole sensor and rebuilding my hotend. If something of this fixes things, I'll let you know!

 

Posted : 21/01/2022 3:26 pm
Credo PD
(@credo-pd)
Active Member
RE: Problems upgrading to firmware 3.10.1

I have the exact same issue with two MK3's.  Both were updated to the 3.10.1 firmware at the same time, and both now hang on the loading screen after reboot.  Unplugging the sensor enables both printers to finish booting immediately.   I tried installing a new sensor, but the issue persists.  Rolling back to 3.9 firmware fixes the issue, but why is this happening?  And how can it be fixed.  The same issue manifesting on two separate devices at the same time seems to preclude a hardware issue, particularly since a new sensor has no effect.  Can anyone help with this?

Posted : 15/02/2022 9:08 pm
Credo PD
(@credo-pd)
Active Member
RE: Problems upgrading to firmware 3.10.1

Did the upgrade kit solve the issue?

Posted : 15/02/2022 9:09 pm
Auriea
(@auriea)
Active Member
Topic starter answered:
RE: Problems upgrading to firmware 3.10.1

Hello, The upgrade was quite extensive so it took me awhile to have time to do it. The short answer is YES, this does solve all the issues! Mainly because the Mk3s+ upgrade involves adding a new sensor and rebuilding the entire extruder array, among other things. I sucessfully did the upgrade and everything works perfectly now with the sensor and the latest firmware. I do recommend dioing the upgrade if you are experiencing issues.

Posted : 30/03/2022 9:53 am
Credo PD
(@credo-pd)
Active Member
RE: Problems upgrading to firmware 3.10.1

Fantastic, thanks for the update!!

I ended up getting in contact with some developers who work on the firmware releases, and they're going to at least modify the timeout which was preventing the printer from starting up in the event the filament sensor isn't detected in the next version of the firmware.

Posted : 30/03/2022 1:00 pm
PommieDownUnder
(@pommiedownunder)
Eminent Member
RE:

Well, 3.11.0 still does the same error, so back to 3.93 yet again!

 

And yes, my filament sensor stopped working a while ago.

This post was modified 3 weeks ago by PommieDownUnder
Posted : 28/04/2022 5:05 am
Credo PD
(@credo-pd)
Active Member
RE: Problems upgrading to firmware 3.10.1

Sorry to hear that!

I went ahead and did the MK3S+ upgrade and now everything works perfectly, so that may be the best path forward.

Posted : 28/04/2022 12:56 pm
Share: