Clear all

i3 MK3s+ &MMU2s wrong Filament Selection  

New Member
i3 MK3s+ &MMU2s wrong Filament Selection


PrusaSlicerVersion: 2.3.3+win64Build: PrusaSlicer-2.3.3+win64-202107161027

i3 MK3s+ & MMU2s

Prusa MK3s+ 3.9.3
MMU2s 1.0.6
Rpi 4B
OctoPrint 1.6.1
Python 3.7.3
OctoPi 0.18.0

This is really confusing Trouble I am facing. Regularly By downloading Gcode file over Octopi and/or also loading directly over SD Card, The Gcode Tool selection is correct but Physically it selects random slot of an other Filament of MMU2.This morning finally I could catch the case as follow:


IR_Sensor_State_Window_0.15mm_PETG_MK3SMMU2S_2m.gcode shows
`; generated by PrusaSlicer 2.3.3+win64 on 2021-09-25 at 06:13:20 UTC
; external perimeters extrusion width = 0.45mm
; perimeters extrusion width = 0.45mm
; infill extrusion width = 0.45mm
; solid infill extrusion width = 0.45mm
; top infill extrusion width = 0.40mm
; first layer extrusion width = 0.42mm

M73 P0 R2
M73 Q0 S2
M201 X1000 Y1000 Z200 E8000 ; sets maximum accelerations, mm/sec^2
M203 X200 Y200 Z12 E120 ; sets maximum feedrates, mm/sec
M204 P1250 R1250 T1250 ; sets acceleration (P, T) and retract acceleration (R), mm/sec^2
M205 X8.00 Y8.00 Z0.40 E4.50 ; sets the jerk limits, mm/sec
M205 S0 T0 ; sets the minimum extruding and travel feed rate, mm/sec
M862.3 P "MK3SMMU2S" ; printer model check
M862.1 P0.4 ; nozzle diameter check
M115 U3.10.0 ; tell printer latest fw version
G90 ; use absolute coordinates
M83 ; extruder relative mode
M104 S240 ; set extruder temp
M140 S70 ; set bed temp
M190 S70 ; wait for bed temp
M109 S240 ; wait for extruder temp
G28 W ; home all without mesh bed level
G80 ; mesh bed leveling

; Send the filament type to the MMU2.0 unit.
; E stands for extruder number, F stands for filament type (0: default; 1:flex; 2: PVA)
M403 E0 F0
M403 E1 F0
M403 E2 F0
M403 E3 F0
M403 E4 F0

;go outside print area
G1 Y-3.0 F1000.0
M73 P14 R2
M73 Q14 S2
G1 Z0.4 F1000.0
; select extruder
; initial load


T3 is correct, but Physically is Loading T1 on LCD Display showing F2 ` I made the test as well downloading from Octopi as well loading over SD Card. Behave in both cases the same way. It seems that somehow ensy or mmu board hangs. So thats the reason why I do not think it is octopi related.

Over octopi once startet job tried to enter in therminal window T0 with no reaction then T2 right away changed filament to T0 tried as well T3 and it changed back again to T1 confusing....

After Restarting (Power OFF / On cycle ) everythings works again as expected.

checked on octopi that 5 Extruder with shared nozzle is configured.

modified filament sensor with LED stat to exclude Loading Filament Issues

I have noticed that behave since really a long time and my turn arround was always before restarting a job to consequently Power Off/ On cycle, and up to know it always worked.

My question it is permanently behaving again that way, but I could not reproduce it up to know. There somebody got me a tip where I might be look at?

thanks a lot

Posted : 26/09/2021 1:12 pm