Notifications
Clear all

[Solved] Default Flow  

  RSS
Kurmit
(@kurmit)
Active Member
Default Flow

I have the MK3S+  And I noticed the default flow rate on the printer itself is set to 95% I very rarely use this setting  because I would prefer to tune everything in my slicer  Not to say that I haven't used it Is there a reason that it is set to 95% and can I change it to  100%

Best Answer by sylviatrilling:

In PrusaSlicer: select 'Expert Mode'. Go to Printer Settings > Custom G-code and look at the topmost box which has the g-code that is inserted to execute before the start of the print. Find the line: 'M221 S{if layer_height<0.075}100{else}95{endif}' and either delete it or put a semi-colon in front of it which will turn it into a comment and make it not execute. This will take effect for every model you slice in PrusaSlicer. 

Posted : 21/01/2022 4:32 pm
sylviatrilling
(@sylviatrilling)
Honorable Member
RE: Default Flow

I'm not sure why this is in the custom gcode, but you can easily change it. In the custom g-code for starting a print  this is the line that sets it: M221 S{if layer_height<0.075}100{else}95{endif}

 

Mk3S+,SL1S

Posted : 21/01/2022 4:46 pm
Kurmit
(@kurmit)
Active Member
Topic starter answered:
RE: Default Flow

Is it in the G code or is it in the printer's firmware Every time I load a print I'm going to the tune menu it says 95% on the flow

Posted : 21/01/2022 4:54 pm
Kurmit
(@kurmit)
Active Member
Topic starter answered:
RE: Default Flow

And if I can simply change this in my G code can you show me where And what to change it to the only thing I have ever done to my G code was make my purge line longer

Posted : 21/01/2022 4:56 pm
sylviatrilling
(@sylviatrilling)
Honorable Member
RE: Default Flow

In PrusaSlicer: select 'Expert Mode'. Go to Printer Settings > Custom G-code and look at the topmost box which has the g-code that is inserted to execute before the start of the print. Find the line: 'M221 S{if layer_height<0.075}100{else}95{endif}' and either delete it or put a semi-colon in front of it which will turn it into a comment and make it not execute. This will take effect for every model you slice in PrusaSlicer. 

Mk3S+,SL1S

Posted : 21/01/2022 5:13 pm
Kurmit
(@kurmit)
Active Member
Topic starter answered:
RE:

 OK so when I go into my printer's tune settings on the physical printer itself the flow rate will be a 100%  Is after I remove said start g code line

Posted : 21/01/2022 5:16 pm
sylviatrilling
(@sylviatrilling)
Honorable Member
RE: Default Flow

Glad you asked that. You would most likely still get the 95% flow rate on your first print after changing the custom g-code because that setting would persist in the printer. You can change the flow rate to 100% from your LCD screen and then that setting will persist for future prints  and won't be changed back to 95% by the g-code from the slicer. 

Mk3S+,SL1S

Posted : 21/01/2022 5:24 pm
Kurmit liked
Kurmit
(@kurmit)
Active Member
Topic starter answered:
RE: Default Flow

That makes sense thanks again I will try this tonight and post an update

Posted : 21/01/2022 5:27 pm
Kurmit
(@kurmit)
Active Member
Topic starter answered:
RE: Default Flow

That makes sense thanks again I will try this tonight and post an update

Posted : 21/01/2022 5:27 pm
sylviatrilling
(@sylviatrilling)
Honorable Member
RE: Default Flow

I just thought of a better solution: Change that line to M221 S100

Then you will always start with the flow rate of 100 no matter what you did with it in the previous print. 

Mk3S+,SL1S

Posted : 21/01/2022 5:33 pm
Kurmit
(@kurmit)
Active Member
Topic starter answered:
RE: Default Flow

 thats an even better idea when I 1st started 3-D printing  My flow on the printer itself was always a 100% meaning it will print a 100% of what is on my slicer But I didn't know that right away now when I switched to the prusa it messed me up lol

Posted : 21/01/2022 5:40 pm
Kurmit
(@kurmit)
Active Member
Topic starter answered:
RE: Default Flow

Where it messes me up the most is some of my filament have different settings  Such as my wood filament or some metallic filament requires a little extra  Push and I like to change that in the extrusion multiplier  Rather than trying to remember to do it on the printer screen I got enough things to remember I don't want that to be one of them lol

Posted : 21/01/2022 6:15 pm
sylviatrilling
(@sylviatrilling)
Honorable Member
RE: Default Flow

I just happened to see an aswer as to why posted by Bobstro on another thread:

" I know Prusa added similar gcode way back when because Slic3r (on which PrusaSlicer is based) tended to over-extrude on higher (>0.1mm) layer heights."

Mk3S+,SL1S

Posted : 21/01/2022 7:46 pm
Kurmit liked
bobstro
(@bobstro)
Illustrious Member
RE:
Posted by: @kurmit

Where it messes me up the most is some of my filament have different settings  

As usual, @sylviatrilling has you on the right path. I have made a habit of always setting my flow rate to 100% at the start of my custom gcode. If you have created custom filament profiles with flow rate adjustments (and you should!) then these will be added by PrusaSlicer after your start gcode. That way, you can be sure gcode will use 100% flow rate unless you have specifically overridden that value in your filament profile.

I've got notes on the start gcode settings here, and flow rate settings and interaction here that might be useful.

 

Edit: One last note. Any printer adjustments made via the front panel menu or gcode are maintained until the printer is reset or power cycled. This can really screw you up if you make changes on the fly and is why I always reset such settings at the start of every print.

My notes and disclaimers on 3D printing

and miscellaneous other tech projects
He is intelligent, but not experienced. His pattern indicates two dimensional thinking. -- Spock in Star Trek: The Wrath of Khan

Posted : 21/01/2022 7:47 pm
Kurmit liked
Kurmit
(@kurmit)
Active Member
Topic starter answered:
RE: Default Flow

thanks everyone this solution worked, and im doing some more tests i shall return

Posted : 22/01/2022 12:17 am
Share: