Notifications
Clear all

Cycling power bricked my printer  

  RSS
christopher.s22
(@christopher-s22)
New Member
Cycling power bricked my printer

I have been printing for many months and have successfully updated the firmware of my mk3s a couple of times. Last night I was starting a print and it seemed to change to a different file in the "print from SD card" file list just as I hit the button. So I turned off power to the printer thinking I would power it back up and make sure I had the correct file selected. Now whenever the printer powers up it displays "Original Prusa i3 Prusa Research" and three dots in the lower right of the display. I can't get it to do anything else. If I press and hold the reset button the display starts filling with solid blocks; first the top row, then row 3, then row 2 and finally the bottom row. When I release the reset button it goes back to the "Original Prusa i3" display. I tried factory reset by pressing the reset and then immediately pressing the selector knob button but this does nothing. 

I connected my laptop to the printer and tried to reflash the firmware. The flash failed because it couldn't connect on COM8. I opened Pronterface and tried to connect. Com ports 1 & 3 fail immediately due to file not found (wrong COM port). Com port 8 says connecting and sits there. I opened the board case up and there is a yellow led that periodically flashes just below the USB port. I assume this is indicating activity on the USB port where the laptop is trying to connect to the board but the board does not seem to be responding.

Is there anything else I can try or is the board toast?

Posted : 07/02/2020 2:51 pm
rmm200
(@rmm200)
Noble Member
RE: Cycling power bricked my printer

Contact Support on Chat.

Click EShop above, log in, and shortly a Chat button will appear.

Support can step you through it.

Posted : 07/02/2020 4:36 pm
Share: