Clear all


New Member

So I'm having an issue (maybe 2?).
I sliced a mode, started the print and at about 90% of the first layer (takes up about 75% of the print bed) I received a "M112 called. Emergency Stop".
I canceled the print, restarted the printer, and started the print again. Same issue, exact same spot. 
Decided it might be something in the GCODE so I shrank the model just a bit and resliced. 
Before printing again I found that a firmware update was available. When processing the firmware upgrade (from 3.10.0 to 3.10.1) the firmware will install and then on the "verifying firmware install" It does this:

avrdude-slic3r: prusa_init_external_flash(): MK3 printer did not boot up on time or serial communication failed
avrdude-slic3r: arduino_open(): Failed to initialize MK3 external flash programming mode
avrdude-slic3r: Could not open port: COM4

The printer display only shows "Original Prusa i3 Prusa Research...", Fan speed seems to be maxed out and it just sits there like that. 
If I power it down and attempt to power it back up it will do the same thing. I let it sit for over an hour and it will then fully boot up. 
I attempt another firmware update and the same thing happens. 
I did this song and dance a few times and finally reached out to tech support. They jumped right to "Factory Reset" the printer.
I did a full "all" reset.
Same issues.
I WAS able to go through the calibration setup and print a test cube, but when I tried printing the other file I received the "M112" again. I reboot and then its stuck on the boot screen again. I turn it off, let it sit over night, come in this morning and again with the locked boot screen.

Does anyone have any ideas?

NOTES:. I use octoprint with a Raspberry Pi 3B+. All this testing/rebooting was done with the raspberry unplugged. Only when printing the Test Cube did I have the raspberry plugged in.
I've used 3 different USB cables (1 was brand new). 
I've tried both USB ports on my laptop. I also tried one of the firmware upgrade attempts right after a fresh reboot of the laptop.

Terminal export - GCODE

Firmware Fail - Firmware additional Details Export

That's all I can think of to help out. 


Posted : 13/01/2022 3:30 pm
New Member
Topic starter answered:
RE: Bootloop

So now the printer will not boot up at all. It's stuck on the boot screen. 
Doesn't matter if I leave it powered off overnight, or not...

Posted : 14/01/2022 3:42 pm