Clear all

Unable to heat the bed on mk2s  

New Member
Unable to heat the bed on mk2s

Few months back, my bed started giving me thermal runaway issue. On checking the motherboard and it's bed terminal connectors I found that the male connector has somewhat melted, so I replaced with new ones.

After few hours of printing with PLA and PETg, issue repeated. Hence, it checked the following

  • Connection between MOSFET Q5 drain and ground on multimeter continuity, it beeped.
  • Checked voltage between the bed +ve & -ve pins when heat command was passed and female connectors are connected, readings were 0V  and LED was off.
  • Removed the female connector and rechecked with the voltage, still 0V but LED glows solid. Measuring voltage between drain and bed+ve pin was 2.8V

On asking few experts, they asked to measure resistance across bed, which came out to be 0.9 ohms, which as per techie guy is normal so his call was "bed is not the issue, there must be something wrong with the board"

is there something wrong with the board? will it be repairable or do I need to replace it? 

Posted : 01/03/2021 4:32 am
New Member
RE: Unable to heat the bed on mk2s

I’m having exactly the same issue. Have you solved it and if so how?

Posted : 25/05/2022 9:45 pm
New Member
RE: Unable to heat the bed on mk2s

I replaced the melted connectors 2 or 3 times, as they kept melting, then gave up and soldered the heatbed wires directly onto the PCB. It seems that the connectors on Mk2 are inadequate for the bed current. Soldering the wires directly worked for me.

Posted : 25/05/2022 9:52 pm