XYZ calibration failed, consult manual. Belt stretch [SOLVED]
Clear all

[Solved] XYZ calibration failed, consult manual. Belt stretch [SOLVED]  

New Member
XYZ calibration failed, consult manual. Belt stretch [SOLVED]

Hi, just sharing here my experience of the last couple of days for the next unlucky guy.

My printer was working just fine, but I've decided to redo the calibration, as I was having issues with a particular print not sticking to the bed. Instead of just redoing a Z calibration, or first layer, I've decided to redo XYZ calibration, which resulted in the error "XYZ calibration failed, consult the manual" after the fourth point.

Well, that started my saga, as I tried:

  • Checked and double checked firmware version vs. model;
  • Downgrading firmware to 3.9, 3.8, 3.2;
  • Checked that PINDA was working, moved PINDA up and down;
  • Checked the perpendicularity of the X and Y, it was a little skewed before, got to 0.02º on my tests;
  • Factory reset;
  • Checked X/Y shift on the auto home position of PINDA, as, even noticing a little difference on autohome position on the 3.9.3 firmware, compared to older firmwares;
  • Tightened X belt, as the belt seemed a little lose;
  • Connected printer to PC and made the PINDA sensor testing, as in;
  • With the printer still connected with the computer and pronterface, made a XYZ calibration, which got the following results, after each point (yellow highlight on 0s  by me):
    • 2
    • 3
    • 4

What finally got me on the track of the trouble was that 2nd and 3rd image, with too much 0s on the right and the point shifted to the left. I started to think if the printer was passing the point, and why.

So I checked the translation of the extruder on the X axis: after autohome and with the PINDA over the calibration point, settings -> move axis -> X showed that it was on +12.0. After manually moving the extruder so the PINDA was over the second calibration point, the screen showed +215.0. Manually measuring the distance between the points showed a difference between the movement expected from the printer and the actual movement, with a margin of around +2%, or +5mm on the extension of the X axis between the points, and that's what was giving me the error on XYZ calibration.

Then I checked the belt, it was a replacement belt that I've switched about a year ago, and it seemed to show a little bit more of the inner iron than expected, got another new belt (luckily I've kept a few cms to spare) and compared (new on top):

It was misaligned! The belt was stretched, so I switched the belt, and the printer got to the correct position for the second point, and the XYZ calibration worked without an issue.

All of this made with the help of the prusa support team, even though it's already a granny printer.


XYZ failed even though printer was printing normally, all checks passed until found the belt was stretched, making the cartridge move 5mm more on the X axis. Replaced belt and calibration worked.

Posted : 16/02/2021 3:37 am