All axis calibrations just smash violently into the wall non stop
 
Notifications
Clear all

All axis calibrations just smash violently into the wall non stop  

Page 1 / 2
  RSS
engipup
(@engipup)
Active Member
All axis calibrations just smash violently into the wall non stop

I just built my printer, tested it with the normal firmware and everything was fine. I then put the 5.0.0 alpha4 firmware on and all the sudden any attempt to calibrate (before a print or manually calibrating) just lead to a violent shakey smashing on any axis. Reset and tried a few times. Had to downgrade the firmware again 🙁 Has anyone else had this issue?

Best Answer by Virgil:

Good News! I loaded the latest firmware https://forum.prusa3d.com/forum/input-shaping/5-0-0-rc-firmware-for-original-prusa-mk4/ and the smashing stopped!!!

Posted : 02/08/2023 2:43 am
engipup
(@engipup)
Active Member
Topic starter answered:
RE: All axis calibrations just smash violently into the wall non stop

nobody else? Is there something I can do to give logs or anything so I could get some help and can start using IS?

Posted : 03/08/2023 4:49 am
tollopa
(@tollopa)
New Member
RE: All axis calibrations just smash violently into the wall non stop

I have also just finished my MK4 kit and put alpha 4 on it but I do NOT have this issue.  

Posted : 03/08/2023 4:31 pm
Dave77
(@dave77)
Active Member
RE: All axis calibrations just smash violently into the wall non stop

Instead I had the same problem as engipup, I do not know why. With 4.7.2. all ok, but with alpha 4 not. Preassembled MK4 arrived 4th August.

Posted : 05/08/2023 9:20 pm
mattquist
(@mattquist)
Member
RE: All axis calibrations just smash violently into the wall non stop

I have the problem also.  Here is what I have found...

The printer is "smashing to try and home the axis when it is not matching what is stored in it's memory.  For example, I didn't tighten my bearings on my bed super tight and the higher speed of the MK4 over my MK3S caused them to move in their mounts from hitting the stops which enlarged the total Y axis travel over what it should of been.  This caused multiple re-tries by the printer to try and home to clear the fault.

I have also noticed that the Z axis seems to not report it's parking position to the firmware after completing a print; this means that the printer does not know the Z height of the printer when it goes to start the next print and causes crash errors repeatedly.  You can see this yourself if you hold down the button and manually move the Z height and look at the reported location; you can't lower the hotend to the bed because the firmware is reporting the location wrong.

 

Here's my work around:    If you manually grab the threaded rods and rotate them to move the hotend down to the bed and then start your print it will start perfectly because the startup script will find the bed height.  I think that this is a firmware problem that needs to be fixed with the Alpha 4 version (or at least that's the version that I'm using)

Hope this helps.

Posted : 06/08/2023 4:49 am
carlmmii liked
z0rlac
(@z0rlac)
Member
RE: All axis calibrations just smash violently into the wall non stop

I had this on the second day after I completed my MK4 kit build. Build was on 4.7.1, which worked fine, but I wanted to test IS and so upgraded to alpha4. Started a print and BRRRRR went the X-axis and it didnt stop... it just kept BRRRing, never finding home. I powered it off, downgraded to 4.7.2 and haven't tried alpha4 again since.

Posted : 12/08/2023 3:56 pm
SgtCaffran
(@sgtcaffran)
Active Member
RE: All axis calibrations just smash violently into the wall non stop

I have been running the IS alpha firmware since I run my printer two weeks ago. Homing works perfectly fine for me. Can it be that your printers are not setup perfectly? For example, position of bearings, tension of belts, etc.

Maybe the alpha firmware has some features that make these hardware differences come to light?

Posted : 12/08/2023 5:36 pm
z0rlac
(@z0rlac)
Member
RE: All axis calibrations just smash violently into the wall non stop

Maybe... I see there is a new v5 Release candidate to have a play with. Once my current print is done, I`ll update and see if that improves things for my specific printer

Posted : 12/08/2023 5:41 pm
Virgil
(@virgil)
Active Member
RE: All axis calibrations just smash violently into the wall non stop

I also had this issue. After building the MK4 kit I did have some issues with my z axis not passing the self test. It seems to be passing now with the original firmware. But I tried to load the IS firmware and at the beginning of a print it tried to home the x axis and it repeatedly crashed to the right. I hit the reset button and then tried to run the xyz self test and it crashed this time on the z axis at the top of the travel. 

Posted : 13/08/2023 1:08 am
Virgil
(@virgil)
Active Member
RE: All axis calibrations just smash violently into the wall non stop

Good News! I loaded the latest firmware https://forum.prusa3d.com/forum/input-shaping/5-0-0-rc-firmware-for-original-prusa-mk4/ and the smashing stopped!!!

Posted : 13/08/2023 2:05 pm
Virgil
(@virgil)
Active Member
RE: All axis calibrations just smash violently into the wall non stop

This seems to have been fixed and the issue went away for me when I installed the latest 5.0.0 RC firmware.

5.0.0-RC Firmware for Original Prusa MK4 – Input Shaper – Prusa3D Forum

Posted : 13/08/2023 2:07 pm
z0rlac
(@z0rlac)
Member
RE: All axis calibrations just smash violently into the wall non stop

Same for me, 5.00-RC fixed the x-axis crashing issue, and appears to be working fine now.

Posted : 14/08/2023 10:41 am
Antimix
(@antimix)
Reputable Member
RE: All axis calibrations just smash violently into the wall non stop

Lucky you, it seems someone else was not so lucky. The issue seems still random also in 5.0 RC as described here.

Posted : 18/08/2023 8:56 pm
engipup
(@engipup)
Active Member
Topic starter answered:
RE: All axis calibrations just smash violently into the wall non stop

I just loaded it up and it printed fine 🙂 I did notice a small bug but ill post about that in a different post. Thank you

Posted : 22/08/2023 5:39 pm
GreatOldOne
(@greatoldone-2)
Eminent Member
RE: All axis calibrations just smash violently into the wall non stop

I had been fine on 5.0.0 RC. No violent homing. Upgraded to the 5.0.0 general / “stable” release as on the firmware downloads page, and now it’s doing a head-banger impression on x & y. I lost count how many times it did it on the bed.

my machine is an upgraded 3s+, and worked fine on the previous 4.7.x firmware, and the RC. Not sure what to do here - it’s currently printed and looks ok. But as others have said, it’s a bit disturbing when it starts up - it’s like it’s trying to destroy itself.

https://www.printables.com/@GreatOldOne

Posted : 21/09/2023 10:25 am
Microtic liked
Karza
(@karza)
Active Member
RE: All axis calibrations just smash violently into the wall non stop

 

Posted by: @greatoldone-2

I had been fine on 5.0.0 RC. No violent homing. Upgraded to the 5.0.0 general / “stable” release as on the firmware downloads page, and now it’s doing a head-banger impression on x & y. I lost count how many times it did it on the bed.

my machine is an upgraded 3s+, and worked fine on the previous 4.7.x firmware, and the RC. Not sure what to do here - it’s currently printed and looks ok. But as others have said, it’s a bit disturbing when it starts up - it’s like it’s trying to destroy itself.

I see the same behaviour on my upgraded MK4 after flashing 5.0.0. That's not too bad though.

But I cannot use Octoprint anymore ( that IS bad ). If I start print from Octoprint, the Y-axis homing never ends. Its just keeps banging hard against the endstop until I hit reset. Printing via Octoprint worked OK with version 4.7.2.

Anyone else tried Octoprint with 5.0.0 ?

Posted : 21/09/2023 12:05 pm
GreatOldOne
(@greatoldone-2)
Eminent Member
RE: All axis calibrations just smash violently into the wall non stop

I’m running octoprint with 5.0.0 and its ok - they seem to be coexisting for me. And since posting my previous reply, I started another print. And it didn’t do it this time. Maybe it just needed to store new home positions? The print I experienced all the homing and banging was the first one after flashing the new firmware… 

https://www.printables.com/@GreatOldOne

Posted : 21/09/2023 12:49 pm
Karza
(@karza)
Active Member
RE:

Interesting... What printer setting did you slice with? I used "Original Prusa MK4 Input Shaper 0.4 nozzle" and "0.20mm SPEED @MK4IS 0.4"

Posted : 21/09/2023 2:08 pm
Rocrail
(@rocrail)
Active Member
RE: All axis calibrations just smash violently into the wall non stop

The final release of V5.0.0 does "All axis calibrations just smash violently into the wall non stop"...
I was afraid that my MK4 would break apart. :((

After reinstalling V4.7.2 everything was OK again.
I do not understand that this V5.0.0 version is published and pushed by email. For me the V5.0.0 is destructive...

 

Posted : 21/09/2023 4:05 pm
Karza
(@karza)
Active Member
RE:

 

Posted by: @rocrail

The final release of V5.0.0 does "All axis calibrations just smash violently into the wall non stop"...
I was afraid that my MK4 would break apart. :((

After reinstalling V4.7.2 everything was OK again.
I do not understand that this V5.0.0 version is published and pushed by email. For me the V5.0.0 is destructive...

 

I can print from SD, only five or so 'bangs' during Y-axis homing. 

Today I encountered another problem: Printer suddenly requested filament change mid print. Reported this to Github and there is at least one other user having the same issue.

Hoping to see bugfix release for 5.0 soon, not holding my breath though...

This post was modified 5 months ago by Karza
Posted : 21/09/2023 5:20 pm
Page 1 / 2
Share: